]> git.pld-linux.org Git - packages/ffms2.git/commitdiff
- fix building with ffmpeg 4.0 auto/th/ffms2-2.20-5
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 29 Apr 2018 07:44:18 +0000 (09:44 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 29 Apr 2018 07:44:18 +0000 (09:44 +0200)
- rel 5

ffmpeg4.patch [new file with mode: 0644]
ffms2.spec

diff --git a/ffmpeg4.patch b/ffmpeg4.patch
new file mode 100644 (file)
index 0000000..fa0c760
--- /dev/null
@@ -0,0 +1,31 @@
+--- ffms2-2.20/src/core/matroskareader.cpp~    2014-06-20 17:09:10.000000000 +0200
++++ ffms2-2.20/src/core/matroskareader.cpp     2018-04-29 09:42:31.607973790 +0200
+@@ -301,8 +301,8 @@
+ }
+ void MatroskaReaderContext::Append(const void *Data, size_t Length) {
+-      if (BufferSize < Length + FrameSize + FF_INPUT_BUFFER_PADDING_SIZE) {
+-              size_t NewSize = (FrameSize + Length) * 2 + FF_INPUT_BUFFER_PADDING_SIZE;
++      if (BufferSize < Length + FrameSize + AV_INPUT_BUFFER_PADDING_SIZE) {
++              size_t NewSize = (FrameSize + Length) * 2 + AV_INPUT_BUFFER_PADDING_SIZE;
+               safe_aligned_reallocz(Buffer, BufferSize, NewSize);
+               BufferSize = NewSize;
+       }
+@@ -340,5 +340,5 @@
+       }
+       if (FrameSize)
+-              memset(Buffer + FrameSize, 0, FF_INPUT_BUFFER_PADDING_SIZE);
++              memset(Buffer + FrameSize, 0, AV_INPUT_BUFFER_PADDING_SIZE);
+ }
+--- ffms2-2.20/src/core/utils.cpp~     2018-04-29 09:41:45.000000000 +0200
++++ ffms2-2.20/src/core/utils.cpp      2018-04-29 09:43:06.088381421 +0200
+@@ -173,7 +173,7 @@
+       // but I don't think anyone actually uses that.
+       if (PrivateDataSrc && PrivateDataSize > 0) {
+-              CodecContext->extradata = static_cast<uint8_t *>(av_mallocz(PrivateDataSize + FF_INPUT_BUFFER_PADDING_SIZE));
++              CodecContext->extradata = static_cast<uint8_t *>(av_mallocz(PrivateDataSize + AV_INPUT_BUFFER_PADDING_SIZE));
+               CodecContext->extradata_size = PrivateDataSize;
+               memcpy(CodecContext->extradata, PrivateDataSrc, PrivateDataSize);
+       }
index 0554728440f8ab96f0ebe8289b02070d8a0f8918..8e3fc46e2ae64a437c2fb6c244a5b9ee8d374584 100644 (file)
@@ -7,13 +7,14 @@ Summary:      FFmpegSource - FFmpeg wrapper library
 Summary(pl.UTF-8):     FFmpegSource - biblioteka obudowująca FFmpeg
 Name:          ffms2
 Version:       2.20
-Release:       4
+Release:       5
 License:       MIT (ffmpegsource itself), GPL v3+ (forced by ffmpeg)
 Group:         Libraries
 Source0:       https://github.com/FFMS/ffms2/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: d6f2faa9e0ffed2e2d8d926592a87744
 Patch0:                ffmpegsource-ffmpeg011.patch
 Patch1:                ffmpeg3.patch
+Patch2:                ffmpeg4.patch
 URL:           https://github.com/FFMS/ffms2
 BuildRequires: autoconf >= 2.58
 BuildRequires: automake >= 1:1.11
@@ -87,6 +88,7 @@ Statyczna biblioteka FFmpegSource.
 %setup -q
 %patch0 -p0
 %patch1 -p1
+%patch2 -p1
 %undos src/core/{indexing,lavfindexer,utils}.cpp
 %{__rm} configure
 
This page took 0.107378 seconds and 4 git commands to generate.