]> git.pld-linux.org Git - packages/ffms2.git/commitdiff
- up to 2.16 auto/th/ffmpegsource-2_16-1 auto/ti/ffmpegsource-2_16-1 ffmpegsource-2_16-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 13 Dec 2011 19:53:04 +0000 (19:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ffmpegsource-c++.patch -> 1.2
    ffmpegsource-ffmpeg-0.8.patch -> 1.2
    ffmpegsource.spec -> 1.7

ffmpegsource-c++.patch [deleted file]
ffmpegsource-ffmpeg-0.8.patch [deleted file]
ffmpegsource.spec

diff --git a/ffmpegsource-c++.patch b/ffmpegsource-c++.patch
deleted file mode 100644 (file)
index c7e67d5..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- ffmpegsource-2.15_src/src/core/utils.cpp.orig      2011-02-12 01:33:57.000000000 +0100
-+++ ffmpegsource-2.15_src/src/core/utils.cpp   2011-04-29 19:00:44.272480825 +0200
-@@ -230,7 +230,7 @@
- template<class T> static void safe_aligned_reallocz(T *&ptr, size_t old_size, size_t new_size) {
-       void *newalloc = av_mallocz(new_size);
-       if (newalloc) {
--              memcpy(newalloc, ptr, min(old_size, new_size));
-+              memcpy(newalloc, ptr, std::min(old_size, new_size));
-       }
-       av_free(ptr);
-       ptr = static_cast<T*>(newalloc);
diff --git a/ffmpegsource-ffmpeg-0.8.patch b/ffmpegsource-ffmpeg-0.8.patch
deleted file mode 100644 (file)
index ebc6bfb..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
---- ffmpegsource-2.15_src/src/core/indexing.cpp.orig   2011-02-10 01:17:44.000000000 +0100
-+++ ffmpegsource-2.15_src/src/core/indexing.cpp        2011-06-27 17:26:09.431750638 +0200
-@@ -27,7 +27,7 @@
- extern "C" {
--#include <libavutil/sha1.h>
-+#include <libavutil/sha.h>
- #include <zlib.h>
- }
-@@ -188,9 +188,9 @@
-                       std::string("Failed to open '") + Filename + "' for hashing");
-       std::vector<uint8_t> FileBuffer(1024*1024, 0);
--      std::vector<uint8_t> ctxmem(av_sha1_size);
--      AVSHA1 *ctx = (AVSHA1 *)(&ctxmem[0]);
--      av_sha1_init(ctx);
-+      std::vector<uint8_t> ctxmem(av_sha_size);
-+      AVSHA *ctx = (AVSHA *)(&ctxmem[0]);
-+      av_sha_init(ctx, 160);
-       try {
-               fread(&FileBuffer[0], 1, FileBuffer.size(), SFile);
-@@ -198,7 +198,7 @@
-                       throw FFMS_Exception(FFMS_ERROR_PARSER, FFMS_ERROR_FILE_READ,
-                               std::string("Failed to read '") + Filename + "' for hashing");
--              av_sha1_update(ctx, &FileBuffer[0], FileBuffer.size());
-+              av_sha_update(ctx, &FileBuffer[0], FileBuffer.size());
-               fseeko(SFile, -(int)FileBuffer.size(), SEEK_END);
-               std::fill(FileBuffer.begin(), FileBuffer.end(), 0);
-@@ -209,7 +209,7 @@
-                       throw FFMS_Exception(FFMS_ERROR_PARSER, FFMS_ERROR_FILE_READ, buf.str());
-               }
--              av_sha1_update(ctx, &FileBuffer[0], FileBuffer.size());
-+              av_sha_update(ctx, &FileBuffer[0], FileBuffer.size());
-               fseeko(SFile, 0, SEEK_END);
-               if (ferror(SFile))
-@@ -220,11 +220,11 @@
-       }
-       catch (...) {
-               fclose(SFile);
--              av_sha1_final(ctx, Digest);
-+              av_sha_final(ctx, Digest);
-               throw;
-       }
-       fclose(SFile);
--      av_sha1_final(ctx, Digest);
-+      av_sha_final(ctx, Digest);
- }
- void FFMS_Index::Sort() {
---- ffmpegsource-2.15_src/src/core/lavfindexer.cpp.orig        2011-01-21 21:58:09.000000000 +0100
-+++ ffmpegsource-2.15_src/src/core/lavfindexer.cpp     2011-06-27 17:45:31.855122896 +0200
-@@ -20,6 +20,9 @@
- #include "indexing.h"
-+extern "C" {
-+#include <libavutil/avutil.h>
-+}
- FFLAVFIndexer::FFLAVFIndexer(const char *Filename, AVFormatContext *FormatContext) : FFMS_Indexer(Filename) {
-@@ -49,7 +52,7 @@
-                       FormatContext->streams[i]->time_base.den,
-                       static_cast<FFMS_TrackType>(FormatContext->streams[i]->codec->codec_type)));
--              if (FormatContext->streams[i]->codec->codec_type == CODEC_TYPE_VIDEO) {
-+              if (FormatContext->streams[i]->codec->codec_type == AVMEDIA_TYPE_VIDEO) {
-                       AVCodec *VideoCodec = avcodec_find_decoder(FormatContext->streams[i]->codec->codec_id);
-                       if (!VideoCodec)
-                               throw FFMS_Exception(FFMS_ERROR_CODEC, FFMS_ERROR_UNSUPPORTED,
-@@ -65,7 +68,7 @@
-                               VideoContexts[i].Parser->flags = PARSER_FLAG_COMPLETE_FRAMES;
-                       IndexMask |= 1 << i;
-               }
--              else if (IndexMask & (1 << i) && FormatContext->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO) {
-+              else if (IndexMask & (1 << i) && FormatContext->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO) {
-                       AVCodecContext *AudioCodecContext = FormatContext->streams[i]->codec;
-                       AVCodec *AudioCodec = avcodec_find_decoder(AudioCodecContext->codec_id);
-@@ -105,7 +108,7 @@
-               bool KeyFrame = !!(Packet.flags & AV_PKT_FLAG_KEY);
-               ReadTS(Packet, LastValidTS[Track], (*TrackIndices)[Track].UseDTS);
--              if (FormatContext->streams[Track]->codec->codec_type == CODEC_TYPE_VIDEO) {
-+              if (FormatContext->streams[Track]->codec->codec_type == AVMEDIA_TYPE_VIDEO) {
-                       if (LastValidTS[Track] == ffms_av_nopts_value)
-                               throw FFMS_Exception(FFMS_ERROR_INDEXING, FFMS_ERROR_PARSER,
-                               "Invalid initial pts and dts");
-@@ -121,7 +124,7 @@
-                       (*TrackIndices)[Track].push_back(TFrameInfo::VideoFrameInfo(LastValidTS[Track], RepeatPict, KeyFrame, Packet.pos));
-               }
--              else if (FormatContext->streams[Track]->codec->codec_type == CODEC_TYPE_AUDIO) {
-+              else if (FormatContext->streams[Track]->codec->codec_type == AVMEDIA_TYPE_AUDIO) {
-                       int64_t StartSample = AudioContexts[Track].CurrentSample;
-                       int64_t SampleCount = IndexAudioPacket(Track, &Packet, AudioContexts[Track], *TrackIndices);
index 53549151cbd6bd1d0ecb89bc3fc3664f7f1ae635..0f3ed99b80e9c082d016ea820089fcc58f467679 100644 (file)
@@ -1,15 +1,13 @@
 Summary:       FFmpegSource - FFmpeg wrapper library
 Summary(pl.UTF-8):     FFmpegSource - biblioteka obudowująca FFmpeg
 Name:          ffmpegsource
-Version:       2.15
-Release:       4
+Version:       2.16
+Release:       1
 License:       MIT (ffmpegsource itself), GPL v3+ (forced by ffmpeg)
 Group:         Libraries
 #Source0Download: http://code.google.com/p/ffmpegsource/downloads/list
-Source0:       http://ffmpegsource.googlecode.com/files/%{name}-%{version}_src.7z
-# Source0-md5: 0d0e2d4f6c4424e5f182f40f451c064e
-Patch0:                %{name}-c++.patch
-Patch1:                %{name}-ffmpeg-0.8.patch
+Source0:       http://ffmpegsource.googlecode.com/files/ffms-%{version}-src.tar.bz2
+# Source0-md5: de5d8a4ba7b9920fa5cc290b012bbbf0
 URL:           http://code.google.com/p/ffmpegsource/
 BuildRequires: autoconf >= 2.58
 BuildRequires: automake
@@ -70,11 +68,8 @@ Static FFmpegSource library.
 Statyczna biblioteka FFmpegSource.
 
 %prep
-%setup -q -c -T -n %{name}-%{version}_src
-7z -o.. x %{SOURCE0}
+%setup -q -n ffms-%{version}-src
 %undos src/core/{indexing,lavfindexer,utils}.cpp
-%patch0 -p1
-%patch1 -p1
 %{__rm} configure
 
 %build
@@ -84,7 +79,8 @@ Statyczna biblioteka FFmpegSource.
 %{__autoheader}
 %{__automake}
 %configure \
-       --enable-shared
+       --enable-shared \
+       --enable-postproc
 %{__make} \
        V=1
 
This page took 0.107795 seconds and 4 git commands to generate.