]> git.pld-linux.org Git - packages/ffmpeg.git/commitdiff
up to 4.4.1 auto/th/ffmpeg-4.4.1-1
authorJan Palus <atler@pld-linux.org>
Mon, 29 Nov 2021 11:39:58 +0000 (12:39 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 29 Nov 2021 11:39:58 +0000 (12:39 +0100)
ffmpeg.spec
v4l2-request-hwdec.patch

index 1467e04ba2fdc943098e992f56afaa064d8dc53f..affb686d102b064427cab873b3d3b2e6fa52b404 100644 (file)
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       4.4
-Release:       5
+Version:       4.4.1
+Release:       1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # GPL: frei0r libcdio libdavs2 rubberband vidstab x264 x265 xavs xavs2 xvid
 # v3 (allows *GPLv3 or Apache-licensed libs): gmp lensfun opencore-amr vmaf vo-*enc rkmpp
@@ -125,7 +125,7 @@ Release:    5
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       https://ffmpeg.org/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 7b9d5b652d20e8c5405304ad72636d4a
+# Source0-md5: 41a1ca8693acc56088e8eaf3899b91ea
 Patch0:                %{name}-omx-libnames.patch
 Patch1:                %{name}-atadenoise.patch
 Patch2:                opencv4.patch
index ee7acab71d217776a5fa3e7b6b0d61acd1eeb6ce..bac2e9b96ae172e14c7e58562380da6bb9479906 100644 (file)
@@ -1262,8 +1262,8 @@ index db8363e4cc98..a19635a23d44 100644
 -        get_ue_golomb_long(&sl->gb); /* idr_pic_id */
 +        sl->idr_pic_id = get_ue_golomb_long(&sl->gb);
  
-     if (sps->poc_type == 0) {
-         sl->poc_lsb = get_bits(&sl->gb, sps->log2_max_poc_lsb);
+     sl->poc_lsb = 0;
+     sl->delta_poc_bottom = 0;
 diff --git a/libavcodec/h264dec.h b/libavcodec/h264dec.h
 index a419615124b2..316dc6a2c890 100644
 --- a/libavcodec/h264dec.h
@@ -1309,9 +1309,9 @@ index a19635a23d44..5a5ceb09352c 100644
          sl->idr_pic_id = get_ue_golomb_long(&sl->gb);
  
 +    pos = sl->gb.index;
+     sl->poc_lsb = 0;
+     sl->delta_poc_bottom = 0;
      if (sps->poc_type == 0) {
-         sl->poc_lsb = get_bits(&sl->gb, sps->log2_max_poc_lsb);
 @@ -1833,6 +1834,7 @@ static int h264_slice_header_parse(const H264Context *h, H264SliceContext *sl,
          if (pps->pic_order_present == 1 && picture_structure == PICT_FRAME)
              sl->delta_poc[1] = get_se_golomb(&sl->gb);
This page took 0.226077 seconds and 4 git commands to generate.