]> git.pld-linux.org Git - packages/ffmpeg.git/commitdiff
- added kvazaar patch (update to kvazaar 0.7.x API), enable kvazaar support
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 15 Oct 2015 15:46:09 +0000 (17:46 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 15 Oct 2015 15:46:35 +0000 (17:46 +0200)
- enable snappy support

ffmpeg-kvazaar.patch [new file with mode: 0644]
ffmpeg.spec

diff --git a/ffmpeg-kvazaar.patch b/ffmpeg-kvazaar.patch
new file mode 100644 (file)
index 0000000..374809d
--- /dev/null
@@ -0,0 +1,11 @@
+--- ffmpeg-2.8/libavcodec/libkvazaar.c.orig    2015-09-09 03:17:45.000000000 +0200
++++ ffmpeg-2.8/libavcodec/libkvazaar.c 2015-10-15 16:14:57.344277118 +0200
+@@ -173,7 +173,7 @@
+         }
+     }
+-    if (!ctx->api->encoder_encode(ctx->encoder, img_in, &data_out, &len_out, NULL)) {
++    if (!ctx->api->encoder_encode(ctx->encoder, img_in, &data_out, &len_out, NULL, NULL, NULL)) {
+         av_log(avctx, AV_LOG_ERROR, "Failed to encode frame.\n");
+         retval = AVERROR_EXTERNAL;
+         goto done;
index 397f94a4f841261cb59322734483fc8d5e679894..35acdb2eec8ed83303b8048c3d170358c9d01c75 100644 (file)
@@ -19,6 +19,7 @@
 %bcond_without fribidi         # fribidi support
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
 %bcond_without fribidi         # fribidi support
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
+%bcond_without kvazaar         # Kvazaar HEVC encoder support
 %bcond_without ladspa          # LADSPA audio filtering
 %bcond_with    mfx             # MFX hardware acceleration support
 %bcond_with    nvenc           # NVIDIA NVENC support (requires nonfree)
 %bcond_without ladspa          # LADSPA audio filtering
 %bcond_with    mfx             # MFX hardware acceleration support
 %bcond_with    nvenc           # NVIDIA NVENC support (requires nonfree)
@@ -30,6 +31,7 @@
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
 %bcond_without shine           # shine fixed-point MP3 encoder
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
 %bcond_without shine           # shine fixed-point MP3 encoder
+%bcond_without snappy          # Snappy compression support (needed for hap encoding)
 %bcond_without ssh             # SFTP protocol support via libssh
 %bcond_with    smb             # SMB support via libsmbclient
 %bcond_without soxr            # SoX Resampler support
 %bcond_without ssh             # SFTP protocol support via libssh
 %bcond_with    smb             # SMB support via libsmbclient
 %bcond_without soxr            # SoX Resampler support
@@ -71,6 +73,7 @@ Source0:      http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
+Patch0:                %{name}-kvazaar.patch
 URL:           http://www.ffmpeg.org/
 %{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
 URL:           http://www.ffmpeg.org/
 %{?with_decklink:BuildRequires:        Blackmagic_DeckLink_SDK}
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
@@ -96,6 +99,7 @@ BuildRequires:        gcc >= 5:3.3.2-3
 BuildRequires: gmp-devel
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
 BuildRequires: gmp-devel
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
+%{?with_kvazaar:BuildRequires: kvazaar-devel >= 0.7}
 %{?with_ladspa:BuildRequires:  ladspa-devel}
 BuildRequires: lame-libs-devel >= 3.98.3
 %{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
 %{?with_ladspa:BuildRequires:  ladspa-devel}
 BuildRequires: lame-libs-devel >= 3.98.3
 %{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
@@ -149,6 +153,7 @@ BuildRequires:      pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: schroedinger-devel
 %{?with_shine:BuildRequires:   shine-devel >= 3.0.0}
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: schroedinger-devel
 %{?with_shine:BuildRequires:   shine-devel >= 3.0.0}
+%{?with_snappy:BuildRequires:  snappy-devel}
 %{?with_soxr:BuildRequires:    soxr-devel}
 BuildRequires: speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     tetex}
 %{?with_soxr:BuildRequires:    soxr-devel}
 BuildRequires: speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     tetex}
@@ -251,6 +256,7 @@ Requires:   freetype-devel
 %{?with_fribidi:Requires:      fribidi-devel}
 %{?with_gme:Requires:  game-music-emu-devel}
 Requires:      jack-audio-connection-kit-devel
 %{?with_fribidi:Requires:      fribidi-devel}
 %{?with_gme:Requires:  game-music-emu-devel}
 Requires:      jack-audio-connection-kit-devel
+%{?with_kvazaar:Requires:      kvazaar-devel >= 0.7}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
@@ -282,6 +288,7 @@ Requires:   opencore-amr-devel
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 %{?with_shine:Requires:        shine-devel >= 3.0.0}
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 %{?with_shine:Requires:        shine-devel >= 3.0.0}
+%{?with_snappy:Requires:       snappy-devel}
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
@@ -370,6 +377,7 @@ Dokumentacja pakietu FFmpeg w formacie HTML.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
+%patch0 -p1
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
@@ -476,6 +484,7 @@ EOF
        --enable-libgsm \
        --enable-libiec61883 \
        %{?with_ilbc:--enable-libilbc} \
        --enable-libgsm \
        --enable-libiec61883 \
        %{?with_ilbc:--enable-libilbc} \
+       %{?with_kvazaar:--enable-libkvazaar} \
        %{?with_mfx:--enable-libmfx} \
        --enable-libmodplug \
        --enable-libmp3lame \
        %{?with_mfx:--enable-libmfx} \
        --enable-libmodplug \
        --enable-libmp3lame \
@@ -492,6 +501,7 @@ EOF
        --enable-libschroedinger \
        %{?with_shine:--enable-libshine} \
        %{?with_smb:--enable-libsmbclient} \
        --enable-libschroedinger \
        %{?with_shine:--enable-libshine} \
        %{?with_smb:--enable-libsmbclient} \
+       %{?with_snappy:--enable-libsnappy} \
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
        %{?with_ssh:--enable-libssh} \
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
        %{?with_ssh:--enable-libssh} \
This page took 0.22957 seconds and 4 git commands to generate.