]> git.pld-linux.org Git - packages/ffmpeg.git/commitdiff
- updated to 0.10 (note: new libpostproc soname)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Jan 2012 07:19:58 +0000 (07:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- avconv has been merged into ffmpeg

Changed files:
    ffmpeg-bug-803.patch -> 1.3
    ffmpeg-gsm.patch -> 1.4
    ffmpeg.spec -> 1.241

ffmpeg-bug-803.patch
ffmpeg-gsm.patch
ffmpeg.spec

index 72d4833deb1db17de564a4d90739770e0aef8a3a..35addb2cf4eed93350c4c9974b9e1da583e7a621 100644 (file)
@@ -1,6 +1,6 @@
---- ffmpeg-0.8/libavcodec/libmp3lame.c.orig    2011-06-21 21:29:25.000000000 +0200
-+++ ffmpeg-0.8/libavcodec/libmp3lame.c 2011-06-26 17:35:11.772209142 +0200
-@@ -35,6 +35,7 @@
+--- ffmpeg-0.10/libavcodec/libmp3lame.c.orig   2012-01-26 23:15:59.000000000 +0100
++++ ffmpeg-0.10/libavcodec/libmp3lame.c        2012-01-27 17:53:34.901932031 +0100
+@@ -38,6 +38,7 @@
      int stereo;
      uint8_t buffer[BUFFER_SIZE];
      int buffer_index;
@@ -8,10 +8,10 @@
      struct {
          int *left;
          int *right;
-@@ -169,11 +170,16 @@
+@@ -181,11 +182,16 @@
      /* lame 3.91 dies on '1-channel interleaved' data */
  
-     if(!data){
+     if (!data){
 +      if(s->flushed)
 +          lame_result = 0;
 +      else {
@@ -25,7 +25,7 @@
  #if 2147483647 == INT_MAX
      }else if(AV_SAMPLE_FMT_S32 == avctx->sample_fmt){
          if (s->stereo) {
-@@ -205,6 +211,7 @@
+@@ -217,6 +223,7 @@
                  BUFFER_SIZE - s->buffer_index
                  );
          }
  #endif
      }else{
          if (s->stereo) {
-@@ -225,6 +232,7 @@
+@@ -237,6 +244,7 @@
                  BUFFER_SIZE - s->buffer_index
                  );
          }
 +      s->flushed = 0;
      }
  
-     if(lame_result < 0){
+     if (lame_result < 0) {
index caff5e8ea49ef11fb4306b01f44e4e8763da4529..c62b28710b450bc9a2740ee9cbcd99abc9df84b4 100644 (file)
@@ -1,5 +1,5 @@
---- configure.orig     2011-06-21 21:29:25.000000000 +0200
-+++ configure  2011-06-26 20:07:17.579181375 +0200
+--- ffmpeg-0.10/configure.orig 2011-06-21 21:29:25.000000000 +0200
++++ ffmpeg-0.10/configure      2011-06-26 20:07:17.579181375 +0200
 @@ -3071,7 +3071,7 @@
      "dirac_decoder_init dirac_encoder_init"
  enabled libfaac    && require2 libfaac "stdint.h faac.h" faacEncGetVersion -lfaac
@@ -9,14 +9,14 @@
  enabled libmodplug && require  libmodplug libmodplug/modplug.h ModPlug_Load -lmodplug
  enabled libmp3lame && require  "libmp3lame >= 3.98.3" lame/lame.h lame_set_VBR_quality -lmp3lame
  enabled libnut     && require  libnut libnut.h nut_demuxer_init -lnut
---- libavcodec/libgsm.c~       2010-04-20 16:45:34.000000000 +0200
-+++ libavcodec/libgsm.c        2010-06-18 08:05:19.692574999 +0200
-@@ -28,7 +28,7 @@
+--- ffmpeg-0.10/libavcodec/libgsm.c.orig       2012-01-26 23:15:59.000000000 +0100
++++ ffmpeg-0.10/libavcodec/libgsm.c    2012-01-27 17:58:28.495275196 +0100
+@@ -27,7 +27,7 @@
  // The idiosyncrasies of GSM-in-WAV are explained at http://kbs.cs.tu-berlin.de/~jutta/toast.html
  
- #include "avcodec.h"
 -#include <gsm/gsm.h>
 +#include <gsm.h>
  
- // gsm.h misses some essential constants
- #define GSM_BLOCK_SIZE 33
+ #include "avcodec.h"
+ #include "gsm.h"
index ecef37dd0c9158dcdf39a08eeeb641ee9eecd41a..7aca03dc6eca4ab8ff0bba040b4a760effe6caaa 100644 (file)
@@ -25,7 +25,7 @@
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       0.9.1
+Version:       0.10
 Release:       1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
@@ -33,7 +33,7 @@ Release:      1
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 41ae6cfdef81a54835b914f523e575cf
+# Source0-md5: dc665cc599a739e3c5262ccdac13d129
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -246,7 +246,7 @@ dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p0
+%patch1 -p1
 
 # package the grep result for mplayer, the result formatted as ./mplayer/configure
 cat <<EOF > ffmpeg-avconfig
@@ -317,7 +317,6 @@ EOF
        --disable-debug \
        --disable-optimizations \
        --disable-stripping \
-       --enable-avconv \
        --enable-avfilter \
        --enable-gnutls \
        --enable-gpl \
@@ -442,13 +441,12 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
-%attr(755,root,root) %{_bindir}/avconv
 %attr(755,root,root) %{_bindir}/ffmpeg
 %attr(755,root,root) %{_bindir}/ffprobe
 %attr(755,root,root) %{_bindir}/qt-faststart
 %dir %{_datadir}/ffmpeg
 %{_datadir}/ffmpeg/*.ffpreset
-%{?with_doc:%{_mandir}/man1/avconv.1*}
+%{_datadir}/ffmpeg/ffprobe.xsd
 %{?with_doc:%{_mandir}/man1/ffmpeg.1*}
 %{?with_doc:%{_mandir}/man1/ffprobe.1*}
 
@@ -465,7 +463,7 @@ fi
 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.51
+%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
This page took 0.043518 seconds and 4 git commands to generate.