]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- removed BR libstdc++-devel (it was caused by SDL, which has been fixed now)
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 # _without_imlib        - we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.8
9 Release:        2
10 License:        LGPL/GPL
11 Group:          Daemons
12 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}.tar.gz
13 # Source0-md5:  e00d47614ba1afd99ad2ea387e782dd9
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 URL:            http://ffmpeg.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  freetype-devel
20 %{!?_without_imlib:BuildRequires:       imlib2-devel >= 1.1.0-2}
21 BuildRequires:  libtool >= 2:1.4d-3
22 %ifarch i586 i686 athlon
23 BuildRequires:  nasm
24 %endif
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
29
30 %description
31 ffmpeg is a hyper fast realtime audio/video encoder and streaming
32 server. It can grab from a standard Video4Linux video source and
33 convert it into several file formats based on DCT/motion compensation
34 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
35 compatible stream.
36
37 This package contains also ffmpeg shared libraries (libavcodec and
38 libavformat).
39
40 %description -l pl
41 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
42 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
43 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
44 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
45 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
46 strumienia kompatybilnego z AC3.
47
48 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
49 libavformat).
50
51 %package ffplay
52 Summary:        FFplay - SDL-based media player
53 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
54 Group:          Applications/Multimedia
55 Requires:       %{name} = %{version}
56
57 %description ffplay
58 FFplay is a very simple and portable media player using the FFmpeg
59 libraries and the SDL library. It is mostly used as a test bench for
60 the various APIs of FFmpeg.
61
62 %description ffplay -l pl
63 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
64 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
65 testowania ró¿nych API FFmpeg.
66
67 %package vhook-imlib2
68 Summary:        imlib2 based hook
69 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
70 Group:          Libraries
71 Requires:       %{name} = %{version}
72
73 %description vhook-imlib2
74 This module implements a text overlay for a video image. Currently it
75 supports a fixed overlay or reading the text from a file. The string
76 is passed through strftime so that it is easy to imprint the date and
77 time onto the image.
78
79 %description vhook-imlib2 -l pl
80 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
81 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
82 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
83 obrazie.
84
85 %package devel
86 Summary:        ffmpeg header files
87 Summary(pl):    Pliki nag³ówkowe ffmpeg
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}
90
91 %description devel
92 ffmpeg header files.
93
94 %description devel -l pl
95 Pliki nag³ówkowe ffmpeg.
96
97 %package static
98 Summary:        ffmpeg static libraries
99 Summary(pl):    Statyczne biblioteki ffmpeg
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}
102
103 %description static
104 ffmpeg static libraries (libavcodec and libavformat).
105
106 %description static -l pl
107 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114
115 %build
116 # notes:
117 # - it's not autoconf configure
118 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
119 #   (-fPIC takes one)
120 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
121 # - [temporary!!!] altivec disabled because of gcc 3.3.x bug target/11793
122 ./configure \
123         --prefix=%{_prefix} \
124         --mandir=%{_mandir} \
125         --enable-shared \
126         --enable-a52bin \
127         --enable-faadbin \
128 %ifnarch i586 i686 athlon
129         --disable-mmx \
130 %endif
131 %ifarch ppc
132         --disable-altivec \
133 %endif
134         --cc="%{__cc}" \
135         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
136         --extra-ldflags="%{rpmldflags}" \
137         --disable-debug \
138         --disable-opts \
139         --tune=generic
140
141 %{__make}
142
143 %{__make} -C doc
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
153 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc Changelog README doc/*.html
164 %attr(755,root,root) %{_bindir}/ffmpeg
165 %attr(755,root,root) %{_sbindir}/ffserver
166 %attr(755,root,root) %{_libdir}/libavcodec-*.so
167 %attr(755,root,root) %{_libdir}/libavformat-*.so
168 %dir %{_libdir}/vhook
169 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
170 %attr(755,root,root) %{_libdir}/vhook/fish.so
171 %attr(755,root,root) %{_libdir}/vhook/null.so
172 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
173 %{_mandir}/man1/ffmpeg.1*
174 %{_mandir}/man1/ffserver.1*
175
176 %files ffplay
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/ffplay
179 %{_mandir}/man1/ffplay.1*
180
181 %if %{!?_without_imlib:1}0
182 %files vhook-imlib2
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
185 %endif
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libavcodec.so
190 %attr(755,root,root) %{_libdir}/libavformat.so
191 %{_libdir}/lib*.la
192 %{_includedir}/ffmpeg
193
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/lib*.a
This page took 0.562612 seconds and 4 git commands to generate.