]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- fix .pc versioning ("CVS-" -> "49CVS-$build").
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 %bcond_with     gcc4            # disable long inline mmx assembly.
6                                 # gcc4+ doesn't like hard register pressure and won't be fixed.
7                                 # ffmpeg and other apps should be rewritten with <mmintrin.h>.
8 #
9 Summary:        Realtime audio/video encoder and streaming server
10 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
11 Name:           ffmpeg
12 Version:        0.4.9
13 %define snap    20050806
14 Release:        3.%{snap}.5
15 # LGPL or GPL, chosen at configure time (GPL version is more featured)
16 License:        GPL
17 Group:          Daemons
18 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
19 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
20 # Source0-md5:  f5ea3dd877c5df5b60356053642cf542
21 Patch0:         %{name}-libtool.patch
22 Patch1:         %{name}-libdir.patch
23 Patch2:         %{name}-pkgconfig-version.patch
24 URL:            http://ffmpeg.sourceforge.net/
25 BuildRequires:  SDL-devel
26 BuildRequires:  faac-devel
27 BuildRequires:  freetype-devel
28 %ifarch ppc
29 # require version with altivec support fixed
30 BuildRequires:  gcc >= 5:3.3.2-3
31 %endif
32 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
33 BuildRequires:  lame-libs-devel
34 BuildRequires:  libtheora-devel
35 BuildRequires:  libtool >= 2:1.4d-3
36 BuildRequires:  libvorbis-devel
37 %ifarch %{ix86}
38 %ifnarch i386 i486
39 BuildRequires:  nasm
40 %endif
41 %endif
42 BuildRequires:  perl-tools-pod
43 BuildRequires:  tetex
44 BuildRequires:  texinfo
45 BuildRequires:  xvid-devel
46 BuildRequires:  zlib-devel
47 %{?with_autoreqdep:BuildConflicts:      libpostproc}
48 Obsoletes:      libpostproc
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
52
53 %description
54 ffmpeg is a hyper fast realtime audio/video encoder and streaming
55 server. It can grab from a standard Video4Linux video source and
56 convert it into several file formats based on DCT/motion compensation
57 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
58 compatible stream.
59
60 This package contains also ffmpeg shared libraries (libavcodec and
61 libavformat).
62
63 %description -l pl
64 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
65 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
66 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
67 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
68 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
69 strumienia kompatybilnego z AC3.
70
71 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
72 libavformat).
73
74 %package devel
75 Summary:        ffmpeg header files
76 Summary(pl):    Pliki nag³ówkowe ffmpeg
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Obsoletes:      libpostproc-devel
80 # for libavcodec:
81 Requires:       faac-devel
82 Requires:       lame-libs-devel
83 Requires:       libtheora-devel
84 Requires:       libvorbis-devel
85 Requires:       xvid-devel
86 Requires:       zlib-devel
87
88 %description devel
89 ffmpeg header files.
90
91 %description devel -l pl
92 Pliki nag³ówkowe ffmpeg.
93
94 %package static
95 Summary:        ffmpeg static libraries
96 Summary(pl):    Statyczne biblioteki ffmpeg
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 ffmpeg static libraries (libavcodec and libavformat).
102
103 %description static -l pl
104 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
105
106 %package ffplay
107 Summary:        FFplay - SDL-based media player
108 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
109 Group:          Applications/Multimedia
110 Requires:       %{name} = %{version}-%{release}
111
112 %description ffplay
113 FFplay is a very simple and portable media player using the FFmpeg
114 libraries and the SDL library. It is mostly used as a test bench for
115 the various APIs of FFmpeg.
116
117 %description ffplay -l pl
118 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
119 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
120 testowania ró¿nych API FFmpeg.
121
122 %package vhook-imlib2
123 Summary:        imlib2 based hook
124 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
125 Group:          Libraries
126 Requires:       %{name} = %{version}-%{release}
127
128 %description vhook-imlib2
129 This module implements a text overlay for a video image. Currently it
130 supports a fixed overlay or reading the text from a file. The string
131 is passed through strftime so that it is easy to imprint the date and
132 time onto the image.
133
134 %description vhook-imlib2 -l pl
135 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
136 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
137 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
138 obrazie.
139
140 %prep
141 %setup -q -n FFMpeg-%{snap}
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145
146 %build
147 # notes:
148 # - it's not autoconf configure
149 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
150 #   (-fPIC takes one)
151 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
152 ./configure \
153         --prefix=%{_prefix} \
154         --libdir=%{_libdir} \
155         --mandir=%{_mandir} \
156         --disable-strip \
157         --enable-a52 \
158         --enable-faac \
159         --enable-faadbin \
160         --enable-gpl \
161         --enable-libogg \
162         --enable-mp3lame \
163         --enable-pp \
164         --enable-pthreads \
165         --enable-shared \
166         --enable-shared-pp \
167         --enable-theora \
168         --enable-vorbis \
169         --enable-xvid \
170 %if %{without gcc4}
171 %ifnarch %{ix86}
172         --disable-mmx \
173 %endif
174 %ifarch i386 i486
175         --disable-mmx \
176 %endif
177 %else
178         --disable-mmx \
179 %endif
180         --cc="%{__cc}" \
181         --extra-cflags="%{rpmcflags} -fomit-frame-pointer -fno-strict-aliasing" \
182         --extra-ldflags="%{rpmldflags}" \
183         --disable-debug \
184         --disable-opts \
185         --tune=generic
186
187 %{__make} \
188         BUILD_DOC=yes \
189         LIBVERSION=%{snap}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
194
195 %{__make} install \
196         DESTDIR=$RPM_BUILD_ROOT
197
198 install xvmc_render.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
199
200 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
201 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post   -p /sbin/ldconfig
207 %postun -p /sbin/ldconfig
208
209 %files
210 %defattr(644,root,root,755)
211 %doc Changelog README doc/*.html
212 %attr(755,root,root) %{_bindir}/ffmpeg
213 %attr(755,root,root) %{_sbindir}/ffserver
214 %attr(755,root,root) %{_libdir}/libavcodec-*.so
215 %attr(755,root,root) %{_libdir}/libavformat-*.so
216 %attr(755,root,root) %{_libdir}/libavutil-*.so
217 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
218 %dir %{_libdir}/vhook
219 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
220 %attr(755,root,root) %{_libdir}/vhook/fish.so
221 %attr(755,root,root) %{_libdir}/vhook/null.so
222 %attr(755,root,root) %{_libdir}/vhook/ppm.so
223 %attr(755,root,root) %{_libdir}/vhook/watermark.so
224 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
225 %{_mandir}/man1/ffmpeg.1*
226 %{_mandir}/man1/ffserver.1*
227
228 %files devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libavcodec.so
231 %attr(755,root,root) %{_libdir}/libavformat.so
232 %attr(755,root,root) %{_libdir}/libavutil.so
233 %attr(755,root,root) %{_libdir}/libpostproc.so
234 %{_libdir}/lib*.la
235 %{_includedir}/ffmpeg
236 %{_includedir}/postproc
237 %{_pkgconfigdir}/*.pc
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/lib*.a
242
243 %files ffplay
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_bindir}/ffplay
246 %{_mandir}/man1/ffplay.1*
247
248 %if %{with imlib2}
249 %files vhook-imlib2
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
252 %endif
This page took 0.041034 seconds and 4 git commands to generate.