]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- fixed a52, it was never working, as a52bin is not active without a52; a52bin
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 %bcond_with     gcc4            # disable long inline mmx assembly.
6                                 # gcc4+ doesn't like hard register pressure and won't be fixed.
7                                 # ffmpeg and other apps should be rewritten with <mmintrin.h>.
8 #
9 Summary:        Realtime audio/video encoder and streaming server
10 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
11 Name:           ffmpeg
12 Version:        0.4.9
13 %define snap    20050806
14 Release:        3.%{snap}.3
15 # LGPL or GPL, chosen at configure time (GPL version is more featured)
16 License:        GPL
17 Group:          Daemons
18 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
19 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
20 # Source0-md5:  f5ea3dd877c5df5b60356053642cf542
21 Patch0:         %{name}-libtool.patch
22 Patch1:         %{name}-libdir.patch
23 URL:            http://ffmpeg.sourceforge.net/
24 BuildRequires:  SDL-devel
25 BuildRequires:  faac-devel
26 BuildRequires:  freetype-devel
27 %ifarch ppc
28 # require version with altivec support fixed
29 BuildRequires:  gcc >= 5:3.3.2-3
30 %endif
31 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
32 BuildRequires:  lame-libs-devel
33 BuildRequires:  libtheora-devel
34 BuildRequires:  libtool >= 2:1.4d-3
35 BuildRequires:  libvorbis-devel
36 %ifarch %{ix86}
37 %ifnarch i386 i486
38 BuildRequires:  nasm
39 %endif
40 %endif
41 BuildRequires:  perl-tools-pod
42 BuildRequires:  tetex
43 BuildRequires:  texinfo
44 BuildRequires:  xvid-devel
45 BuildRequires:  zlib-devel
46 %{?with_autoreqdep:BuildConflicts:      libpostproc}
47 Obsoletes:      libpostproc
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
51
52 %description
53 ffmpeg is a hyper fast realtime audio/video encoder and streaming
54 server. It can grab from a standard Video4Linux video source and
55 convert it into several file formats based on DCT/motion compensation
56 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
57 compatible stream.
58
59 This package contains also ffmpeg shared libraries (libavcodec and
60 libavformat).
61
62 %description -l pl
63 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
64 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
65 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
66 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
67 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
68 strumienia kompatybilnego z AC3.
69
70 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
71 libavformat).
72
73 %package devel
74 Summary:        ffmpeg header files
75 Summary(pl):    Pliki nag³ówkowe ffmpeg
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Obsoletes:      libpostproc-devel
79 # for libavcodec:
80 Requires:       faac-devel
81 Requires:       lame-libs-devel
82 Requires:       libtheora-devel
83 Requires:       libvorbis-devel
84 Requires:       xvid-devel
85 Requires:       zlib-devel
86
87 %description devel
88 ffmpeg header files.
89
90 %description devel -l pl
91 Pliki nag³ówkowe ffmpeg.
92
93 %package static
94 Summary:        ffmpeg static libraries
95 Summary(pl):    Statyczne biblioteki ffmpeg
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 ffmpeg static libraries (libavcodec and libavformat).
101
102 %description static -l pl
103 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
104
105 %package ffplay
106 Summary:        FFplay - SDL-based media player
107 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
108 Group:          Applications/Multimedia
109 Requires:       %{name} = %{version}-%{release}
110
111 %description ffplay
112 FFplay is a very simple and portable media player using the FFmpeg
113 libraries and the SDL library. It is mostly used as a test bench for
114 the various APIs of FFmpeg.
115
116 %description ffplay -l pl
117 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
118 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
119 testowania ró¿nych API FFmpeg.
120
121 %package vhook-imlib2
122 Summary:        imlib2 based hook
123 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
124 Group:          Libraries
125 Requires:       %{name} = %{version}-%{release}
126
127 %description vhook-imlib2
128 This module implements a text overlay for a video image. Currently it
129 supports a fixed overlay or reading the text from a file. The string
130 is passed through strftime so that it is easy to imprint the date and
131 time onto the image.
132
133 %description vhook-imlib2 -l pl
134 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
135 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
136 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
137 obrazie.
138
139 %prep
140 %setup -q -n FFMpeg-%{snap}
141 %patch0 -p1
142 %patch1 -p1
143
144 %build
145 # notes:
146 # - it's not autoconf configure
147 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
148 #   (-fPIC takes one)
149 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
150 ./configure \
151         --prefix=%{_prefix} \
152         --libdir=%{_libdir} \
153         --mandir=%{_mandir} \
154         --disable-strip \
155         --enable-a52 \
156         --enable-faac \
157         --enable-faadbin \
158         --enable-gpl \
159         --enable-libogg \
160         --enable-mp3lame \
161         --enable-pp \
162         --enable-pthreads \
163         --enable-shared \
164         --enable-shared-pp \
165         --enable-theora \
166         --enable-vorbis \
167         --enable-xvid \
168 %if %{without gcc4}
169 %ifnarch %{ix86}
170         --disable-mmx \
171 %endif
172 %ifarch i386 i486
173         --disable-mmx \
174 %endif
175 %else
176         --disable-mmx \
177 %endif
178         --cc="%{__cc}" \
179         --extra-cflags="%{rpmcflags} -fomit-frame-pointer -fno-strict-aliasing" \
180         --extra-ldflags="%{rpmldflags}" \
181         --disable-debug \
182         --disable-opts \
183         --tune=generic
184
185 %{__make} \
186         BUILD_DOC=yes \
187         LIBVERSION=%{snap}
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
192
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT
195
196 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
197 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %files
206 %defattr(644,root,root,755)
207 %doc Changelog README doc/*.html
208 %attr(755,root,root) %{_bindir}/ffmpeg
209 %attr(755,root,root) %{_sbindir}/ffserver
210 %attr(755,root,root) %{_libdir}/libavcodec-*.so
211 %attr(755,root,root) %{_libdir}/libavformat-*.so
212 %attr(755,root,root) %{_libdir}/libavutil-*.so
213 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
214 %dir %{_libdir}/vhook
215 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
216 %attr(755,root,root) %{_libdir}/vhook/fish.so
217 %attr(755,root,root) %{_libdir}/vhook/null.so
218 %attr(755,root,root) %{_libdir}/vhook/ppm.so
219 %attr(755,root,root) %{_libdir}/vhook/watermark.so
220 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
221 %{_mandir}/man1/ffmpeg.1*
222 %{_mandir}/man1/ffserver.1*
223
224 %files devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libavcodec.so
227 %attr(755,root,root) %{_libdir}/libavformat.so
228 %attr(755,root,root) %{_libdir}/libavutil.so
229 %attr(755,root,root) %{_libdir}/libpostproc.so
230 %{_libdir}/lib*.la
231 %{_includedir}/ffmpeg
232 %{_includedir}/postproc
233 %{_pkgconfigdir}/*.pc
234
235 %files static
236 %defattr(644,root,root,755)
237 %{_libdir}/lib*.a
238
239 %files ffplay
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_bindir}/ffplay
242 %{_mandir}/man1/ffplay.1*
243
244 %if %{with imlib2}
245 %files vhook-imlib2
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
248 %endif
This page took 0.082083 seconds and 4 git commands to generate.