]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- added Obsoletes for libpostproc,libpostproc-devel
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2  # we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.9
9 Release:        0.pre1.0.1
10 # LGPL or GPL, chosen at configure time (GPL version is more featured)
11 License:        GPL
12 Group:          Daemons
13 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
14 # Source0-md5:  ea5587e3c66d50b1503b82ac4179c303
15 Patch0:         %{name}-imlib2.patch
16 Patch1:         %{name}-libtool.patch
17 URL:            http://ffmpeg.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  freetype-devel
20 %ifarch ppc
21 # require version with altivec support fixed
22 BuildRequires:  gcc >= 5:3.3.2-3
23 %endif
24 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
25 BuildRequires:  libtool >= 2:1.4d-3
26 %ifarch %{ix86}
27 %ifnarch i386 i486
28 BuildRequires:  nasm
29 %endif
30 %endif
31 BuildRequires:  texinfo
32 BuildRequires:  zlib-devel
33 Obsoletes:      libpostproc
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
37
38 %description
39 ffmpeg is a hyper fast realtime audio/video encoder and streaming
40 server. It can grab from a standard Video4Linux video source and
41 convert it into several file formats based on DCT/motion compensation
42 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
43 compatible stream.
44
45 This package contains also ffmpeg shared libraries (libavcodec and
46 libavformat).
47
48 %description -l pl
49 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
50 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
51 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
52 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
53 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
54 strumienia kompatybilnego z AC3.
55
56 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
57 libavformat).
58
59 %package devel
60 Summary:        ffmpeg header files
61 Summary(pl):    Pliki nag³ówkowe ffmpeg
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Obsoletes:      libpostproc-devel
65
66 %description devel
67 ffmpeg header files.
68
69 %description devel -l pl
70 Pliki nag³ówkowe ffmpeg.
71
72 %package static
73 Summary:        ffmpeg static libraries
74 Summary(pl):    Statyczne biblioteki ffmpeg
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 ffmpeg static libraries (libavcodec and libavformat).
80
81 %description static -l pl
82 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
83
84 %package ffplay
85 Summary:        FFplay - SDL-based media player
86 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
87 Group:          Applications/Multimedia
88 Requires:       %{name} = %{version}-%{release}
89
90 %description ffplay
91 FFplay is a very simple and portable media player using the FFmpeg
92 libraries and the SDL library. It is mostly used as a test bench for
93 the various APIs of FFmpeg.
94
95 %description ffplay -l pl
96 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
97 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
98 testowania ró¿nych API FFmpeg.
99
100 %package vhook-imlib2
101 Summary:        imlib2 based hook
102 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
103 Group:          Libraries
104 Requires:       %{name} = %{version}-%{release}
105
106 %description vhook-imlib2
107 This module implements a text overlay for a video image. Currently it
108 supports a fixed overlay or reading the text from a file. The string
109 is passed through strftime so that it is easy to imprint the date and
110 time onto the image.
111
112 %description vhook-imlib2 -l pl
113 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
114 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
115 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
116 obrazie.
117
118 %prep
119 %setup -q -n ffmpeg-0.4.9-pre1
120 %patch0 -p1
121 %patch1 -p1
122
123 %build
124 # notes:
125 # - it's not autoconf configure
126 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
127 #   (-fPIC takes one)
128 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
129 ./configure \
130         --prefix=%{_prefix} \
131         --libdir=%{_libdir} \
132         --mandir=%{_mandir} \
133         --enable-a52bin \
134         --enable-faadbin \
135         --enable-gpl \
136         --enable-pp \
137         --enable-shared \
138         --enable-shared-pp \
139 %ifnarch %{ix86}
140         --disable-mmx \
141 %endif
142 %ifarch i386 i486
143         --disable-mmx \
144 %endif
145         --cc="%{__cc}" \
146         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
147         --extra-ldflags="%{rpmldflags}" \
148         --disable-debug \
149         --disable-opts \
150         --tune=generic
151
152 %{__make} \
153         BUILD_DOC=yes
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
163 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc Changelog README doc/*.html
174 %attr(755,root,root) %{_bindir}/ffmpeg
175 %attr(755,root,root) %{_sbindir}/ffserver
176 %attr(755,root,root) %{_libdir}/libavcodec-*.so
177 %attr(755,root,root) %{_libdir}/libavformat-*.so
178 %attr(755,root,root) %{_libdir}/libpostproc.so.*
179 %dir %{_libdir}/vhook
180 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
181 %attr(755,root,root) %{_libdir}/vhook/fish.so
182 %attr(755,root,root) %{_libdir}/vhook/null.so
183 %attr(755,root,root) %{_libdir}/vhook/ppm.so
184 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
185 %{_mandir}/man1/ffmpeg.1*
186 %{_mandir}/man1/ffserver.1*
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libavcodec.so
191 %attr(755,root,root) %{_libdir}/libavformat.so
192 %attr(755,root,root) %{_libdir}/libpostproc.so
193 %{_libdir}/lib*.la
194 %{_includedir}/ffmpeg
195 %{_includedir}/postproc
196
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/lib*.a
200
201 %files ffplay
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/ffplay
204 %{_mandir}/man1/ffplay.1*
205
206 %if %{with imlib2}
207 %files vhook-imlib2
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
210 %endif
This page took 0.251097 seconds and 4 git commands to generate.