]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- NOT finished (patches not updated) - release 0.1
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2  # we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.9
9 Release:        0.pre1.0.1
10 License:        LGPL/GPL
11 Group:          Daemons
12 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
13 # Source0-md5:  ea5587e3c66d50b1503b82ac4179c303
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 Patch3:         %{name}-lib64.patch
18 Patch4:         %{name}-gcc34.patch
19 URL:            http://ffmpeg.sourceforge.net/
20 BuildRequires:  SDL-devel
21 BuildRequires:  freetype-devel
22 %ifarch ppc
23 # require version with altivec support fixed
24 BuildRequires:  gcc >= 5:3.3.2-3
25 %endif
26 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
27 BuildRequires:  libtool >= 2:1.4d-3
28 %ifarch %{ix86}
29 %ifnarch i386 i486
30 BuildRequires:  nasm
31 %endif
32 %endif
33 BuildRequires:  zlib-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
37
38 %description
39 ffmpeg is a hyper fast realtime audio/video encoder and streaming
40 server. It can grab from a standard Video4Linux video source and
41 convert it into several file formats based on DCT/motion compensation
42 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
43 compatible stream.
44
45 This package contains also ffmpeg shared libraries (libavcodec and
46 libavformat).
47
48 %description -l pl
49 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
50 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
51 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
52 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
53 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
54 strumienia kompatybilnego z AC3.
55
56 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
57 libavformat).
58
59 %package ffplay
60 Summary:        FFplay - SDL-based media player
61 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
62 Group:          Applications/Multimedia
63 Requires:       %{name} = %{version}-%{release}
64
65 %description ffplay
66 FFplay is a very simple and portable media player using the FFmpeg
67 libraries and the SDL library. It is mostly used as a test bench for
68 the various APIs of FFmpeg.
69
70 %description ffplay -l pl
71 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
72 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
73 testowania ró¿nych API FFmpeg.
74
75 %package vhook-imlib2
76 Summary:        imlib2 based hook
77 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
78 Group:          Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description vhook-imlib2
82 This module implements a text overlay for a video image. Currently it
83 supports a fixed overlay or reading the text from a file. The string
84 is passed through strftime so that it is easy to imprint the date and
85 time onto the image.
86
87 %description vhook-imlib2 -l pl
88 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
89 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
90 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
91 obrazie.
92
93 %package devel
94 Summary:        ffmpeg header files
95 Summary(pl):    Pliki nag³ówkowe ffmpeg
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description devel
100 ffmpeg header files.
101
102 %description devel -l pl
103 Pliki nag³ówkowe ffmpeg.
104
105 # %package static
106 # Summary:      ffmpeg static libraries
107 # Summary(pl):  Statyczne biblioteki ffmpeg
108 # Group:                Development/Libraries
109 # Requires:     %{name}-devel = %{version}-%{release}
110
111 # %description static
112 # ffmpeg static libraries (libavcodec and libavformat).
113
114 # %description static -l pl
115 # Statyczne biblioteki ffmpeg (libavcodec i libavformat).
116
117 %prep
118 %setup -q -n ffmpeg-0.4.9-pre1
119 # %patch0 -p1
120 # %patch1 -p1
121 # %patch2 -p1
122 %ifarch amd64
123 %patch3 -p1
124 %endif
125 # %patch4 -p1
126
127 %build
128 # notes:
129 # - it's not autoconf configure
130 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
131 #   (-fPIC takes one)
132 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
133 ./configure \
134         --prefix=%{_prefix} \
135         --mandir=%{_mandir} \
136         --enable-gpl \
137         --enable-shared \
138         --enable-a52bin \
139         --enable-faadbin \
140 %ifnarch %{ix86}
141         --disable-mmx \
142 %endif
143 %ifarch i386 i486
144         --disable-mmx \
145 %endif
146         --cc="%{__cc}" \
147         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
148         --extra-ldflags="%{rpmldflags}" \
149         --disable-debug \
150         --disable-opts \
151         --tune=generic
152
153 %{__make} 
154 %{__make} -C doc
155 %{__make} -C libavcodec/libpostproc 
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT \
163         mandir=$RPM_BUILD_ROOT%{_mandir} \
164         prefix=$RPM_BUILD_ROOT%{_prefix} \
165         bindir=$RPM_BUILD_ROOT%{_bindir} \
166         SHARED_PP=yes
167
168 %{__make} -C libavcodec/libpostproc install \
169         DESTDIR=$RPM_BUILD_ROOT \
170         mandir=$RPM_BUILD_ROOT%{_mandir} \
171         prefix=$RPM_BUILD_ROOT%{_prefix} \
172         bindir=$RPM_BUILD_ROOT%{_bindir} \
173         SHARED_PP=yes
174                         
175
176 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
177 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -p /sbin/ldconfig
183 %postun -p /sbin/ldconfig
184
185 %files
186 %defattr(644,root,root,755)
187 %doc Changelog README doc/*.html
188 %attr(755,root,root) %{_bindir}/ffmpeg
189 %attr(755,root,root) %{_sbindir}/ffserver
190 %attr(755,root,root) %{_libdir}/libavcodec-*.so
191 %attr(755,root,root) %{_libdir}/libavformat-*.so
192 %attr(755,root,root) %{_libdir}/libpostproc.so.*
193 %dir %{_libdir}/vhook
194 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
195 %attr(755,root,root) %{_libdir}/vhook/fish.so
196 %attr(755,root,root) %{_libdir}/vhook/null.so
197 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
198 %{_mandir}/man1/ffmpeg.1*
199 %{_mandir}/man1/ffserver.1*
200
201 %files ffplay
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/ffplay
204 %{_mandir}/man1/ffplay.1*
205
206 %if %{with imlib2}
207 %files vhook-imlib2
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
210 %endif
211
212 %files devel
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/libavcodec.so
215 %attr(755,root,root) %{_libdir}/libavformat.so
216 %attr(755,root,root) %{_libdir}/libpostproc.so
217 # %{_libdir}/lib*.la
218 %{_includedir}/ffmpeg
219 %{_includedir}/postproc
220
221 # %files static
222 # %defattr(644,root,root,755)
223 # %{_libdir}/lib*.a
This page took 0.061328 seconds and 4 git commands to generate.