]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- normalize bcond for omitting BC
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 Release:        0.pre1.1
11 # LGPL or GPL, chosen at configure time (GPL version is more featured)
12 License:        GPL
13 Group:          Daemons
14 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
15 # Source0-md5:  ea5587e3c66d50b1503b82ac4179c303
16 Patch0:         %{name}-imlib2.patch
17 Patch1:         %{name}-libtool.patch
18 URL:            http://ffmpeg.sourceforge.net/
19 BuildRequires:  SDL-devel
20 BuildRequires:  freetype-devel
21 %ifarch ppc
22 # require version with altivec support fixed
23 BuildRequires:  gcc >= 5:3.3.2-3
24 %endif
25 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
26 BuildRequires:  libtool >= 2:1.4d-3
27 BuildRequires:  faac-devel
28 %ifarch %{ix86}
29 %ifnarch i386 i486
30 BuildRequires:  nasm
31 %endif
32 %endif
33 BuildRequires:  perl-tools-pod
34 BuildRequires:  tetex
35 BuildRequires:  texinfo
36 BuildRequires:  zlib-devel
37 BuildRequires:  lame-libs-devel
38 BuildRequires:  libvorbis-devel
39 %{?with_autoreqdep:BuildConflicts:      libpostproc}
40 Obsoletes:      libpostproc
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
44
45 %description
46 ffmpeg is a hyper fast realtime audio/video encoder and streaming
47 server. It can grab from a standard Video4Linux video source and
48 convert it into several file formats based on DCT/motion compensation
49 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
50 compatible stream.
51
52 This package contains also ffmpeg shared libraries (libavcodec and
53 libavformat).
54
55 %description -l pl
56 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
57 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
58 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
59 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
60 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
61 strumienia kompatybilnego z AC3.
62
63 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
64 libavformat).
65
66 %package devel
67 Summary:        ffmpeg header files
68 Summary(pl):    Pliki nag³ówkowe ffmpeg
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Obsoletes:      libpostproc-devel
72
73 %description devel
74 ffmpeg header files.
75
76 %description devel -l pl
77 Pliki nag³ówkowe ffmpeg.
78
79 %package static
80 Summary:        ffmpeg static libraries
81 Summary(pl):    Statyczne biblioteki ffmpeg
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 ffmpeg static libraries (libavcodec and libavformat).
87
88 %description static -l pl
89 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
90
91 %package ffplay
92 Summary:        FFplay - SDL-based media player
93 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
94 Group:          Applications/Multimedia
95 Requires:       %{name} = %{version}-%{release}
96
97 %description ffplay
98 FFplay is a very simple and portable media player using the FFmpeg
99 libraries and the SDL library. It is mostly used as a test bench for
100 the various APIs of FFmpeg.
101
102 %description ffplay -l pl
103 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
104 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
105 testowania ró¿nych API FFmpeg.
106
107 %package vhook-imlib2
108 Summary:        imlib2 based hook
109 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description vhook-imlib2
114 This module implements a text overlay for a video image. Currently it
115 supports a fixed overlay or reading the text from a file. The string
116 is passed through strftime so that it is easy to imprint the date and
117 time onto the image.
118
119 %description vhook-imlib2 -l pl
120 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
121 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
122 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
123 obrazie.
124
125 %prep
126 %setup -q -n ffmpeg-0.4.9-pre1
127 %patch0 -p1
128 %patch1 -p1
129
130 %build
131 # notes:
132 # - it's not autoconf configure
133 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
134 #   (-fPIC takes one)
135 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
136 ./configure \
137         --prefix=%{_prefix} \
138         --libdir=%{_libdir} \
139         --mandir=%{_mandir} \
140         --enable-a52bin \
141         --enable-faac \
142         --enable-faadbin \
143         --enable-pthreads \
144         --enable-gpl \
145         --enable-pp \
146         --enable-shared \
147         --enable-shared-pp \
148         --enable-mp3lame \
149         --enable-vorbis \
150 %ifnarch %{ix86}
151         --disable-mmx \
152 %endif
153 %ifarch i386 i486
154         --disable-mmx \
155 %endif
156         --cc="%{__cc}" \
157         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
158         --extra-ldflags="%{rpmldflags}" \
159         --disable-debug \
160         --disable-opts \
161         --tune=generic
162
163 %{__make} \
164         BUILD_DOC=yes
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
174 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc Changelog README doc/*.html
185 %attr(755,root,root) %{_bindir}/ffmpeg
186 %attr(755,root,root) %{_sbindir}/ffserver
187 %attr(755,root,root) %{_libdir}/libavcodec-*.so
188 %attr(755,root,root) %{_libdir}/libavformat-*.so
189 %attr(755,root,root) %{_libdir}/libpostproc.so.*
190 %dir %{_libdir}/vhook
191 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
192 %attr(755,root,root) %{_libdir}/vhook/fish.so
193 %attr(755,root,root) %{_libdir}/vhook/null.so
194 %attr(755,root,root) %{_libdir}/vhook/ppm.so
195 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
196 %{_mandir}/man1/ffmpeg.1*
197 %{_mandir}/man1/ffserver.1*
198
199 %files devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libavcodec.so
202 %attr(755,root,root) %{_libdir}/libavformat.so
203 %attr(755,root,root) %{_libdir}/libpostproc.so
204 %{_libdir}/lib*.la
205 %{_includedir}/ffmpeg
206 %{_includedir}/postproc
207
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/lib*.a
211
212 %files ffplay
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_bindir}/ffplay
215 %{_mandir}/man1/ffplay.1*
216
217 %if %{with imlib2}
218 %files vhook-imlib2
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
221 %endif
This page took 0.072916 seconds and 4 git commands to generate.