]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- AMD64 build fixed
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 # _without_imlib        - we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.8
9 Release:        2
10 License:        LGPL/GPL
11 Group:          Daemons
12 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}.tar.gz
13 # Source0-md5:  e00d47614ba1afd99ad2ea387e782dd9
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 Patch3:         %{name}-lib64.patch
18 URL:            http://ffmpeg.sourceforge.net/
19 BuildRequires:  SDL-devel
20 BuildRequires:  freetype-devel
21 %{!?_without_imlib:BuildRequires:       imlib2-devel >= 1.1.0-2}
22 BuildRequires:  libtool >= 2:1.4d-3
23 %ifarch i586 i686 athlon
24 BuildRequires:  nasm
25 %endif
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 ffmpeg is a hyper fast realtime audio/video encoder and streaming
33 server. It can grab from a standard Video4Linux video source and
34 convert it into several file formats based on DCT/motion compensation
35 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
36 compatible stream.
37
38 This package contains also ffmpeg shared libraries (libavcodec and
39 libavformat).
40
41 %description -l pl
42 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
43 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
44 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
45 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
46 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
47 strumienia kompatybilnego z AC3.
48
49 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
50 libavformat).
51
52 %package ffplay
53 Summary:        FFplay - SDL-based media player
54 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
55 Group:          Applications/Multimedia
56 Requires:       %{name} = %{version}
57
58 %description ffplay
59 FFplay is a very simple and portable media player using the FFmpeg
60 libraries and the SDL library. It is mostly used as a test bench for
61 the various APIs of FFmpeg.
62
63 %description ffplay -l pl
64 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
65 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
66 testowania ró¿nych API FFmpeg.
67
68 %package vhook-imlib2
69 Summary:        imlib2 based hook
70 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
71 Group:          Libraries
72 Requires:       %{name} = %{version}
73
74 %description vhook-imlib2
75 This module implements a text overlay for a video image. Currently it
76 supports a fixed overlay or reading the text from a file. The string
77 is passed through strftime so that it is easy to imprint the date and
78 time onto the image.
79
80 %description vhook-imlib2 -l pl
81 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
82 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
83 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
84 obrazie.
85
86 %package devel
87 Summary:        ffmpeg header files
88 Summary(pl):    Pliki nag³ówkowe ffmpeg
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}
91
92 %description devel
93 ffmpeg header files.
94
95 %description devel -l pl
96 Pliki nag³ówkowe ffmpeg.
97
98 %package static
99 Summary:        ffmpeg static libraries
100 Summary(pl):    Statyczne biblioteki ffmpeg
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}
103
104 %description static
105 ffmpeg static libraries (libavcodec and libavformat).
106
107 %description static -l pl
108 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115 %ifarch amd64
116 %patch3 -p1
117 %endif
118
119 %build
120 # notes:
121 # - it's not autoconf configure
122 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
123 #   (-fPIC takes one)
124 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
125 # - [temporary!!!] altivec disabled because of gcc 3.3.x bug target/11793
126 ./configure \
127         --prefix=%{_prefix} \
128         --mandir=%{_mandir} \
129         --enable-shared \
130         --enable-a52bin \
131         --enable-faadbin \
132 %ifnarch i586 i686 athlon
133         --disable-mmx \
134 %endif
135 %ifarch ppc
136         --disable-altivec \
137 %endif
138         --cc="%{__cc}" \
139         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
140         --extra-ldflags="%{rpmldflags}" \
141         --disable-debug \
142         --disable-opts \
143         --tune=generic
144
145 %{__make}
146
147 %{__make} -C doc
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
157 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc Changelog README doc/*.html
168 %attr(755,root,root) %{_bindir}/ffmpeg
169 %attr(755,root,root) %{_sbindir}/ffserver
170 %attr(755,root,root) %{_libdir}/libavcodec-*.so
171 %attr(755,root,root) %{_libdir}/libavformat-*.so
172 %dir %{_libdir}/vhook
173 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
174 %attr(755,root,root) %{_libdir}/vhook/fish.so
175 %attr(755,root,root) %{_libdir}/vhook/null.so
176 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
177 %{_mandir}/man1/ffmpeg.1*
178 %{_mandir}/man1/ffserver.1*
179
180 %files ffplay
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/ffplay
183 %{_mandir}/man1/ffplay.1*
184
185 %if %{!?_without_imlib:1}0
186 %files vhook-imlib2
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
189 %endif
190
191 %files devel
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libavcodec.so
194 %attr(755,root,root) %{_libdir}/libavformat.so
195 %{_libdir}/lib*.la
196 %{_includedir}/ffmpeg
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/lib*.a
This page took 0.072569 seconds and 4 git commands to generate.