]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- added libavcodec deps to -devel
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 %define snap    20050806
11 Release:        3.%{snap}.2
12 # LGPL or GPL, chosen at configure time (GPL version is more featured)
13 License:        GPL
14 Group:          Daemons
15 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
16 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
17 # Source0-md5:  f5ea3dd877c5df5b60356053642cf542
18 Patch0:         %{name}-libtool.patch
19 Patch1:         %{name}-libdir.patch
20 URL:            http://ffmpeg.sourceforge.net/
21 BuildRequires:  SDL-devel
22 BuildRequires:  faac-devel
23 BuildRequires:  freetype-devel
24 %ifarch ppc
25 # require version with altivec support fixed
26 BuildRequires:  gcc >= 5:3.3.2-3
27 %endif
28 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
29 BuildRequires:  lame-libs-devel
30 BuildRequires:  libtheora-devel
31 BuildRequires:  libtool >= 2:1.4d-3
32 BuildRequires:  libvorbis-devel
33 %ifarch %{ix86}
34 %ifnarch i386 i486
35 BuildRequires:  nasm
36 %endif
37 %endif
38 BuildRequires:  perl-tools-pod
39 BuildRequires:  tetex
40 BuildRequires:  texinfo
41 BuildRequires:  xvid-devel
42 BuildRequires:  zlib-devel
43 %{?with_autoreqdep:BuildConflicts:      libpostproc}
44 Obsoletes:      libpostproc
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
48
49 %description
50 ffmpeg is a hyper fast realtime audio/video encoder and streaming
51 server. It can grab from a standard Video4Linux video source and
52 convert it into several file formats based on DCT/motion compensation
53 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
54 compatible stream.
55
56 This package contains also ffmpeg shared libraries (libavcodec and
57 libavformat).
58
59 %description -l pl
60 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
61 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
62 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
63 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
64 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
65 strumienia kompatybilnego z AC3.
66
67 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
68 libavformat).
69
70 %package devel
71 Summary:        ffmpeg header files
72 Summary(pl):    Pliki nag³ówkowe ffmpeg
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Obsoletes:      libpostproc-devel
76 # for libavcodec:
77 Requires:       faac-devel
78 Requires:       lame-libs-devel
79 Requires:       libtheora-devel
80 Requires:       libvorbis-devel
81 Requires:       xvid-devel
82 Requires:       zlib-devel
83
84 %description devel
85 ffmpeg header files.
86
87 %description devel -l pl
88 Pliki nag³ówkowe ffmpeg.
89
90 %package static
91 Summary:        ffmpeg static libraries
92 Summary(pl):    Statyczne biblioteki ffmpeg
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 ffmpeg static libraries (libavcodec and libavformat).
98
99 %description static -l pl
100 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
101
102 %package ffplay
103 Summary:        FFplay - SDL-based media player
104 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
105 Group:          Applications/Multimedia
106 Requires:       %{name} = %{version}-%{release}
107
108 %description ffplay
109 FFplay is a very simple and portable media player using the FFmpeg
110 libraries and the SDL library. It is mostly used as a test bench for
111 the various APIs of FFmpeg.
112
113 %description ffplay -l pl
114 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
115 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
116 testowania ró¿nych API FFmpeg.
117
118 %package vhook-imlib2
119 Summary:        imlib2 based hook
120 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123
124 %description vhook-imlib2
125 This module implements a text overlay for a video image. Currently it
126 supports a fixed overlay or reading the text from a file. The string
127 is passed through strftime so that it is easy to imprint the date and
128 time onto the image.
129
130 %description vhook-imlib2 -l pl
131 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
132 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
133 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
134 obrazie.
135
136 %prep
137 %setup -q -n FFMpeg-%{snap}
138 %patch0 -p1
139 %patch1 -p1
140
141 %build
142 # notes:
143 # - it's not autoconf configure
144 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
145 #   (-fPIC takes one)
146 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
147 ./configure \
148         --prefix=%{_prefix} \
149         --libdir=%{_libdir} \
150         --mandir=%{_mandir} \
151         --disable-strip \
152         --enable-a52bin \
153         --enable-faac \
154         --enable-faadbin \
155         --enable-gpl \
156         --enable-libogg \
157         --enable-mp3lame \
158         --enable-pp \
159         --enable-pthreads \
160         --enable-shared \
161         --enable-shared-pp \
162         --enable-theora \
163         --enable-vorbis \
164         --enable-xvid \
165 %ifnarch %{ix86}
166         --disable-mmx \
167 %endif
168 %ifarch i386 i486
169         --disable-mmx \
170 %endif
171         --cc="%{__cc}" \
172         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
173         --extra-ldflags="%{rpmldflags}" \
174         --disable-debug \
175         --disable-opts \
176         --tune=generic
177
178 %{__make} \
179         BUILD_DOC=yes \
180         LIBVERSION=%{snap}
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT
188
189 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
190 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   -p /sbin/ldconfig
196 %postun -p /sbin/ldconfig
197
198 %files
199 %defattr(644,root,root,755)
200 %doc Changelog README doc/*.html
201 %attr(755,root,root) %{_bindir}/ffmpeg
202 %attr(755,root,root) %{_sbindir}/ffserver
203 %attr(755,root,root) %{_libdir}/libavcodec-*.so
204 %attr(755,root,root) %{_libdir}/libavformat-*.so
205 %attr(755,root,root) %{_libdir}/libavutil-*.so
206 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
207 %dir %{_libdir}/vhook
208 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
209 %attr(755,root,root) %{_libdir}/vhook/fish.so
210 %attr(755,root,root) %{_libdir}/vhook/null.so
211 %attr(755,root,root) %{_libdir}/vhook/ppm.so
212 %attr(755,root,root) %{_libdir}/vhook/watermark.so
213 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
214 %{_mandir}/man1/ffmpeg.1*
215 %{_mandir}/man1/ffserver.1*
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libavcodec.so
220 %attr(755,root,root) %{_libdir}/libavformat.so
221 %attr(755,root,root) %{_libdir}/libavutil.so
222 %attr(755,root,root) %{_libdir}/libpostproc.so
223 %{_libdir}/lib*.la
224 %{_includedir}/ffmpeg
225 %{_includedir}/postproc
226 %{_pkgconfigdir}/*.pc
227
228 %files static
229 %defattr(644,root,root,755)
230 %{_libdir}/lib*.a
231
232 %files ffplay
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_bindir}/ffplay
235 %{_mandir}/man1/ffplay.1*
236
237 %if %{with imlib2}
238 %files vhook-imlib2
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
241 %endif
This page took 0.057668 seconds and 4 git commands to generate.