]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- BR: perl-tools-pod, tetex
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2  # we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.9
9 Release:        0.pre1.1
10 # LGPL or GPL, chosen at configure time (GPL version is more featured)
11 License:        GPL
12 Group:          Daemons
13 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
14 # Source0-md5:  ea5587e3c66d50b1503b82ac4179c303
15 Patch0:         %{name}-imlib2.patch
16 Patch1:         %{name}-libtool.patch
17 URL:            http://ffmpeg.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  freetype-devel
20 %ifarch ppc
21 # require version with altivec support fixed
22 BuildRequires:  gcc >= 5:3.3.2-3
23 %endif
24 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
25 BuildRequires:  libtool >= 2:1.4d-3
26 %ifarch %{ix86}
27 %ifnarch i386 i486
28 BuildRequires:  nasm
29 %endif
30 %endif
31 BuildRequires:  perl-tools-pod
32 BuildRequires:  tetex
33 BuildRequires:  texinfo
34 BuildRequires:  zlib-devel
35 Obsoletes:      libpostproc
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
39
40 %description
41 ffmpeg is a hyper fast realtime audio/video encoder and streaming
42 server. It can grab from a standard Video4Linux video source and
43 convert it into several file formats based on DCT/motion compensation
44 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
45 compatible stream.
46
47 This package contains also ffmpeg shared libraries (libavcodec and
48 libavformat).
49
50 %description -l pl
51 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
52 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
53 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
54 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
55 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
56 strumienia kompatybilnego z AC3.
57
58 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
59 libavformat).
60
61 %package devel
62 Summary:        ffmpeg header files
63 Summary(pl):    Pliki nag³ówkowe ffmpeg
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Obsoletes:      libpostproc-devel
67
68 %description devel
69 ffmpeg header files.
70
71 %description devel -l pl
72 Pliki nag³ówkowe ffmpeg.
73
74 %package static
75 Summary:        ffmpeg static libraries
76 Summary(pl):    Statyczne biblioteki ffmpeg
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 ffmpeg static libraries (libavcodec and libavformat).
82
83 %description static -l pl
84 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
85
86 %package ffplay
87 Summary:        FFplay - SDL-based media player
88 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
89 Group:          Applications/Multimedia
90 Requires:       %{name} = %{version}-%{release}
91
92 %description ffplay
93 FFplay is a very simple and portable media player using the FFmpeg
94 libraries and the SDL library. It is mostly used as a test bench for
95 the various APIs of FFmpeg.
96
97 %description ffplay -l pl
98 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
99 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
100 testowania ró¿nych API FFmpeg.
101
102 %package vhook-imlib2
103 Summary:        imlib2 based hook
104 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description vhook-imlib2
109 This module implements a text overlay for a video image. Currently it
110 supports a fixed overlay or reading the text from a file. The string
111 is passed through strftime so that it is easy to imprint the date and
112 time onto the image.
113
114 %description vhook-imlib2 -l pl
115 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
116 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
117 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
118 obrazie.
119
120 %prep
121 %setup -q -n ffmpeg-0.4.9-pre1
122 %patch0 -p1
123 %patch1 -p1
124
125 %build
126 # notes:
127 # - it's not autoconf configure
128 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
129 #   (-fPIC takes one)
130 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
131 ./configure \
132         --prefix=%{_prefix} \
133         --libdir=%{_libdir} \
134         --mandir=%{_mandir} \
135         --enable-a52bin \
136         --enable-faadbin \
137         --enable-gpl \
138         --enable-pp \
139         --enable-shared \
140         --enable-shared-pp \
141 %ifnarch %{ix86}
142         --disable-mmx \
143 %endif
144 %ifarch i386 i486
145         --disable-mmx \
146 %endif
147         --cc="%{__cc}" \
148         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
149         --extra-ldflags="%{rpmldflags}" \
150         --disable-debug \
151         --disable-opts \
152         --tune=generic
153
154 %{__make} \
155         BUILD_DOC=yes
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
165 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc Changelog README doc/*.html
176 %attr(755,root,root) %{_bindir}/ffmpeg
177 %attr(755,root,root) %{_sbindir}/ffserver
178 %attr(755,root,root) %{_libdir}/libavcodec-*.so
179 %attr(755,root,root) %{_libdir}/libavformat-*.so
180 %attr(755,root,root) %{_libdir}/libpostproc.so.*
181 %dir %{_libdir}/vhook
182 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
183 %attr(755,root,root) %{_libdir}/vhook/fish.so
184 %attr(755,root,root) %{_libdir}/vhook/null.so
185 %attr(755,root,root) %{_libdir}/vhook/ppm.so
186 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
187 %{_mandir}/man1/ffmpeg.1*
188 %{_mandir}/man1/ffserver.1*
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libavcodec.so
193 %attr(755,root,root) %{_libdir}/libavformat.so
194 %attr(755,root,root) %{_libdir}/libpostproc.so
195 %{_libdir}/lib*.la
196 %{_includedir}/ffmpeg
197 %{_includedir}/postproc
198
199 %files static
200 %defattr(644,root,root,755)
201 %{_libdir}/lib*.a
202
203 %files ffplay
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/ffplay
206 %{_mandir}/man1/ffplay.1*
207
208 %if %{with imlib2}
209 %files vhook-imlib2
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
212 %endif
This page took 0.054737 seconds and 4 git commands to generate.