]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- enable xvid
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # we can safely play without it :-)
4 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
5 #
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.9
10 %define snap    20050806
11 Release:        3.%{snap}.2
12 # LGPL or GPL, chosen at configure time (GPL version is more featured)
13 License:        GPL
14 Group:          Daemons
15 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
16 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
17 # Source0-md5:  f5ea3dd877c5df5b60356053642cf542
18 Patch0:         %{name}-libtool.patch
19 Patch1:         %{name}-libdir.patch
20 URL:            http://ffmpeg.sourceforge.net/
21 BuildRequires:  SDL-devel
22 BuildRequires:  faac-devel
23 BuildRequires:  freetype-devel
24 %ifarch ppc
25 # require version with altivec support fixed
26 BuildRequires:  gcc >= 5:3.3.2-3
27 %endif
28 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
29 BuildRequires:  lame-libs-devel
30 BuildRequires:  libtheora-devel
31 BuildRequires:  libtool >= 2:1.4d-3
32 BuildRequires:  libvorbis-devel
33 %ifarch %{ix86}
34 %ifnarch i386 i486
35 BuildRequires:  nasm
36 %endif
37 %endif
38 BuildRequires:  perl-tools-pod
39 BuildRequires:  tetex
40 BuildRequires:  texinfo
41 BuildRequires:  zlib-devel
42 BuildRequires:  xvid-devel
43 %{?with_autoreqdep:BuildConflicts:      libpostproc}
44 Obsoletes:      libpostproc
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
48
49 %description
50 ffmpeg is a hyper fast realtime audio/video encoder and streaming
51 server. It can grab from a standard Video4Linux video source and
52 convert it into several file formats based on DCT/motion compensation
53 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
54 compatible stream.
55
56 This package contains also ffmpeg shared libraries (libavcodec and
57 libavformat).
58
59 %description -l pl
60 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
61 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
62 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
63 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
64 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
65 strumienia kompatybilnego z AC3.
66
67 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
68 libavformat).
69
70 %package devel
71 Summary:        ffmpeg header files
72 Summary(pl):    Pliki nag³ówkowe ffmpeg
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Obsoletes:      libpostproc-devel
76
77 %description devel
78 ffmpeg header files.
79
80 %description devel -l pl
81 Pliki nag³ówkowe ffmpeg.
82
83 %package static
84 Summary:        ffmpeg static libraries
85 Summary(pl):    Statyczne biblioteki ffmpeg
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 ffmpeg static libraries (libavcodec and libavformat).
91
92 %description static -l pl
93 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
94
95 %package ffplay
96 Summary:        FFplay - SDL-based media player
97 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
98 Group:          Applications/Multimedia
99 Requires:       %{name} = %{version}-%{release}
100
101 %description ffplay
102 FFplay is a very simple and portable media player using the FFmpeg
103 libraries and the SDL library. It is mostly used as a test bench for
104 the various APIs of FFmpeg.
105
106 %description ffplay -l pl
107 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
108 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
109 testowania ró¿nych API FFmpeg.
110
111 %package vhook-imlib2
112 Summary:        imlib2 based hook
113 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
114 Group:          Libraries
115 Requires:       %{name} = %{version}-%{release}
116
117 %description vhook-imlib2
118 This module implements a text overlay for a video image. Currently it
119 supports a fixed overlay or reading the text from a file. The string
120 is passed through strftime so that it is easy to imprint the date and
121 time onto the image.
122
123 %description vhook-imlib2 -l pl
124 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
125 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
126 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
127 obrazie.
128
129 %prep
130 %setup -q -n FFMpeg-%{snap}
131 %patch0 -p1
132 %patch1 -p1
133
134 %build
135 # notes:
136 # - it's not autoconf configure
137 # - -fomit-frame-pointer is always needed on x86 due to lack of registers
138 #   (-fPIC takes one)
139 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
140 ./configure \
141         --prefix=%{_prefix} \
142         --libdir=%{_libdir} \
143         --mandir=%{_mandir} \
144         --disable-strip \
145         --enable-a52bin \
146         --enable-faac \
147         --enable-faadbin \
148         --enable-gpl \
149         --enable-libogg \
150         --enable-mp3lame \
151         --enable-pp \
152         --enable-pthreads \
153         --enable-shared \
154         --enable-shared-pp \
155         --enable-theora \
156         --enable-vorbis \
157         --enable-xvid \
158 %ifnarch %{ix86}
159         --disable-mmx \
160 %endif
161 %ifarch i386 i486
162         --disable-mmx \
163 %endif
164         --cc="%{__cc}" \
165         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
166         --extra-ldflags="%{rpmldflags}" \
167         --disable-debug \
168         --disable-opts \
169         --tune=generic
170
171 %{__make} \
172         BUILD_DOC=yes \
173         LIBVERSION=%{snap}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
183 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post   -p /sbin/ldconfig
189 %postun -p /sbin/ldconfig
190
191 %files
192 %defattr(644,root,root,755)
193 %doc Changelog README doc/*.html
194 %attr(755,root,root) %{_bindir}/ffmpeg
195 %attr(755,root,root) %{_sbindir}/ffserver
196 %attr(755,root,root) %{_libdir}/libavcodec-*.so
197 %attr(755,root,root) %{_libdir}/libavformat-*.so
198 %attr(755,root,root) %{_libdir}/libavutil-*.so
199 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
200 %dir %{_libdir}/vhook
201 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
202 %attr(755,root,root) %{_libdir}/vhook/fish.so
203 %attr(755,root,root) %{_libdir}/vhook/null.so
204 %attr(755,root,root) %{_libdir}/vhook/ppm.so
205 %attr(755,root,root) %{_libdir}/vhook/watermark.so
206 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
207 %{_mandir}/man1/ffmpeg.1*
208 %{_mandir}/man1/ffserver.1*
209
210 %files devel
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/libavcodec.so
213 %attr(755,root,root) %{_libdir}/libavformat.so
214 %attr(755,root,root) %{_libdir}/libavutil.so
215 %attr(755,root,root) %{_libdir}/libpostproc.so
216 %{_libdir}/lib*.la
217 %{_includedir}/ffmpeg
218 %{_includedir}/postproc
219 %{_pkgconfigdir}/*.pc
220
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/lib*.a
224
225 %files ffplay
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_bindir}/ffplay
228 %{_mandir}/man1/ffplay.1*
229
230 %if %{with imlib2}
231 %files vhook-imlib2
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
234 %endif
This page took 0.475091 seconds and 4 git commands to generate.