]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
Suggest some font
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO:
2 # - libtensorflow [-ltensorflow tensorflow/c/c_api.h]
3 # - AMF >= 1.4.4.1 (available at https://github.com/GPUOpen-LibrariesAndSDKs/AMF, where is original source?)
4 #
5 # How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
6 #       1. make-request -r --with bootstrap ffmpeg.spec
7 #       2  bump release of opencv.spec and chromaprint.spec
8 #       3. make-request -r opencv.spec chromaprint.spec
9 #       4. bump release of ffmpeg.spec
10 #       5. make-request -r ffmpeg.spec
11 #
12 # Conditional build:
13 %bcond_with     bootstrap       # disable features to able to build without installed ffmpeg
14 %bcond_with     nonfree         # unblock non free options of package (currently: cuda_nvcc, decklib, fdk_aac, npp, openssl, libressl/libtls)
15 %bcond_without  aribb24         # ARIB text and caption decoding via libaribb24
16 %bcond_without  avs2            # AVS2 de/encoding via libdavs2/libxavs2
17 %bcond_without  bs2b            # BS2B audio filter support
18 %bcond_without  caca            # textual display using libcaca
19 %bcond_without  codec2          # codec2 support using libcodec2
20 %bcond_without  chromaprint     # audio fingerprinting with chromaprint
21 %bcond_with     cudasdk         # NVIDIA CUDA code using nvcc from CUDA SDK [BR: cuda.h, non-free]
22 %bcond_without  dav1d           # AV1 decoding via libdav1d
23 %bcond_with     decklink        # Blackmagic DeckLink I/O support (requires nonfree)
24 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
25 %bcond_without  ffnvcodec       # NVIDIA codecs support using ffnvcodec headers (covered: cuda cuvid nvdec nvenc)
26 %bcond_without  flite           # flite voice synthesis support
27 %bcond_without  frei0r          # frei0r video filtering
28 %bcond_without  fribidi         # fribidi support
29 %bcond_without  gme             # Game Music Emu support
30 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
31 %bcond_without  kvazaar         # Kvazaar HEVC encoder support
32 %bcond_without  ladspa          # LADSPA audio filtering
33 %bcond_without  lensfun         # lensfun lens correction
34 %bcond_with     libdrm          # Linux Direct Rendering Manager code
35 %bcond_with     libklvanc       # Kernel Labs VANC processing (in decklink driver)
36 %bcond_without  libmysofa       # sofalizer filter
37 %bcond_with     librsvg         # SVG rasterization via librsvg
38 %bcond_with     libxml2         # XML parsing using libxml2
39 %bcond_without  lv2             # LV2 audio filtering
40 %bcond_with     mfx             # MFX hardware acceleration support
41 %bcond_with     npp             # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
42 %bcond_without  omx             # OpenMAX IL support
43 %bcond_without  openal          # OpenAL 1.1 capture support
44 %bcond_without  opencl          # OpenCL 1.2 code
45 %bcond_without  opencv          # OpenCV video filtering
46 %bcond_without  opengl          # OpenGL rendering support
47 %bcond_with     openh264        # OpenH264 H.264 encoder
48 %bcond_without  openmpt         # OpenMPT module decoder
49 %bcond_with     pocketsphinx    # asr filter using PocketSphinx
50 %bcond_without  pulseaudio      # PulseAudio input support
51 %bcond_with     rkmpp           # Rockchip Media Process Platform code [implies libdrm]
52 %bcond_without  rubberband      # rubberband filter
53 %bcond_without  shine           # shine fixed-point MP3 encoder
54 %bcond_without  snappy          # Snappy compression support (needed for hap encoding)
55 %bcond_without  srt             # Haivision SRT protocol support
56 %bcond_without  ssh             # SFTP protocol support via libssh
57 %bcond_with     smb             # SMB support via libsmbclient
58 %bcond_without  soxr            # SoX Resampler support
59 %bcond_with     tesseract       # OCR filter based on Tesseract
60 %bcond_without  vmaf            # VMAF filter support
61 %bcond_without  x264            # H.264 x264 encoder
62 %bcond_without  x265            # H.265/HEVC x265 encoder
63 %bcond_without  va              # VAAPI (Video Acceleration API)
64 %bcond_without  vapoursynth     # VapourSynth demuxer
65 %bcond_without  vidstab         # vid.stab video stabilization support
66 %bcond_without  vpx             # VP8, a high-quality video codec
67 %bcond_without  wavpack         # wavpack encoding support
68 %bcond_without  webp            # WebP encoding support
69 %bcond_without  zimg            # zscale filter based on z.lib
70 %bcond_without  zmq             # 0MQ message passing
71 %bcond_without  zvbi            # teletext via libzvbi
72 %bcond_without  doc             # don't build docs
73 %bcond_with     tests           # "make check" (some tests fail as of 2.5)
74
75 %if %{with bootstrap}
76 %undefine       with_opencv
77 %undefine       with_chromaprint
78 %endif
79 %if %{with rkmpp}
80 %define         with_libdrm     1
81 %endif
82
83 %ifnarch %{ix86} %{x8664}
84 %undefine       with_ffnvcodec
85 %endif
86 %ifnarch %{ix86} %{x8664} %{arm}
87 %undefine       with_x265
88 %endif
89 %ifarch i386 i486
90 %undefine       with_x265
91 %endif
92 Summary:        FFmpeg - a very fast video and audio converter
93 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
94 Name:           ffmpeg
95 Version:        4.2.2
96 Release:        2
97 # LGPL or GPL, chosen at configure time (GPL version is more featured)
98 # GPL: frei0r libcdio libdavs2 rubberband vidstab x264 x265 xavs xavs2 xvid
99 # v3 (allows *GPLv3 or Apache-licensed libs): gmp lensfun opencore-amr vmaf vo-*enc rkmpp
100 # GPLv3: smbclient
101 License:        GPL v3+ with LGPL v3+ parts
102 Group:          Applications/Multimedia
103 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
104 # Source0-md5:  348956fc2faa57a2f79bbb84ded9fbc3
105 Patch0:         %{name}-omx-libnames.patch
106 URL:            http://www.ffmpeg.org/
107 %{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.9.5}
108 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
109 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
110 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
111 # libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
112 %{?with_omx:BuildRequires:      OpenMAX-IL-devel}
113 BuildRequires:  SDL2-devel >= 2.0.1
114 BuildRequires:  SDL2-devel < 2.1.0
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  aom-devel >= 1.0.0
117 %{?with_aribb24:BuildRequires:  aribb24-devel}
118 BuildRequires:  bzip2-devel
119 BuildRequires:  celt-devel >= 0.11.0
120 %{?with_codec2:BuildRequires:   codec2-devel}
121 %{?with_dav1d:BuildRequires:    dav1d-devel >= 0.2.1}
122 %{?with_avs2:BuildRequires:     davs2-devel >= 1.6}
123 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
124 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
125 BuildRequires:  fontconfig-devel
126 BuildRequires:  freetype-devel
127 %{?with_frei0r:BuildRequires:   frei0r-devel}
128 %{?with_fribidi:BuildRequires:  fribidi-devel}
129 %{?with_gme:BuildRequires:      game-music-emu-devel}
130 %ifarch ppc
131 # require version with altivec support fixed
132 BuildRequires:  gcc >= 5:3.3.2-3
133 %endif
134 BuildRequires:  gmp-devel
135 BuildRequires:  gnutls-devel
136 BuildRequires:  jack-audio-connection-kit-devel
137 %{?with_kvazaar:BuildRequires:  kvazaar-devel >= 0.8.1}
138 %{?with_ladspa:BuildRequires:   ladspa-devel}
139 BuildRequires:  lame-libs-devel >= 3.98.3
140 %{?with_lensfun:BuildRequires:  lensfun-devel}
141 BuildRequires:  libass-devel
142 BuildRequires:  libavc1394-devel
143 %{?with_bs2b:BuildRequires:     libbs2b-devel}
144 BuildRequires:  libbluray-devel
145 %{?with_caca:BuildRequires:     libcaca-devel}
146 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
147 %{?with_chromaprint:BuildRequires:      libchromaprint-devel}
148 BuildRequires:  libcrystalhd-devel
149 BuildRequires:  libdc1394-devel >= 2
150 %{?with_libdrm:BuildRequires:   libdrm-devel}
151 BuildRequires:  libgsm-devel
152 BuildRequires:  libiec61883-devel
153 %{?with_libklvanc:BuildRequires:        libklvanc-devel}
154 BuildRequires:  libmodplug-devel
155 %{?with_libmysofa:BuildRequires:        libmysofa-devel >= 0.7}
156 %{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.4.5}
157 BuildRequires:  libraw1394-devel >= 2
158 %{?with_librsvg:BuildRequires:  librsvg-devel >= 2}
159 BuildRequires:  librtmp-devel
160 %{?with_ssh:BuildRequires:      libssh-devel}
161 %{?with_smb:BuildRequires:      libsmbclient-devel}
162 BuildRequires:  libtheora-devel >= 1.0-0.beta3
163 BuildRequires:  libtool >= 2:1.4d-3
164 BuildRequires:  libv4l-devel
165 %if %{with va}
166 BuildRequires:  libva-devel >= 1.0.3
167 BuildRequires:  libva-drm-devel >= 1.0.3
168 BuildRequires:  libva-x11-devel >= 1.0.3
169 %endif
170 BuildRequires:  libvdpau-devel >= 0.2
171 BuildRequires:  libvorbis-devel
172 %{?with_vpx:BuildRequires:      libvpx-devel >= 1.4.0}
173 %{?with_webp:BuildRequires:     libwebp-devel >= 0.4.0}
174 # X264_BUILD >= 118
175 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
176 # X265_BUILD >= 68
177 %{?with_x265:BuildRequires:     libx265-devel >= 1.8}
178 # libxcb xcb-shm xcb-xfixes xcb-shape
179 BuildRequires:  libxcb-devel >= 1.4
180 %{?with_libxml2:BuildRequires:  libxml2-devel >= 2}
181 %{?with_lv2:BuildRequires:      lilv-devel}
182 %{?with_lv2:BuildRequires:      lv2-devel}
183 %{?with_mfx:BuildRequires:      mfx_dispatch-devel}
184 %ifarch %{ix86}
185 %ifnarch i386 i486
186 BuildRequires:  nasm
187 %endif
188 %endif
189 %{?with_ffnvcodec:BuildRequires:        nv-codec-headers >= 9.0.18.0}
190 # amrnb,amrwb
191 BuildRequires:  opencore-amr-devel
192 %{?with_opencv:BuildRequires:   opencv-devel >= 2}
193 %{?with_openh264:BuildRequires: openh264-devel >= 1.3}
194 BuildRequires:  openjpeg2-devel >= 2.1
195 BuildRequires:  opus-devel
196 BuildRequires:  perl-Encode
197 BuildRequires:  perl-tools-pod
198 %{?with_pocketsphinx:BuildRequires:     pocketsphinx-devel > 0.8}
199 BuildRequires:  pkgconfig
200 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
201 %{?with_rkmpp:BuildRequires:    rockchip-mpp-devel >= 1.3.7}
202 BuildRequires:  rpmbuild(macros) >= 1.470
203 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.8.1}
204 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
205 %{?with_snappy:BuildRequires:   snappy-devel}
206 %{?with_soxr:BuildRequires:     soxr-devel}
207 BuildRequires:  speex-devel >= 1:1.2-rc1
208 %{?with_srt:BuildRequires:      srt-devel >= 1.3}
209 %{?with_tesseract:BuildRequires:        tesseract-devel}
210 %{?with_doc:BuildRequires:      tetex}
211 %{?with_doc:BuildRequires:      texi2html}
212 %{?with_doc:BuildRequires:      texinfo}
213 BuildRequires:  twolame-devel >= 0.3.10
214 %{?with_vapoursynth:BuildRequires:      vapoursynth-devel >= 42}
215 %{?with_vidstab:BuildRequires:  vid.stab-devel >= 0.98}
216 %{?with_vmaf:BuildRequires:     vmaf-devel >= 1.3.9}
217 BuildRequires:  vo-amrwbenc-devel
218 %{?with_wavpack:BuildRequires:  wavpack-devel}
219 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
220 BuildRequires:  xavs-devel
221 %{?with_avs2:BuildRequires:     xavs2-devel >= 1.3}
222 BuildRequires:  xorg-lib-libX11-devel
223 BuildRequires:  xorg-lib-libXext-devel
224 BuildRequires:  xorg-lib-libXv-devel
225 BuildRequires:  xvid-devel >= 1:1.1.0
226 BuildRequires:  xz-devel
227 BuildRequires:  yasm
228 %{?with_zmq:BuildRequires:      zeromq-devel}
229 %{?with_zimg:BuildRequires:     zimg-devel >= 2.7.0}
230 BuildRequires:  zlib-devel
231 %{?with_zvbi:BuildRequires:     zvbi-devel >= 0.2.28}
232 %{?with_autoreqdep:BuildConflicts:      libpostproc}
233 # overflows maximum hash table size
234 BuildConflicts: pdksh < 5.2.14-57
235 Requires:       %{name}-libs = %{version}-%{release}
236 Suggests:       fontconfig
237 Suggests:       fonts-TTF-Roboto
238 Obsoletes:      libpostproc
239 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
240
241 %define         specflags       -fno-strict-aliasing
242
243 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
244 %define         specflags_ia32  -fomit-frame-pointer
245 # -mmmx is needed to enable <mmintrin.h> code.
246 %define         specflags_i586  -mmmx
247 %define         specflags_i686  -mmmx
248 %define         specflags_ppc   -fPIC
249
250 %description
251 FFmpeg is a complete solution to record, convert and stream audio and
252 video. It is a command line tool to convert one video file format to
253 another. It also supports grabbing and encoding in real time from a TV
254 card.
255
256 %description -l pl.UTF-8
257 FFmpeg to kompletne rozwiÄ…zanie nagrywania, konwersji i transmisji
258 strumieni dźwiÄ™ku i obrazu. Jest to dziaÅ‚ajÄ…ce z linii poleceÅ„
259 narzÄ™dzie do konwersji obrazu z jednego formatu do innego. ObsÅ‚uguje
260 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
261 telewizyjnej.
262
263 %package libs
264 Summary:        ffmpeg libraries
265 Summary(pl.UTF-8):      Biblioteki ffmpeg
266 Group:          Libraries
267 Requires:       SDL2 >= 2.0.1
268 Requires:       aom >= 1.0.0
269 Requires:       celt >= 0.11.0
270 %{?with_dav1d:Requires: dav1d >= 0.2.1}
271 %{?with_avs2:Requires:  davs2 >= 1.6}
272 %{?with_flite:Requires: flite >= 1.4}
273 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
274 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
275 Requires:       gnutls-libs >= 3.0.20
276 %endif
277 %{?with_kvazaar:Requires:       kvazaar-libs >= 0.8.1}
278 %{?with_libmysofa:Requires:     libmysofa >= 0.7}
279 %{?with_openmpt:Requires: libopenmpt >= 0.4.5}
280 Requires:       libtheora >= 1.0-0.beta3
281 %if %{with va}
282 Requires:       libva >= 1.0.3
283 Requires:       libva-drm >= 1.0.3
284 Requires:       libva-x11 >= 1.0.3
285 %endif
286 Requires:       libvdpau >= 0.2
287 %{?with_vpx:Requires:   libvpx >= 1.4.0}
288 %{?with_webp:Requires:  libwebp >= 0.4.0}
289 %{?with_x264:Requires:  libx264 >= 0.1.3-1.20111212_2245}
290 %{?with_x265:Requires:  libx265 >= 1.8}
291 Requires:       libxcb >= 1.4
292 Requires:       lame-libs >= 3.98.3
293 %{?with_openh264:Requires:      openh264 >= 1.3}
294 Requires:       openjpeg2 >= 2.1
295 %{?with_rkmpp:Requires: rockchip-mpp >= 1.3.7}
296 %{?with_rubberband:Requires:    rubberband-libs >= 1.8.1}
297 %{?with_shine:Requires: shine >= 3.0.0}
298 Requires:       speex >= 1:1.2-rc1
299 %{?with_srt:Requires:   srt >= 1.3}
300 Requires:       twolame-libs >= 0.3.10
301 %{?with_vapoursynth:Requires:   vapoursynth >= 42}
302 %{?with_vidstab:Requires:       vid.stab >= 0.98}
303 %{?with_vmaf:Requires:  vmaf-libs >= 1.3.9}
304 %{?with_avs2:Requires:  xavs2 >= 1.3}
305 Requires:       xvid >= 1:1.1.0
306 %{?with_zimg:Requires:  zimg >= 2.7.0}
307 %{?with_zvbi:Requires:  zvbi >= 0.2.28}
308
309 %description libs
310 This package contains the ffmpeg shared libraries:
311 - the codec library (libavcodec). It supports most existing encoding
312   formats (MPEG, DivX, MPEG4, AC3, DV...),
313 - demuxer library (libavformat). It supports most existing file
314   formats (AVI, MPEG, OGG, Matroska, ASF...),
315 - video postprocessing library (libpostproc).
316
317 %description libs -l pl.UTF-8
318 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
319 - bibliotekÄ™ kodeków (libavcodec); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
320   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
321 - bibliotekÄ™ demuksera (libavformat); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
322   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
323 - bibliotekÄ™ postprocessingu (libpostproc).
324
325 %package devel
326 Summary:        ffmpeg header files
327 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
328 Group:          Development/Libraries
329 Requires:       %{name}-libs = %{version}-%{release}
330 # Libs.private from *.pc
331 %{?with_openal:Requires:        OpenAL-devel >= 1.1}
332 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
333 %{?with_opengl:Requires:        OpenGL-devel}
334 Requires:       SDL2-devel >= 2.0.1
335 Requires:       alsa-lib-devel
336 Requires:       aom-devel >= 1.0.0
337 %{?with_aribb24:Requires:       aribb24-devel}
338 %{?with_avs2:Requires:  davs2-devel >= 1.6}
339 Requires:       bzip2-devel
340 Requires:       celt-devel >= 0.11.0
341 %{?with_codec2:Requires:        codec2-devel}
342 %{?with_dav1d:Requires: dav1d-devel >= 0.2.1}
343 %{?with_fdk_aac:Requires:       fdk-aac-devel}
344 %{?with_flite:Requires: flite-devel >= 1.4}
345 Requires:       fontconfig-devel
346 Requires:       freetype-devel
347 %{?with_fribidi:Requires:       fribidi-devel}
348 %{?with_gme:Requires:   game-music-emu-devel}
349 Requires:       gnutls-devel
350 Requires:       jack-audio-connection-kit-devel
351 %{?with_kvazaar:Requires:       kvazaar-devel >= 0.8.1}
352 Requires:       lame-libs-devel >= 3.98.3
353 %{?with_lensfun:Requires:       lensfun-devel}
354 Requires:       libass-devel
355 Requires:       libavc1394-devel
356 Requires:       libbluray-devel
357 %{?with_bs2b:Requires:  libbs2b-devel}
358 %{?with_caca:Requires:  libcaca-devel}
359 Requires:       libcdio-paranoia-devel >= 0.90-2
360 %{?with_chromaprint:Requires:   libchromaprint-devel}
361 Requires:       libcrystalhd-devel
362 Requires:       libdc1394-devel >= 2
363 %{?with_libdrm:Requires:        libdrm-devel}
364 Requires:       libgsm-devel
365 Requires:       libiec61883-devel
366 %{?with_libklvanc:Requires:     libklvanc-devel}
367 Requires:       libmodplug-devel
368 %{?with_libmysofa:Requires:     libmysofa-devel >= 0.7}
369 %{?with_openmpt:Requires: libopenmpt-devel >= 0.4.5}
370 Requires:       libraw1394-devel >= 2
371 %{?with_librsvg:Requires:       librsvg-devel >= 2}
372 Requires:       librtmp-devel
373 %{?with_smb:Requires:   libsmbclient-devel}
374 %{?with_ssh:Requires:   libssh-devel}
375 Requires:       libstdc++-devel
376 Requires:       libtheora-devel >= 1.0-0.beta3
377 Requires:       libv4l-devel
378 %{?with_va:Requires:    libva-devel >= 1.0.3}
379 %{?with_va:Requires:    libva-drm-devel >= 1.0.3}
380 %{?with_va:Requires:    libva-x11-devel >= 1.0.3}
381 Requires:       libvdpau-devel >= 0.2
382 Requires:       libvorbis-devel
383 %{?with_vpx:Requires:   libvpx-devel >= 1.4.0}
384 %{?with_webp:Requires:  libwebp-devel >= 0.4.0}
385 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
386 %{?with_x265:Requires:  libx265-devel >= 1.8}
387 # libxcb xcb-shm xcb-xfixes xcb-shape
388 Requires:       libxcb-devel >= 1.4
389 %{?with_libxml2:Requires:       libxml2-devel >= 2}
390 %{?with_lv2:Requires:   lilv-devel}
391 %{?with_mfx:Requires:   mfx_dispatch-devel}
392 Requires:       opencore-amr-devel
393 %{?with_opencv:Requires:        opencv-devel >= 2}
394 %{?with_openh264:Requires:      openh264-devel >= 1.3}
395 Requires:       openjpeg2-devel >= 2.1
396 Requires:       opus-devel
397 %{?with_pulseaudio:Requires:    pulseaudio-devel}
398 %{?with_rkmpp:Requires: rockchip-mpp-devel >= 1.3.7}
399 %{?with_rubberband:Requires:    rubberband-devel >= 1.8.1}
400 %{?with_shine:Requires: shine-devel >= 3.0.0}
401 %{?with_snappy:Requires:        snappy-devel}
402 %{?with_soxr:Requires:  soxr-devel}
403 Requires:       speex-devel >= 1:1.2-rc1
404 %{?with_srt:Requires:   srt-devel >= 1.3}
405 %{?with_tesseract:Requires:     tesseract-devel}
406 Requires:       twolame-devel >= 0.3.10
407 %{?with_vapoursynth:Requires:   vapoursynth-devel >= 42}
408 %{?with_vidstab:Requires:       vid.stab-devel >= 0.98}
409 Requires:       vo-amrwbenc-devel
410 %{?with_vmaf:Requires:  vmaf-devel >= 1.3.9}
411 %{?with_wavpack:Requires:       wavpack-devel}
412 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
413 Requires:       xavs-devel
414 %{?with_avs2:Requires:  xavs2-devel >= 1.3}
415 Requires:       xorg-lib-libX11-devel
416 Requires:       xorg-lib-libXext-devel
417 Requires:       xorg-lib-libXv-devel
418 Requires:       xvid-devel >= 1:1.1.0
419 Requires:       xz-devel
420 %{?with_zmq:Requires:   zeromq-devel}
421 %{?with_zimg:Requires:  zimg-devel >= 2.7.0}
422 Requires:       zlib-devel
423 %{?with_zvbi:Requires:  zvbi-devel >= 0.2.28}
424 Obsoletes:      libpostproc-devel
425
426 %description devel
427 ffmpeg header files.
428
429 %description devel -l pl.UTF-8
430 Pliki nagłówkowe ffmpeg.
431
432 %package static
433 Summary:        ffmpeg static libraries
434 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
435 Group:          Development/Libraries
436 Requires:       %{name}-devel = %{version}-%{release}
437
438 %description static
439 ffmpeg static libraries (libavcodec and libavformat).
440
441 %description static -l pl.UTF-8
442 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
443
444 %package ffplay
445 Summary:        FFplay - SDL-based media player
446 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
447 Group:          Applications/Multimedia
448 Requires:       %{name}-libs = %{version}-%{release}
449
450 %description ffplay
451 FFplay is a very simple and portable media player using the FFmpeg
452 libraries and the SDL library. It is mostly used as a test bench for
453 the various APIs of FFmpeg.
454
455 %description ffplay -l pl.UTF-8
456 FFplay to bardzo prosty i przenoÅ›ny odtwarzacz mediów używajÄ…cy
457 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
458 testowania różnych API FFmpeg.
459
460 %package doc
461 Summary:        FFmpeg documentation in HTML format
462 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
463 Group:          Documentation
464 %if "%{_rpmversion}" >= "5"
465 BuildArch:      noarch
466 %endif
467
468 %description doc
469 FFmpeg documentation in HTML format.
470
471 %description doc -l pl.UTF-8
472 Dokumentacja pakietu FFmpeg w formacie HTML.
473
474 %prep
475 %setup -q
476 %patch0 -p1
477
478 # package the grep result for mplayer, the result formatted as ./mplayer/configure
479 cat <<EOF > ffmpeg-avconfig
480 #! /bin/sh
481 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
482 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
483 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
484 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
485 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
486 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
487 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
488 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
489 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
490 EOF
491 cat <<'EOF' >> ffmpeg-avconfig
492
493 case "$1" in
494 --decoders)
495         echo $libavdecoders_all
496         ;;
497 --encoders)
498         echo $libavencoders_all
499         ;;
500 --parsers)
501         echo $libavparsers_all
502         ;;
503 --bsfs)
504         echo $libavbsfs_all
505         ;;
506 --demuxers)
507         echo $libavdemuxers_all
508         ;;
509 --muxers)
510         echo $libavmuxers_all
511         ;;
512 --protocols)
513         echo $libavprotocols_all
514         ;;
515 --hwaccels)
516         echo $libavhwaccels_all
517         ;;
518 --filters)
519         echo $libavfilters_all
520         ;;
521 *)
522         cat <<USAGE
523 Usage: $0 [OPTION]
524 Options:
525   --decoders
526   --encoders
527   --parsers
528   --bsfs
529   --demuxers
530   --muxers
531   --protocols
532   --hwaccels
533   --filters
534 USAGE
535         exit 1;;
536 esac
537
538 exit 0
539 EOF
540
541 %build
542 # notes:
543 # - it's not autoconf configure
544 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
545 ./configure \
546         --arch=%{_target_base_arch} \
547         --prefix=%{_prefix} \
548         --libdir=%{_libdir} \
549         --shlibdir=%{_libdir} \
550         --mandir=%{_mandir} \
551         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
552         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
553         --cc="%{__cc}" \
554         --disable-debug \
555         --disable-optimizations \
556         --disable-stripping \
557         %{!?with_doc:--disable-doc} \
558         --enable-avfilter \
559         --enable-avresample \
560         %{?with_chromaprint:--enable-chromaprint} \
561         %{?with_cudasdk:--enable-cuda-nvcc} \
562         %{?with_decklink:--enable-decklink} \
563         %{!?with_ffnvcodec:--disable-ffnvcodec} \
564         --enable-gnutls \
565         --enable-gpl \
566         --enable-version3 \
567         %{?with_frei0r:--enable-frei0r} \
568         %{?with_ladspa:--enable-ladspa} \
569         --enable-libaom \
570         %{?with_aribb24:--enable-libaribb24} \
571         --enable-libass \
572         --enable-libbluray \
573         %{?with_bs2b:--enable-libbs2b} \
574         %{?with_caca:--enable-libcaca} \
575         --enable-libcelt \
576         --enable-libcdio \
577         %{?with_codec2:--enable-libcodec2} \
578         %{?with_dav1d:--enable-libdav1d} \
579         %{?with_avs2:--enable-libdavs2} \
580         --enable-libdc1394 \
581         %{?with_libdrm:--enable-libdrm} \
582         %{?with_flite:--enable-libflite} \
583         --enable-libfontconfig \
584         --enable-libfreetype \
585         %{?with_fribidi:--enable-libfribidi} \
586         %{?with_gme:--enable-libgme} \
587         --enable-libgsm \
588         --enable-libiec61883 \
589         %{?with_ilbc:--enable-libilbc} \
590         --enable-libjack \
591         %{?with_kvazaar:--enable-libkvazaar} \
592         %{?with_libklvanc:--enable-libklvanc} \
593         %{?with_lensfun:--enable-liblensfun} \
594         %{?with_mfx:--enable-libmfx} \
595         --enable-libmodplug \
596         --enable-libmp3lame \
597         %{?with_libmysofa:--enable-libmysofa} \
598         --enable-libopencore-amrnb \
599         --enable-libopencore-amrwb \
600         %{?with_opencv:--enable-libopencv} \
601         %{?with_openh264:--enable-libopenh264} \
602         --enable-libopenjpeg \
603         %{?with_openmpt:--enable-libopenmpt} \
604         --enable-libopus \
605         %{?with_pulseaudio:--enable-libpulse} \
606         %{?with_librsvg:--enable-librsvg} \
607         --enable-librtmp \
608         %{?with_srt:--enable-libsrt} \
609         %{?with_libxml2:--enable-libxml2} \
610         %{?with_rubberband:--enable-librubberband} \
611         %{?with_shine:--enable-libshine} \
612         %{?with_smb:--enable-libsmbclient} \
613         %{?with_snappy:--enable-libsnappy} \
614         %{?with_soxr:--enable-libsoxr} \
615         --enable-libspeex \
616         %{?with_ssh:--enable-libssh} \
617         %{?with_tesseract:--enable-libtesseract} \
618         --enable-libtheora \
619         --enable-libtwolame \
620         --enable-libv4l2 \
621         %{?with_vidstab:--enable-libvidstab} \
622         %{?with_vmaf:--enable-libvmaf} \
623         --enable-libvo-amrwbenc \
624         --enable-libvorbis \
625         %{?with_vpx:--enable-libvpx} \
626         %{?with_wavpack:--enable-libwavpack} \
627         %{?with_webp:--enable-libwebp} \
628         %{?with_x264:--enable-libx264} \
629         %{?with_x265:--enable-libx265} \
630         --enable-libxavs \
631         %{?with_avs2:--enable-libxavs2} \
632         --enable-libxcb \
633         --enable-libxvid \
634         %{?with_zimg:--enable-libzimg} \
635         %{?with_zmq:--enable-libzmq} \
636         %{?with_zvbi:--enable-libzvbi} \
637         %{?with_lv2:--enable-lv2} \
638         %{?with_omx:--enable-omx} \
639         %{?with_openal:--enable-openal} \
640         %{?with_opencl:--enable-opencl} \
641         %{?with_opengl:--enable-opengl} \
642         %{?with_pocketsphinx:--enable-pocketsphinx} \
643         --enable-postproc \
644         --enable-pthreads \
645         %{?with_rkmpp:--enable-rkmpp} \
646         --enable-shared \
647         --enable-swscale \
648         %{!?with_va:--disable-vaapi} \
649         %{?with_vapoursynth:--enable-vapoursynth} \
650 %ifnarch %{ix86} %{x8664}
651         --disable-mmx \
652 %endif
653 %ifarch i386 i486
654         --disable-mmx \
655 %endif
656 %ifarch x32
657         --disable-asm \
658 %endif
659 %if %{with nonfree}
660         --enable-nonfree \
661         %{?with_fdk_aac:--enable-libfdk-aac} \
662         %{?with_npp:--enable-libnpp} \
663 %endif
664         --enable-runtime-cpudetect
665
666 %{__make} \
667         V=1
668
669 # CC_O to add -c to commandline. makefile should be patched
670 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
671
672 %{?with_tests:%{__make} check V=1}
673
674 %install
675 rm -rf $RPM_BUILD_ROOT
676 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
677         $RPM_BUILD_ROOT%{_includedir}/ffmpeg
678
679 %{__make} install install-headers \
680         DESTDIR=$RPM_BUILD_ROOT \
681         V=1
682
683 # install nonstandard, non-public headers manually
684 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
685 for a in libavutil/*/{asm,bswap}.h; do
686         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
687 done
688 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
689
690 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
691
692 # install as ffmpeg-avconfig to avoid with possible programs looking for
693 # ffmpeg-config and expecting --libs output from it which is not implemented
694 # simple to do (by querying pkgconfig), but why?
695 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
696
697 # packaged as %doc in -doc
698 %if %{with doc}
699 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
700 %endif
701
702 install -d $RPM_BUILD_ROOT%{_examplesdir}
703 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
704
705 %clean
706 rm -rf $RPM_BUILD_ROOT
707
708 %post   libs -p /sbin/ldconfig
709 %postun libs -p /sbin/ldconfig
710
711 %files
712 %defattr(644,root,root,755)
713 %doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
714 %attr(755,root,root) %{_bindir}/ffmpeg
715 %attr(755,root,root) %{_bindir}/ffprobe
716 %attr(755,root,root) %{_bindir}/qt-faststart
717 %dir %{_datadir}/ffmpeg
718 %{_datadir}/ffmpeg/*.ffpreset
719 %{_datadir}/ffmpeg/ffprobe.xsd
720 %if %{with doc}
721 %{_mandir}/man1/ffmpeg.1*
722 %{_mandir}/man1/ffmpeg-all.1*
723 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
724 %{_mandir}/man1/ffmpeg-codecs.1*
725 %{_mandir}/man1/ffmpeg-devices.1*
726 %{_mandir}/man1/ffmpeg-filters.1*
727 %{_mandir}/man1/ffmpeg-formats.1*
728 %{_mandir}/man1/ffmpeg-protocols.1*
729 %{_mandir}/man1/ffmpeg-resampler.1*
730 %{_mandir}/man1/ffmpeg-scaler.1*
731 %{_mandir}/man1/ffmpeg-utils.1*
732 %{_mandir}/man1/ffprobe.1*
733 %{_mandir}/man1/ffprobe-all.1*
734 %endif
735
736 %files libs
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
740 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
742 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
744 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
746 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
747 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
748 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
750 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
751 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
752 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
753 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
754 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
755 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
756
757 %files devel
758 %defattr(644,root,root,755)
759 %doc doc/optimization.txt
760 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
761 %attr(755,root,root) %{_libdir}/libavcodec.so
762 %attr(755,root,root) %{_libdir}/libavdevice.so
763 %attr(755,root,root) %{_libdir}/libavfilter.so
764 %attr(755,root,root) %{_libdir}/libavformat.so
765 %attr(755,root,root) %{_libdir}/libavresample.so
766 %attr(755,root,root) %{_libdir}/libavutil.so
767 %attr(755,root,root) %{_libdir}/libpostproc.so
768 %attr(755,root,root) %{_libdir}/libswresample.so
769 %attr(755,root,root) %{_libdir}/libswscale.so
770 %{_includedir}/ffmpeg
771 %{_includedir}/libavcodec
772 %{_includedir}/libavdevice
773 %{_includedir}/libavfilter
774 %{_includedir}/libavformat
775 %{_includedir}/libavresample
776 %{_includedir}/libavutil
777 %{_includedir}/libpostproc
778 %{_includedir}/libswresample
779 %{_includedir}/libswscale
780 %{_pkgconfigdir}/libavcodec.pc
781 %{_pkgconfigdir}/libavdevice.pc
782 %{_pkgconfigdir}/libavfilter.pc
783 %{_pkgconfigdir}/libavformat.pc
784 %{_pkgconfigdir}/libavresample.pc
785 %{_pkgconfigdir}/libavutil.pc
786 %{_pkgconfigdir}/libpostproc.pc
787 %{_pkgconfigdir}/libswresample.pc
788 %{_pkgconfigdir}/libswscale.pc
789 %if %{with doc}
790 %{_mandir}/man3/libavcodec.3*
791 %{_mandir}/man3/libavdevice.3*
792 %{_mandir}/man3/libavfilter.3*
793 %{_mandir}/man3/libavformat.3*
794 %{_mandir}/man3/libavutil.3*
795 %{_mandir}/man3/libswresample.3*
796 %{_mandir}/man3/libswscale.3*
797 %endif
798 %{_examplesdir}/%{name}-%{version}
799
800 %files static
801 %defattr(644,root,root,755)
802 %{_libdir}/libavcodec.a
803 %{_libdir}/libavdevice.a
804 %{_libdir}/libavfilter.a
805 %{_libdir}/libavformat.a
806 %{_libdir}/libavresample.a
807 %{_libdir}/libavutil.a
808 %{_libdir}/libpostproc.a
809 %{_libdir}/libswresample.a
810 %{_libdir}/libswscale.a
811
812 %files ffplay
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_bindir}/ffplay
815 %if %{with doc}
816 %{_mandir}/man1/ffplay.1*
817 %{_mandir}/man1/ffplay-all.1*
818 %endif
819
820 %if %{with doc}
821 %files doc
822 %defattr(644,root,root,755)
823 %doc doc/*.html
824 %endif
This page took 0.523746 seconds and 3 git commands to generate.