]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- spaces -> tabs
[packages/ffmpeg.git] / ffmpeg.spec
1
2 # Conditional build:
3 # _without_imlib        - we can safetly play without it :-)
4
5
6 Summary:        Realtime audio/video encoder and streaming server
7 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
8 Name:           ffmpeg
9 Version:        0.4.6
10 Release:        1
11 License:        LGPL/GPL
12 Group:          Daemons
13 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}.tar.gz
14 # Source0-md5: bdd96d28327d3abe02e886c13e633878
15 Patch0:         %{name}-opt.patch
16 Patch1:         %{name}-imlib2.patch
17 Patch2:         %{name}-libtool.patch
18 URL:            http://ffmpeg.sourceforge.net/
19 %{!?_without_imlib:BuildRequires:       imlib2-devel}
20 BuildRequires:  libtool >= 2:1.4d-3
21 %ifarch i586 i686 athlon
22 BuildRequires:  nasm
23 %endif
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 ffmpeg is a hyper fast realtime audio/video encoder and streaming
29 server. It can grab from a standard Video4Linux video source and
30 convert it into several file formats based on DCT/motion compensation
31 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
32 compatible stream.
33
34 This package contains also ffmpeg shared libraries (libavcodec and
35 libavformat).
36
37 %description -l pl
38 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
39 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
40 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
41 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
42 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
43 strumienia kompatybilnego z AC3.
44
45 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
46 libavformat).
47
48 %package vhook-imlib2
49 Summary:        imlib2 based hook
50 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
51 Group:          Libraries
52 Requires:       %{name} = %{version}
53
54 %description vhook-imlib2
55 This module implements a text overlay for a video image. Currently it
56 supports a fixed overlay or reading the text from a file. The string
57 is passed through strftime so that it is easy to imprint the date and
58 time onto the image.
59
60 %description vhook-imlib2 -l pl
61 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
62 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
63 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
64 obrazie.
65
66 %package devel
67 Summary:        ffmpeg header files
68 Summary(pl):    Pliki nag³ówkowe ffmpeg
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}
71
72 %description devel
73 ffmpeg header files.
74
75 %description devel -l pl
76 Pliki nag³ówkowe ffmpeg.
77
78 %package static
79 Summary:        ffmpeg static libraries
80 Summary(pl):    Statyczne biblioteki ffmpeg
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}
83
84 %description static
85 ffmpeg static libraries (libavcodec and libavformat).
86
87 %description static -l pl
88 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95
96 %build
97 # note: it's not autoconf configure
98 ./configure \
99         --prefix=%{_prefix} \
100         --enable-shared \
101         --enable-a52bin \
102 %ifnarch i586 i686 athlon
103         --disable-mmx
104 %endif
105
106 # note: -fomit-frame-pointer is always needed on x86 due to lack of registers
107 #       (-fPIC takes one)
108 %{__make} \
109         CC="%{__cc}" \
110         OPT="%{rpmcflags} -fomit-frame-pointer -I/usr/X11R6/include" \
111         LDOPT="%{rpmldflags} -L/usr/X11R6/lib"
112
113 %{__make} -C doc
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
123 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc Changelog README doc/*.html
134 %attr(755,root,root) %{_bindir}/*
135 %attr(755,root,root) %{_sbindir}/*
136 %attr(755,root,root) %{_libdir}/libavcodec-*.so
137 %attr(755,root,root) %{_libdir}/libavformat-*.so
138 %dir %{_libdir}/vhook
139 %attr(755,root,root) %{_libdir}/vhook/null.so
140 %attr(755,root,root) %{_libdir}/vhook/fish.so
141 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
142
143 %if %{!?_without_imlib:1}0
144 %files vhook-imlib2
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
147 %endif
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libavcodec.so
152 %attr(755,root,root) %{_libdir}/libavformat.so
153 %{_libdir}/lib*.la
154 %{_includedir}/ffmpeg
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
This page took 0.154359 seconds and 3 git commands to generate.