]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
ba8e8c499bbfebac5be16255d2188f8b369dfa82
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # How to deal with ffmpeg/opencv checken-egg problem:
3 #       1. make-request -r --without opencv ffmpeg.spec
4 #       2. make-request -r opencv.spec
5 #       3. bump release of ffmpeg.spec
6 #       4. make-request -r ffmpeg.spec
7 #
8 # Conditional build:
9 %bcond_with     nonfree         # non free options of package (currently: faac)
10 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
11 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
12 %bcond_without  caca            # textual display using libcaca
13 %bcond_without  flite           # flite voice synthesis support
14 %bcond_without  frei0r          # frei0r video filtering
15 %bcond_without  gme             # Game Music Emu support
16 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
17 %bcond_without  ladspa          # LADSPA audio filtering
18 %bcond_without  ssh             # SFTP protocol support via libssh
19 %bcond_without  openal          # OpenAL 1.1 capture support
20 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, not available in Mesa yet]
21 %bcond_without  opencv          # OpenCV video filtering
22 %bcond_without  pulseaudio      # PulseAudio input support
23 %bcond_without  quvi            # quvi input support
24 %bcond_without  shine           # shine fixed-point MP3 encoder
25 %bcond_without  soxr            # SoX Resampler support
26 %bcond_without  x264            # x264 encoder
27 %bcond_without  utvideo         # Ut Video decoder
28 %bcond_without  va              # VAAPI (Video Acceleration API)
29 %bcond_without  vidstab         # vid.stab video stabilization support
30 %bcond_without  vpx             # VP8, a high-quality video codec
31 %bcond_without  wavpack         # wavpack encoding support
32 %bcond_without  zmq             # 0MQ message passing
33 %bcond_without  zvbi            # teletext via libzvbi
34 %bcond_without  doc             # don't build docs
35
36 Summary:        FFmpeg - a very fast video and audio converter
37 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
38 Name:           ffmpeg
39 Version:        2.1.4
40 Release:        1
41 # LGPL or GPL, chosen at configure time (GPL version is more featured)
42 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
43 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
44 License:        GPL v3+ with LGPL v3+ parts
45 Group:          Applications/Multimedia
46 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
47 # Source0-md5:  dedc28003a77c69432c42ab16e5f6982
48 Source1:        ffserver.init
49 Source2:        ffserver.sysconfig
50 Source3:        ffserver.conf
51 Patch0:         %{name}-opencv24.patch
52 URL:            http://www.ffmpeg.org/
53 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
54 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
55 BuildRequires:  SDL-devel >= 1.2.1
56 BuildRequires:  alsa-lib-devel
57 BuildRequires:  bzip2-devel
58 BuildRequires:  celt-devel >= 0.11.0
59 %{?with_nonfree:BuildRequires:  faac-devel}
60 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
61 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
62 BuildRequires:  fontconfig-devel
63 BuildRequires:  freetype-devel
64 %{?with_frei0r:BuildRequires:   frei0r-devel}
65 %{?with_gme:BuildRequires:      game-music-emu-devel}
66 %ifarch ppc
67 # require version with altivec support fixed
68 BuildRequires:  gcc >= 5:3.3.2-3
69 %endif
70 BuildRequires:  gnutls-devel
71 BuildRequires:  jack-audio-connection-kit-devel
72 %{?with_ladspa:BuildRequires:   ladspa-devel}
73 BuildRequires:  lame-libs-devel >= 3.98.3
74 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
75 BuildRequires:  libass-devel
76 BuildRequires:  libavc1394-devel
77 BuildRequires:  libbluray-devel
78 %{?with_caca:BuildRequires:     libcaca-devel}
79 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
80 BuildRequires:  libdc1394-devel >= 2
81 BuildRequires:  libgsm-devel
82 BuildRequires:  libiec61883-devel
83 BuildRequires:  libmodplug-devel
84 BuildRequires:  libnut-devel
85 %{?with_quvi:BuildRequires:     libquvi-devel}
86 BuildRequires:  libraw1394-devel >= 2
87 BuildRequires:  librtmp-devel
88 %{?with_ssh:BuildRequires:      libssh-devel}
89 BuildRequires:  libtheora-devel >= 1.0-0.beta3
90 BuildRequires:  libtool >= 2:1.4d-3
91 BuildRequires:  libv4l-devel
92 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
93 BuildRequires:  libvdpau-devel >= 0.2
94 BuildRequires:  libvorbis-devel
95 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
96 # X264_BUILD >= 118
97 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
98 %ifarch %{ix86}
99 %ifnarch i386 i486
100 BuildRequires:  nasm
101 %endif
102 %endif
103 BuildRequires:  opencore-amr-devel
104 %{?with_opencv:BuildRequires:   opencv-devel}
105 BuildRequires:  openjpeg-devel >= 1.5
106 BuildRequires:  opus-devel
107 BuildRequires:  perl-Encode
108 BuildRequires:  perl-tools-pod
109 BuildRequires:  pkgconfig
110 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
111 BuildRequires:  rpmbuild(macros) >= 1.470
112 BuildRequires:  schroedinger-devel
113 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
114 %{?with_soxr:BuildRequires:     soxr-devel}
115 BuildRequires:  speex-devel >= 1:1.2-rc1
116 %{?with_doc:BuildRequires:      tetex}
117 %{?with_doc:BuildRequires:      texi2html}
118 %{?with_doc:BuildRequires:      texinfo}
119 BuildRequires:  twolame-devel
120 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
121 %{?with_vidstab:BuildRequires:  vid.stab-devel}
122 BuildRequires:  vo-aacenc-devel
123 BuildRequires:  vo-amrwbenc-devel
124 %{?with_wavpack:BuildRequires:  wavpack-devel}
125 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
126 BuildRequires:  xavs-devel
127 BuildRequires:  xorg-lib-libX11-devel
128 BuildRequires:  xorg-lib-libXext-devel
129 BuildRequires:  xorg-lib-libXfixes-devel
130 BuildRequires:  xvid-devel >= 1:1.1.0
131 BuildRequires:  yasm
132 %{?with_zmq:BuildRequires:      zeromq-devel}
133 %{?with_zvbi:BuildRequires:     zvbi-devel}
134 BuildRequires:  zlib-devel
135 %{?with_autoreqdep:BuildConflicts:      libpostproc}
136 # overflows maximum hash table size
137 BuildConflicts: pdksh < 5.2.14-57
138 Requires:       %{name}-libs = %{version}-%{release}
139 %{?with_utvideo:Requires:       utvideo >= 12}
140 %{?with_ilbc:Requires:  webrtc-libilbc}
141 Requires:       xvid >= 1:1.1.0
142 Obsoletes:      libpostproc
143 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
144
145 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
146
147 %define         specflags       -fno-strict-aliasing
148
149 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
150 %define         specflags_ia32  -fomit-frame-pointer
151 # -mmmx is needed to enable <mmintrin.h> code.
152 %define         specflags_i586  -mmmx
153 %define         specflags_i686  -mmmx
154 %define         specflags_ppc   -fPIC
155
156 %description
157 FFmpeg is a complete solution to record, convert and stream audio and
158 video. It is a command line tool to convert one video file format to
159 another. It also supports grabbing and encoding in real time from a TV
160 card.
161
162 %description -l pl.UTF-8
163 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
164 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
165 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
166 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
167 telewizyjnej.
168
169 %package libs
170 Summary:        ffmpeg libraries
171 Summary(pl.UTF-8):      Biblioteki ffmpeg
172 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
173 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
174 Requires:       gnutls-libs >= 3.0.20
175 %endif
176 Group:          Libraries
177
178 %description libs
179 This package contains the ffmpeg shared libraries:
180 - the codec library (libavcodec). It supports most existing encoding
181   formats (MPEG, DivX, MPEG4, AC3, DV...),
182 - demuxer library (libavformat). It supports most existing file
183   formats (AVI, MPEG, OGG, Matroska, ASF...),
184 - video postprocessing library (libpostproc).
185
186 %description libs -l pl.UTF-8
187 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
188 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
189   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
190 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
191   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
192 - bibliotekę postprocessingu (libpostproc).
193
194 %package devel
195 Summary:        ffmpeg header files
196 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
197 Group:          Development/Libraries
198 Requires:       %{name}-libs = %{version}-%{release}
199 # Libs.private from *.pc (unreasonably they are all the same)
200 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
201 Requires:       SDL-devel >= 1.2.1
202 Requires:       alsa-lib-devel
203 Requires:       bzip2-devel
204 Requires:       celt-devel >= 0.11.0
205 %{?with_nonfree:Requires:       faac-devel}
206 %{?with_fdk_aac:Requires:       fdk-aac-devel}
207 %{?with_flite:Requires: flite-devel >= 1.4}
208 Requires:       fontconfig-devel
209 Requires:       freetype-devel
210 %{?with_gme:Requires:   game-music-emu-devel}
211 Requires:       jack-audio-connection-kit-devel
212 Requires:       lame-libs-devel >= 3.98.3
213 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
214 Requires:       libass-devel
215 Requires:       libavc1394-devel
216 Requires:       libbluray-devel
217 %{?with_caca:Requires:  libcaca-devel}
218 Requires:       libcdio-paranoia-devel >= 0.90-2
219 Requires:       libdc1394-devel >= 2
220 Requires:       libgsm-devel
221 Requires:       libiec61883-devel
222 Requires:       libmodplug-devel
223 Requires:       libnut-devel
224 %{?with_quvi:Requires:  libquvi-devel}
225 Requires:       libraw1394-devel >= 2
226 Requires:       librtmp-devel
227 Requires:       libtheora-devel >= 1.0-0.beta3
228 %{?with_va:Requires:    libva-devel >= 1.0.3}
229 Requires:       libvorbis-devel
230 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
231 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
232 Requires:       opencore-amr-devel
233 %{?with_opencv:Requires:        opencv-devel}
234 Requires:       openjpeg-devel >= 1.5
235 Requires:       schroedinger-devel
236 %{?with_shine:Requires: shine-devel >= 3.0.0}
237 %{?with_soxr:Requires:  soxr-devel}
238 Requires:       speex-devel >= 1:1.2-rc1
239 Requires:       twolame-devel
240 %{?with_utvideo:Requires:       utvideo-devel >= 12}
241 %{?with_vidstab:Requires:       vid.stab-devel}
242 Requires:       vo-aacenc-devel
243 Requires:       vo-amrwbenc-devel
244 %{?with_wavpack:Requires:       wavpack-devel}
245 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
246 Requires:       xavs-devel
247 Requires:       xorg-lib-libXext-devel
248 Requires:       xorg-lib-libXfixes-devel
249 Requires:       xvid-devel >= 1:1.1.0
250 %{?with_zmq:Requires:   zeromq-devel}
251 Requires:       zlib-devel
252 Obsoletes:      libpostproc-devel
253
254 %description devel
255 ffmpeg header files.
256
257 %description devel -l pl.UTF-8
258 Pliki nagłówkowe ffmpeg.
259
260 %package static
261 Summary:        ffmpeg static libraries
262 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
263 Group:          Development/Libraries
264 Requires:       %{name}-devel = %{version}-%{release}
265
266 %description static
267 ffmpeg static libraries (libavcodec and libavformat).
268
269 %description static -l pl.UTF-8
270 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
271
272 %package ffplay
273 Summary:        FFplay - SDL-based media player
274 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
275 Group:          Applications/Multimedia
276 Requires:       %{name}-libs = %{version}-%{release}
277
278 %description ffplay
279 FFplay is a very simple and portable media player using the FFmpeg
280 libraries and the SDL library. It is mostly used as a test bench for
281 the various APIs of FFmpeg.
282
283 %description ffplay -l pl.UTF-8
284 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
285 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
286 testowania różnych API FFmpeg.
287
288 %package ffserver
289 Summary:        FFserver video server
290 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
291 Group:          Daemons
292 Requires(post,preun):   /sbin/chkconfig
293 Requires:       %{name}-libs = %{version}-%{release}
294 Requires:       rc-scripts >= 0.4.0.10
295
296 %description ffserver
297 FFserver is a streaming server for both audio and video. It supports
298 several live feeds, streaming from files and time shifting on live
299 feeds (you can seek to positions in the past on each live feed,
300 provided you specify a big enough feed storage in ffserver.conf).
301
302 %description ffserver -l pl.UTF-8
303 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
304 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
305 czasie dla źródeł na żywo (można przeskakiwać na położenia w
306 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
307 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
308
309 %package doc
310 Summary:        FFmpeg documentation in HTML format
311 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
312 Group:          Documentation
313 %if "%{_rpmversion}" >= "5"
314 BuildArch:      noarch
315 %endif
316
317 %description doc
318 FFmpeg documentation in HTML format.
319
320 %description doc -l pl.UTF-8
321 Dokumentacja pakietu FFmpeg w formacie HTML.
322
323 %prep
324 %setup -q
325 %patch0 -p1
326
327 # package the grep result for mplayer, the result formatted as ./mplayer/configure
328 cat <<EOF > ffmpeg-avconfig
329 #! /bin/sh
330 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
331 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
332 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
333 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
334 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
335 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
336 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
337 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
338 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
339 EOF
340 cat <<'EOF' >> ffmpeg-avconfig
341
342 case "$1" in
343 --decoders)
344         echo $libavdecoders_all
345         ;;
346 --encoders)
347         echo $libavencoders_all
348         ;;
349 --parsers)
350         echo $libavparsers_all
351         ;;
352 --bsfs)
353         echo $libavbsfs_all
354         ;;
355 --demuxers)
356         echo $libavdemuxers_all
357         ;;
358 --muxers)
359         echo $libavmuxers_all
360         ;;
361 --protocols)
362         echo $libavprotocols_all
363         ;;
364 --hwaccels)
365         echo $libavhwaccels_all
366         ;;
367 --filters)
368         echo $libavfilters_all
369         ;;
370 *)
371         cat <<USAGE
372 Usage: $0 [OPTION]
373 Options:
374   --decoders
375   --encoders
376   --parsers
377   --bsfs
378   --demuxers
379   --muxers
380   --protocols
381   --hwaccels
382   --filters
383 USAGE
384         exit 1;;
385 esac
386
387 exit 0
388 EOF
389
390 %build
391 # notes:
392 # - it's not autoconf configure
393 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
394 ./configure \
395         --arch=%{_target_base_arch} \
396         --prefix=%{_prefix} \
397         --libdir=%{_libdir} \
398         --shlibdir=%{_libdir} \
399         --mandir=%{_mandir} \
400         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
401         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
402         --cc="%{__cc}" \
403         --disable-debug \
404         --disable-optimizations \
405         --disable-stripping \
406         --enable-avfilter \
407         --enable-avresample \
408         --enable-gnutls \
409         --enable-gpl \
410         --enable-version3 \
411         --enable-fontconfig \
412         %{?with_frei0r:--enable-frei0r} \
413         %{?with_ladspa:--enable-ladspa} \
414         %{?with_aacplus:--enable-libaacplus} \
415         --enable-libass \
416         --enable-libbluray \
417         %{?with_caca:--enable-libcaca} \
418         --enable-libcelt \
419         --enable-libcdio \
420         --enable-libdc1394 \
421         %{?with_fdk_aac:--enable-libfdk-aac} \
422         %{?with_flite:--enable-libflite} \
423         --enable-libfreetype \
424         %{?with_gme:--enable-libgme} \
425         --enable-libgsm \
426         --enable-libiec61883 \
427         %{?with_ilbc:--enable-libilbc} \
428         --enable-libmodplug \
429         --enable-libmp3lame \
430         --enable-libnut \
431         --enable-libopencore-amrnb \
432         --enable-libopencore-amrwb \
433         %{?with_opencv:--enable-libopencv} \
434         --enable-libopenjpeg \
435         --enable-libopus \
436         %{?with_pulseaudio:--enable-libpulse} \
437         %{?with_quvi:--enable-libquvi} \
438         --enable-librtmp \
439         --enable-libschroedinger \
440         %{?with_shine:--enable-libshine} \
441         %{?with_soxr:--enable-libsoxr} \
442         --enable-libspeex \
443         %{?with_ssh:--enable-libssh} \
444         --enable-libtheora \
445         --enable-libtwolame \
446         %{?with_utvideo:--enable-libutvideo} \
447         --enable-libv4l2 \
448         %{?with_vidstab:--enable-libvidstab} \
449         --enable-libvo-aacenc \
450         --enable-libvo-amrwbenc \
451         --enable-libvorbis \
452         %{?with_vpx:--enable-libvpx} \
453         %{?with_wavpack:--enable-libwavpack} \
454         %{?with_x264:--enable-libx264} \
455         --enable-libxavs \
456         --enable-libxvid \
457         %{?with_zmq:--enable-libzmq} \
458         %{?with_zvbi:--enable-libzvbi} \
459         %{?with_openal:--enable-openal} \
460         %{?with_opencl:--enable-opencl} \
461         --enable-postproc \
462         --enable-pthreads \
463         --enable-shared \
464         --enable-swscale \
465         %{!?with_va:--disable-vaapi} \
466         --enable-x11grab \
467 %ifnarch %{ix86} %{x8664}
468         --disable-mmx \
469 %endif
470 %ifarch i386 i486
471         --disable-mmx \
472 %endif
473 %if %{with nonfree}
474         --enable-nonfree \
475         --enable-libfaac \
476 %endif
477         --enable-runtime-cpudetect
478
479 %{__make} \
480         V=1
481
482 # CC_O to add -c to commandline. makefile should be patched
483 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
484
485 %install
486 rm -rf $RPM_BUILD_ROOT
487 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
488         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
489         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
490
491 %{__make} install install-headers \
492         DESTDIR=$RPM_BUILD_ROOT \
493         V=1
494
495 # install nonstandard, non-public headers manually
496 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
497 for a in libavutil/*/bswap.h; do
498         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
499 done
500 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
501 # for lim-omx ffmpeg components
502 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
503
504 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
505 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
506 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
507 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
508 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
509
510 # install as ffmpeg-avconfig to avoid with possible programs looking for
511 # ffmpeg-config and expecting --libs output from it which is not implemented
512 # simple to do (by querying pkgconfig), but why?
513 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
514
515 %clean
516 rm -rf $RPM_BUILD_ROOT
517
518 %post   libs -p /sbin/ldconfig
519 %postun libs -p /sbin/ldconfig
520
521 %pre ffserver
522 %groupadd -g 167 ffserver
523 %useradd -g ffserver -u 167 ffserver
524
525 %post ffserver
526 /sbin/chkconfig --add ffserver
527 %service ffserver restart
528
529 %preun ffserver
530 if [ "$1" = 0 ]; then
531         %service ffserver stop
532         /sbin/chkconfig --del ffserver
533 fi
534
535 %postun ffserver
536 if [ "$1" = 0 ]; then
537         %userremove ffserver
538         %groupremove ffserver
539 fi
540
541 %files
542 %defattr(644,root,root,755)
543 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
544 %attr(755,root,root) %{_bindir}/ffmpeg
545 %attr(755,root,root) %{_bindir}/ffprobe
546 %attr(755,root,root) %{_bindir}/qt-faststart
547 %dir %{_datadir}/ffmpeg
548 %{_datadir}/ffmpeg/*.ffpreset
549 %{_datadir}/ffmpeg/ffprobe.xsd
550 %if %{with doc}
551 %{_mandir}/man1/ffmpeg.1*
552 %{_mandir}/man1/ffmpeg-all.1*
553 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
554 %{_mandir}/man1/ffmpeg-codecs.1*
555 %{_mandir}/man1/ffmpeg-devices.1*
556 %{_mandir}/man1/ffmpeg-filters.1*
557 %{_mandir}/man1/ffmpeg-formats.1*
558 %{_mandir}/man1/ffmpeg-protocols.1*
559 %{_mandir}/man1/ffmpeg-resampler.1*
560 %{_mandir}/man1/ffmpeg-scaler.1*
561 %{_mandir}/man1/ffmpeg-utils.1*
562 %{_mandir}/man1/ffprobe.1*
563 %{_mandir}/man1/ffprobe-all.1*
564 %endif
565
566 %files libs
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
570 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
571 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
572 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
573 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
574 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
576 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
578 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
580 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
582 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
584 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
586
587 %files devel
588 %defattr(644,root,root,755)
589 %doc doc/optimization.txt
590 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
591 %attr(755,root,root) %{_libdir}/libavcodec.so
592 %attr(755,root,root) %{_libdir}/libavdevice.so
593 %attr(755,root,root) %{_libdir}/libavfilter.so
594 %attr(755,root,root) %{_libdir}/libavformat.so
595 %attr(755,root,root) %{_libdir}/libavresample.so
596 %attr(755,root,root) %{_libdir}/libavutil.so
597 %attr(755,root,root) %{_libdir}/libpostproc.so
598 %attr(755,root,root) %{_libdir}/libswresample.so
599 %attr(755,root,root) %{_libdir}/libswscale.so
600 %{_includedir}/ffmpeg
601 %{_includedir}/libavcodec
602 %{_includedir}/libavdevice
603 %{_includedir}/libavfilter
604 %{_includedir}/libavformat
605 %{_includedir}/libavresample
606 %{_includedir}/libavutil
607 %{_includedir}/libpostproc
608 %{_includedir}/libswresample
609 %{_includedir}/libswscale
610 %{_pkgconfigdir}/libavcodec.pc
611 %{_pkgconfigdir}/libavdevice.pc
612 %{_pkgconfigdir}/libavfilter.pc
613 %{_pkgconfigdir}/libavformat.pc
614 %{_pkgconfigdir}/libavresample.pc
615 %{_pkgconfigdir}/libavutil.pc
616 %{_pkgconfigdir}/libpostproc.pc
617 %{_pkgconfigdir}/libswresample.pc
618 %{_pkgconfigdir}/libswscale.pc
619 %if %{with doc}
620 %{_mandir}/man3/libavcodec.3*
621 %{_mandir}/man3/libavdevice.3*
622 %{_mandir}/man3/libavfilter.3*
623 %{_mandir}/man3/libavformat.3*
624 %{_mandir}/man3/libavutil.3*
625 %{_mandir}/man3/libswresample.3*
626 %{_mandir}/man3/libswscale.3*
627 %endif
628
629 %files static
630 %defattr(644,root,root,755)
631 %{_libdir}/libavcodec.a
632 %{_libdir}/libavdevice.a
633 %{_libdir}/libavfilter.a
634 %{_libdir}/libavformat.a
635 %{_libdir}/libavresample.a
636 %{_libdir}/libavutil.a
637 %{_libdir}/libpostproc.a
638 %{_libdir}/libswresample.a
639 %{_libdir}/libswscale.a
640
641 %files ffplay
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_bindir}/ffplay
644 %if %{with doc}
645 %{_mandir}/man1/ffplay.1*
646 %{_mandir}/man1/ffplay-all.1*
647 %endif
648
649 %files ffserver
650 %defattr(644,root,root,755)
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
652 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
653 %attr(755,root,root) %{_sbindir}/ffserver
654 %attr(754,root,root) /etc/rc.d/init.d/ffserver
655 %if %{with doc}
656 %{_mandir}/man1/ffserver.1*
657 %{_mandir}/man1/ffserver-all.1*
658 %endif
659 %dir %attr(770,root,ffserver) /var/cache/ffserver
660 %dir %attr(770,root,ffserver) /var/log/ffserver
661
662 %if %{with doc}
663 %files doc
664 %defattr(644,root,root,755)
665 %doc doc/*.html
666 %endif
This page took 0.083513 seconds and 2 git commands to generate.