]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- -ffserver subpackage
[packages/ffmpeg.git] / ffmpeg.spec
1 # Conditional build:
2 %bcond_without  imlib2          # we can safely play without it:-)
3 %bcond_without  autoreqdep      # don't care about package name deps generated by rpm
4 #
5 %define snap    20060129
6 %define _rel 8.3
7 Summary:        Realtime audio/video encoder and streaming server
8 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
9 Name:           ffmpeg
10 Version:        0.4.9
11 Release:        3.%{snap}.%{_rel}
12 # LGPL or GPL, chosen at configure time (GPL version is more featured)
13 License:        GPL
14 Group:          Applications/Multimedia
15 #Source0:       http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
16 #Source0:       ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
17 Source0:        %{name}-%{snap}.tar.bz2
18 # Source0-md5:  d8ea09431d6c0c91bfd35e0ca74a67e1
19 Source1:        ffserver.init
20 Source2:        ffserver.sysconfig
21 Patch0:         %{name}-libtool.patch
22 Patch1:         %{name}-libdir.patch
23 Patch2:         %{name}-gcc4.patch
24 URL:            http://ffmpeg.sourceforge.net/
25 BuildRequires:  SDL-devel
26 BuildRequires:  faac-devel
27 BuildRequires:  faad2-devel
28 BuildRequires:  freetype-devel
29 %ifarch ppc
30 # require version with altivec support fixed
31 BuildRequires:  gcc >= 5:3.3.2-3
32 %endif
33 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.1.0-2}
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  libdts-devel
36 BuildRequires:  libgsm-devel
37 BuildRequires:  libtheora-devel
38 BuildRequires:  libtool >= 2:1.4d-3
39 BuildRequires:  libvorbis-devel
40 #BuildRequires: libx264-devel
41 BuildRequires:  lzo-devel
42 %ifarch %{ix86}
43 %ifnarch i386 i486
44 BuildRequires:  nasm
45 %endif
46 %endif
47 BuildRequires:  perl-tools-pod
48 BuildRequires:  tetex
49 BuildRequires:  texinfo
50 BuildRequires:  xvid-devel >= 1:1.1.0
51 BuildRequires:  zlib-devel
52 %{?with_autoreqdep:BuildConflicts:      libpostproc}
53 Requires:       %{name}-libs = %{version}-%{release}
54 Requires:       xvid >= 1:1.1.0
55 Obsoletes:      libpostproc
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
59
60 %define         specflags       -fno-strict-aliasing
61
62 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
63 %define         specflags_ia32  -fomit-frame-pointer
64 # -mmmx is needed to enable <mmintrin.h> code.
65 %define         specflags_i586  -mmmx
66 %define         specflags_i686  -mmmx
67
68 %description
69 ffmpeg is a hyper fast realtime audio/video encoder and streaming
70 server. It can grab from a standard Video4Linux video source and
71 convert it into several file formats based on DCT/motion compensation
72 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
73 compatible stream.
74
75 %description -l pl
76 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
77 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
78 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
79 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
80 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
81 strumienia kompatybilnego z AC3.
82
83 %package libs
84 Summary:        ffmpeg libraries
85 Summary(pl):    Biblioteki ffmpeg
86 Group:          Libraries
87
88 %description libs
89 This package contains ffmpeg shared libraries.
90
91 %description libs -l pl
92 Ten pakiet zawiera biblioteki wspó³dzielone ffmpeg.
93
94 %package devel
95 Summary:        ffmpeg header files
96 Summary(pl):    Pliki nag³ówkowe ffmpeg
97 Group:          Development/Libraries
98 Requires:       %{name}-libs = %{version}-%{release}
99 Obsoletes:      libpostproc-devel
100 # for libavcodec:
101 Requires:       faac-devel
102 Requires:       lame-libs-devel
103 Requires:       libdts-devel
104 Requires:       libgsm-devel
105 Requires:       libtheora-devel
106 Requires:       libvorbis-devel
107 Requires:       xvid-devel >= 1:1.1.0
108 Requires:       zlib-devel
109
110 %description devel
111 ffmpeg header files.
112
113 %description devel -l pl
114 Pliki nag³ówkowe ffmpeg.
115
116 %package static
117 Summary:        ffmpeg static libraries
118 Summary(pl):    Statyczne biblioteki ffmpeg
119 Group:          Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121
122 %description static
123 ffmpeg static libraries (libavcodec and libavformat).
124
125 %description static -l pl
126 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
127
128 %package ffplay
129 Summary:        FFplay - SDL-based media player
130 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
131 Group:          Applications/Multimedia
132 Requires:       %{name}-libs = %{version}-%{release}
133
134 %description ffplay
135 FFplay is a very simple and portable media player using the FFmpeg
136 libraries and the SDL library. It is mostly used as a test bench for
137 the various APIs of FFmpeg.
138
139 %description ffplay -l pl
140 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
141 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
142 testowania ró¿nych API FFmpeg.
143
144 %package vhook-imlib2
145 Summary:        imlib2 based hook
146 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
147 Group:          Libraries
148 Requires:       %{name}-libs = %{version}-%{release}
149
150 %description vhook-imlib2
151 This module implements a text overlay for a video image. Currently it
152 supports a fixed overlay or reading the text from a file. The string
153 is passed through strftime so that it is easy to imprint the date and
154 time onto the image.
155
156 %description vhook-imlib2 -l pl
157 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
158 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
159 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
160 obrazie.
161
162 %package ffserver
163 Summary:        FFserver video server
164 Group:          Daemons
165
166 %description ffserver
167 FFserver is a streaming server for both audio and video. It supports
168 several live feeds, streaming from files and time shifting on live
169 feeds (you can seek to positions in the past on each live feed,
170 provided you specify a big enough feed storage in ffserver.conf).
171
172 %prep
173 %setup -q -n %{name}
174 %patch0 -p1
175 %patch1 -p1
176 %patch2 -p1
177
178 %build
179 # notes:
180 # - it's not autoconf configure
181 # - --disable-debug, --disable-opts, tune=generic causes not to override our optflags
182 ./configure \
183         --prefix=%{_prefix} \
184         --libdir=%{_libdir} \
185         --mandir=%{_mandir} \
186         --disable-strip \
187         --enable-a52 \
188         --enable-a52bin \
189         --enable-dts \
190         --enable-faac \
191         --enable-faad \
192         --enable-faadbin \
193         --enable-gpl \
194         --enable-libgsm \
195         --enable-libogg \
196         --enable-mp3lame \
197         --enable-pp \
198         --enable-pthreads \
199         --enable-shared \
200         --enable-theora \
201         --enable-vorbis \
202         --enable-xvid \
203 %ifnarch %{ix86} %{x8664}
204         --disable-mmx \
205 %endif
206 %ifarch i386 i486
207         --disable-mmx \
208 %endif
209         --cc="%{__cc}" \
210         --extra-cflags="%{rpmcflags}" \
211         --extra-ldflags="%{rpmldflags}" \
212         --disable-debug \
213         --disable-opts \
214         --tune=generic
215
216 %{__make} \
217         BUILD_DOC=yes
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}}
222
223 %{__make} install \
224         DESTDIR=$RPM_BUILD_ROOT
225
226 install xvmc_render.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
227 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
228 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
229
230 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
231 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
232
233 %clean
234 rm -rf $RPM_BUILD_ROOT
235
236 %post   -p /sbin/ldconfig
237 %postun -p /sbin/ldconfig
238
239 %files
240 %defattr(644,root,root,755)
241 %doc Changelog README doc/*.html doc/TODO
242 %attr(755,root,root) %{_bindir}/ffmpeg
243 %{_mandir}/man1/ffmpeg.1*
244
245 %files libs
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
248 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
249 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
250 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
251 %dir %{_libdir}/vhook
252 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
253 %attr(755,root,root) %{_libdir}/vhook/fish.so
254 %attr(755,root,root) %{_libdir}/vhook/null.so
255 %attr(755,root,root) %{_libdir}/vhook/ppm.so
256 %attr(755,root,root) %{_libdir}/vhook/watermark.so
257
258 %files devel
259 %defattr(644,root,root,755)
260 %doc doc/optimization.txt
261 %attr(755,root,root) %{_libdir}/libavcodec.so
262 %attr(755,root,root) %{_libdir}/libavformat.so
263 %attr(755,root,root) %{_libdir}/libavutil.so
264 %attr(755,root,root) %{_libdir}/libpostproc.so
265 %{_libdir}/lib*.la
266 %{_includedir}/ffmpeg
267 %{_includedir}/postproc
268 %{_pkgconfigdir}/*.pc
269
270 %files static
271 %defattr(644,root,root,755)
272 %{_libdir}/lib*.a
273
274 %files ffplay
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/ffplay
277 %{_mandir}/man1/ffplay.1*
278
279 %if %{with imlib2}
280 %files vhook-imlib2
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
283 %endif
284
285 %files ffserver
286 %defattr(644,root,root,755)
287 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
288 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
289 %attr(755,root,root) %{_sbindir}/ffserver
290 %attr(754,root,root) /etc/rc.d/init.d/ffserver
291 %{_mandir}/man1/ffserver.1*
This page took 1.241763 seconds and 3 git commands to generate.