]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- 0.4.7, updated opt,imlib2,libtool patches
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # Conditional build:
3 # _without_imlib        - we can safely play without it :-)
4 #
5 Summary:        Realtime audio/video encoder and streaming server
6 Summary(pl):    Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
7 Name:           ffmpeg
8 Version:        0.4.7
9 Release:        1
10 License:        LGPL/GPL
11 Group:          Daemons
12 Source0:        http://dl.sourceforge.net/ffmpeg/%{name}-%{version}.tar.gz
13 # Source0-md5:  bd9ab3e27f6c92fa06286b8f40277994
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-imlib2.patch
16 Patch2:         %{name}-libtool.patch
17 URL:            http://ffmpeg.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  freetype-devel
20 %{!?_without_imlib:BuildRequires:       imlib2-devel}
21 BuildRequires:  libtool >= 2:1.4d-3
22 %ifarch i586 i686 athlon
23 BuildRequires:  nasm
24 %endif
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
29
30 %description
31 ffmpeg is a hyper fast realtime audio/video encoder and streaming
32 server. It can grab from a standard Video4Linux video source and
33 convert it into several file formats based on DCT/motion compensation
34 encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
35 compatible stream.
36
37 This package contains also ffmpeg shared libraries (libavcodec and
38 libavformat).
39
40 %description -l pl
41 ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
42 oraz serwerem strumieni multimedialnych. ffmpeg potrafi zrzucaæ dane
43 ze standardowego urz±dzenia Video4Linux i przekonwertowaæ je w kilka
44 formatów plików bazuj±cych na kodowaniu DCT/kompensacji ruchu. D¼wiêk
45 jest kompresowany do strumienia MPEG audio layer 2 lub u¿ywaj±c
46 strumienia kompatybilnego z AC3.
47
48 Ten pakiet zawiera tak¿e biblioteki wspó³dzielone ffmpeg (libavcodec i
49 libavformat).
50
51 %package ffplay
52 Summary:        FFplay - SDL-based media player
53 Summary(pl):    FFplay - odtwarzacz mediów oparty na SDL
54 Group:          Applications/Multimedia
55 Requires:       %{name} = %{version}
56
57 %description ffplay
58 FFplay is a very simple and portable media player using the FFmpeg
59 libraries and the SDL library. It is mostly used as a test bench for
60 the various APIs of FFmpeg.
61
62 %description ffplay -l pl
63 FFplay to bardzo prosty i przeno¶ny odtwarzacz mediów u¿ywaj±cy
64 bibliotek FFmpeg oraz biblioteki SDL. Jest u¿ywany g³ównie do
65 testowania ró¿nych API FFmpeg.
66
67 %package vhook-imlib2
68 Summary:        imlib2 based hook
69 Summary(pl):    Modu³ przej¶ciowy oparty o imlib2
70 Group:          Libraries
71 Requires:       %{name} = %{version}
72
73 %description vhook-imlib2
74 This module implements a text overlay for a video image. Currently it
75 supports a fixed overlay or reading the text from a file. The string
76 is passed through strftime so that it is easy to imprint the date and
77 time onto the image.
78
79 %description vhook-imlib2 -l pl
80 Ten modu³ implementuje tekstow± nak³adkê dla obrazu. Aktualnie
81 obs³uguje sta³± nak³adkê lub wczytywanie tekstu z pliku. £añcuch jest
82 przepuszczany przez strftime, wiêc ³atwo umie¶ciæ datê i czas na
83 obrazie.
84
85 %package devel
86 Summary:        ffmpeg header files
87 Summary(pl):    Pliki nag³ówkowe ffmpeg
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}
90
91 %description devel
92 ffmpeg header files.
93
94 %description devel -l pl
95 Pliki nag³ówkowe ffmpeg.
96
97 %package static
98 Summary:        ffmpeg static libraries
99 Summary(pl):    Statyczne biblioteki ffmpeg
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}
102
103 %description static
104 ffmpeg static libraries (libavcodec and libavformat).
105
106 %description static -l pl
107 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114
115 %build
116 # note: it's not autoconf configure
117 ./configure \
118         --prefix=%{_prefix} \
119         --mandir=%{_mandir} \
120         --enable-shared \
121         --enable-a52bin \
122         --enable-faadbin \
123 %ifnarch i586 i686 athlon
124         --disable-mmx
125 %endif
126
127 # note: -fomit-frame-pointer is always needed on x86 due to lack of registers
128 #       (-fPIC takes one)
129 %{__make} \
130         CC="%{__cc}" \
131         OPT="%{rpmcflags} -fomit-frame-pointer -I/usr/X11R6/include" \
132         LDOPT="%{rpmldflags} -L/usr/X11R6/lib"
133
134 %{__make} -C doc
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir}}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
144 install doc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc Changelog README doc/*.html
155 %attr(755,root,root) %{_bindir}/ffmpeg
156 %attr(755,root,root) %{_sbindir}/ffserver
157 %attr(755,root,root) %{_libdir}/libavcodec-*.so
158 %attr(755,root,root) %{_libdir}/libavformat-*.so
159 %dir %{_libdir}/vhook
160 %attr(755,root,root) %{_libdir}/vhook/drawtext.so
161 %attr(755,root,root) %{_libdir}/vhook/fish.so
162 %attr(755,root,root) %{_libdir}/vhook/null.so
163 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ffserver.conf
164 %{_mandir}/man1/ffmpeg.1*
165 %{_mandir}/man1/ffserver.1*
166
167 %files ffplay
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/ffplay
170 %{_mandir}/man1/ffplay.1*
171
172 %if %{!?_without_imlib:1}0
173 %files vhook-imlib2
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/vhook/imlib2.so
176 %endif
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libavcodec.so
181 %attr(755,root,root) %{_libdir}/libavformat.so
182 %{_libdir}/lib*.la
183 %{_includedir}/ffmpeg
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/lib*.a
This page took 0.053319 seconds and 3 git commands to generate.