]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
3d2d3af7ead4f17d4bb0a82b63b919dc18d163d3
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO:
2 # - libtensorflow [-ltensorflow tensorflow/c/c_api.h]
3 # - AMF >= 1.4.4.1 (available at https://github.com/GPUOpen-LibrariesAndSDKs/AMF, where is original source?)
4 #
5 # How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
6 #       1. make-request -r --with bootstrap ffmpeg.spec
7 #       2  bump release of opencv.spec and chromaprint.spec
8 #       3. make-request -r opencv.spec chromaprint.spec
9 #       4. bump release of ffmpeg.spec
10 #       5. make-request -r ffmpeg.spec
11 #
12 # Conditional build:
13 %bcond_with     bootstrap       # disable features to able to build without installed ffmpeg
14 %bcond_with     nonfree         # unblock non free options of package (currently: cuda_nvcc, decklib, fdk_aac, npp, openssl, libressl/libtls)
15 %bcond_without  aribb24         # ARIB text and caption decoding via libaribb24
16 %bcond_without  avs2            # AVS2 de/encoding via libdavs2/libxavs2
17 %bcond_without  bs2b            # BS2B audio filter support
18 %bcond_without  caca            # textual display using libcaca
19 %bcond_without  codec2          # codec2 support using libcodec2
20 %bcond_without  chromaprint     # audio fingerprinting with chromaprint
21 %bcond_with     cudasdk         # NVIDIA CUDA code using nvcc from CUDA SDK [BR: cuda.h, non-free]
22 %bcond_without  dav1d           # AV1 decoding via libdav1d
23 %bcond_with     decklink        # Blackmagic DeckLink I/O support (requires nonfree)
24 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
25 %bcond_without  ffnvcodec       # NVIDIA codecs support using ffnvcodec headers (covered: cuda cuvid nvdec nvenc)
26 %bcond_without  flite           # flite voice synthesis support
27 %bcond_without  frei0r          # frei0r video filtering
28 %bcond_without  fribidi         # fribidi support
29 %bcond_without  gme             # Game Music Emu support
30 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
31 %bcond_without  kvazaar         # Kvazaar HEVC encoder support
32 %bcond_without  ladspa          # LADSPA audio filtering
33 %bcond_without  lensfun         # lensfun lens correction
34 %bcond_with     libdrm          # Linux Direct Rendering Manager code
35 %bcond_with     libklvanc       # Kernel Labs VANC processing (in decklink driver)
36 %bcond_without  libmysofa       # sofalizer filter
37 %bcond_with     librsvg         # SVG rasterization via librsvg
38 %bcond_with     libxml2         # XML parsing using libxml2
39 %bcond_without  lv2             # LV2 audio filtering
40 %bcond_with     mfx             # MFX hardware acceleration support
41 %bcond_with     npp             # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
42 %bcond_without  omx             # OpenMAX IL support
43 %bcond_without  openal          # OpenAL 1.1 capture support
44 %bcond_without  opencl          # OpenCL 1.2 code
45 %bcond_without  opencv          # OpenCV video filtering
46 %bcond_without  opengl          # OpenGL rendering support
47 %bcond_with     openh264        # OpenH264 H.264 encoder
48 %bcond_without  openmpt         # OpenMPT module decoder
49 %bcond_with     pocketsphinx    # asr filter using PocketSphinx
50 %bcond_without  pulseaudio      # PulseAudio input support
51 %bcond_with     rkmpp           # Rockchip Media Process Platform code [implies libdrm]
52 %bcond_without  rubberband      # rubberband filter
53 %bcond_without  shine           # shine fixed-point MP3 encoder
54 %bcond_without  snappy          # Snappy compression support (needed for hap encoding)
55 %bcond_without  srt             # Haivision SRT protocol support
56 %bcond_without  ssh             # SFTP protocol support via libssh
57 %bcond_with     smb             # SMB support via libsmbclient
58 %bcond_without  soxr            # SoX Resampler support
59 %bcond_with     tesseract       # OCR filter based on Tesseract
60 %bcond_without  vmaf            # VMAF filter support
61 %bcond_without  x264            # H.264 x264 encoder
62 %bcond_without  x265            # H.265/HEVC x265 encoder
63 %bcond_without  va              # VAAPI (Video Acceleration API)
64 %bcond_without  vapoursynth     # VapourSynth demuxer
65 %bcond_without  vidstab         # vid.stab video stabilization support
66 %bcond_without  vpx             # VP8, a high-quality video codec
67 %bcond_without  wavpack         # wavpack encoding support
68 %bcond_without  webp            # WebP encoding support
69 %bcond_without  zimg            # zscale filter based on z.lib
70 %bcond_without  zmq             # 0MQ message passing
71 %bcond_without  zvbi            # teletext via libzvbi
72 %bcond_without  doc             # don't build docs
73 %bcond_with     tests           # "make check" (some tests fail as of 2.5)
74
75 %if %{with bootstrap}
76 %undefine       with_opencv
77 %undefine       with_chromaprint
78 %endif
79 %if %{with rkmpp}
80 %define         with_libdrm     1
81 %endif
82
83 %ifnarch %{ix86} %{x8664}
84 %undefine       with_ffnvcodec
85 %endif
86 %ifnarch %{ix86} %{x8664} %{arm}
87 %undefine       with_x265
88 %endif
89 %ifarch i386 i486
90 %undefine       with_x265
91 %endif
92 Summary:        FFmpeg - a very fast video and audio converter
93 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
94 Name:           ffmpeg
95 Version:        4.2.2
96 Release:        2
97 # LGPL or GPL, chosen at configure time (GPL version is more featured)
98 # GPL: frei0r libcdio libdavs2 rubberband vidstab x264 x265 xavs xavs2 xvid
99 # v3 (allows *GPLv3 or Apache-licensed libs): gmp lensfun opencore-amr vmaf vo-*enc rkmpp
100 # GPLv3: smbclient
101 License:        GPL v3+ with LGPL v3+ parts
102 Group:          Applications/Multimedia
103 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
104 # Source0-md5:  348956fc2faa57a2f79bbb84ded9fbc3
105 Patch0:         %{name}-omx-libnames.patch
106 URL:            http://www.ffmpeg.org/
107 %{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.9.5}
108 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
109 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
110 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
111 # libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
112 %{?with_omx:BuildRequires:      OpenMAX-IL-devel}
113 BuildRequires:  SDL2-devel >= 2.0.1
114 BuildRequires:  SDL2-devel < 2.1.0
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  aom-devel >= 1.0.0
117 %{?with_aribb24:BuildRequires:  aribb24-devel}
118 BuildRequires:  bzip2-devel
119 BuildRequires:  celt-devel >= 0.11.0
120 %{?with_codec2:BuildRequires:   codec2-devel}
121 %{?with_dav1d:BuildRequires:    dav1d-devel >= 0.2.1}
122 %{?with_avs2:BuildRequires:     davs2-devel >= 1.6}
123 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
124 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
125 BuildRequires:  fontconfig-devel
126 BuildRequires:  freetype-devel
127 %{?with_frei0r:BuildRequires:   frei0r-devel}
128 %{?with_fribidi:BuildRequires:  fribidi-devel}
129 %{?with_gme:BuildRequires:      game-music-emu-devel}
130 %ifarch ppc
131 # require version with altivec support fixed
132 BuildRequires:  gcc >= 5:3.3.2-3
133 %endif
134 BuildRequires:  gmp-devel
135 BuildRequires:  gnutls-devel
136 BuildRequires:  jack-audio-connection-kit-devel
137 %{?with_kvazaar:BuildRequires:  kvazaar-devel >= 0.8.1}
138 %{?with_ladspa:BuildRequires:   ladspa-devel}
139 BuildRequires:  lame-libs-devel >= 3.98.3
140 %{?with_lensfun:BuildRequires:  lensfun-devel}
141 BuildRequires:  libass-devel
142 BuildRequires:  libavc1394-devel
143 %{?with_bs2b:BuildRequires:     libbs2b-devel}
144 BuildRequires:  libbluray-devel
145 %{?with_caca:BuildRequires:     libcaca-devel}
146 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
147 %{?with_chromaprint:BuildRequires:      libchromaprint-devel}
148 BuildRequires:  libcrystalhd-devel
149 BuildRequires:  libdc1394-devel >= 2
150 %{?with_libdrm:BuildRequires:   libdrm-devel}
151 BuildRequires:  libgsm-devel
152 BuildRequires:  libiec61883-devel
153 %{?with_libklvanc:BuildRequires:        libklvanc-devel}
154 BuildRequires:  libmodplug-devel
155 %{?with_libmysofa:BuildRequires:        libmysofa-devel >= 0.7}
156 %{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.4.5}
157 BuildRequires:  libraw1394-devel >= 2
158 %{?with_librsvg:BuildRequires:  librsvg-devel >= 2}
159 BuildRequires:  librtmp-devel
160 %{?with_ssh:BuildRequires:      libssh-devel}
161 %{?with_smb:BuildRequires:      libsmbclient-devel}
162 BuildRequires:  libtheora-devel >= 1.0-0.beta3
163 BuildRequires:  libtool >= 2:1.4d-3
164 BuildRequires:  libv4l-devel
165 %if %{with va}
166 BuildRequires:  libva-devel >= 1.0.3
167 BuildRequires:  libva-drm-devel >= 1.0.3
168 BuildRequires:  libva-x11-devel >= 1.0.3
169 %endif
170 BuildRequires:  libvdpau-devel >= 0.2
171 BuildRequires:  libvorbis-devel
172 %{?with_vpx:BuildRequires:      libvpx-devel >= 1.4.0}
173 %{?with_webp:BuildRequires:     libwebp-devel >= 0.4.0}
174 # X264_BUILD >= 118
175 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
176 # X265_BUILD >= 68
177 %{?with_x265:BuildRequires:     libx265-devel >= 1.8}
178 # libxcb xcb-shm xcb-xfixes xcb-shape
179 BuildRequires:  libxcb-devel >= 1.4
180 %{?with_libxml2:BuildRequires:  libxml2-devel >= 2}
181 %{?with_lv2:BuildRequires:      lilv-devel}
182 %{?with_lv2:BuildRequires:      lv2-devel}
183 %{?with_mfx:BuildRequires:      mfx_dispatch-devel}
184 %ifarch %{ix86}
185 %ifnarch i386 i486
186 BuildRequires:  nasm
187 %endif
188 %endif
189 %{?with_ffnvcodec:BuildRequires:        nv-codec-headers >= 9.0.18.0}
190 # amrnb,amrwb
191 BuildRequires:  opencore-amr-devel
192 %{?with_opencv:BuildRequires:   opencv-devel >= 2}
193 %{?with_openh264:BuildRequires: openh264-devel >= 1.3}
194 BuildRequires:  openjpeg2-devel >= 2.1
195 BuildRequires:  opus-devel
196 BuildRequires:  perl-Encode
197 BuildRequires:  perl-tools-pod
198 %{?with_pocketsphinx:BuildRequires:     pocketsphinx-devel > 0.8}
199 BuildRequires:  pkgconfig
200 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
201 %{?with_rkmpp:BuildRequires:    rockchip-mpp-devel >= 1.3.7}
202 BuildRequires:  rpmbuild(macros) >= 1.470
203 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.8.1}
204 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
205 %{?with_snappy:BuildRequires:   snappy-devel}
206 %{?with_soxr:BuildRequires:     soxr-devel}
207 BuildRequires:  speex-devel >= 1:1.2-rc1
208 %{?with_srt:BuildRequires:      srt-devel >= 1.3}
209 %{?with_tesseract:BuildRequires:        tesseract-devel}
210 %{?with_doc:BuildRequires:      tetex}
211 %{?with_doc:BuildRequires:      texi2html}
212 %{?with_doc:BuildRequires:      texinfo}
213 BuildRequires:  twolame-devel >= 0.3.10
214 %{?with_vapoursynth:BuildRequires:      vapoursynth-devel >= 42}
215 %{?with_vidstab:BuildRequires:  vid.stab-devel >= 0.98}
216 %{?with_vmaf:BuildRequires:     vmaf-devel >= 1.3.9}
217 BuildRequires:  vo-amrwbenc-devel
218 %{?with_wavpack:BuildRequires:  wavpack-devel}
219 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
220 BuildRequires:  xavs-devel
221 %{?with_avs2:BuildRequires:     xavs2-devel >= 1.3}
222 BuildRequires:  xorg-lib-libX11-devel
223 BuildRequires:  xorg-lib-libXext-devel
224 BuildRequires:  xorg-lib-libXv-devel
225 BuildRequires:  xvid-devel >= 1:1.1.0
226 BuildRequires:  xz-devel
227 BuildRequires:  yasm
228 %{?with_zmq:BuildRequires:      zeromq-devel}
229 %{?with_zimg:BuildRequires:     zimg-devel >= 2.7.0}
230 BuildRequires:  zlib-devel
231 %{?with_zvbi:BuildRequires:     zvbi-devel >= 0.2.28}
232 %{?with_autoreqdep:BuildConflicts:      libpostproc}
233 # overflows maximum hash table size
234 BuildConflicts: pdksh < 5.2.14-57
235 Requires:       %{name}-libs = %{version}-%{release}
236 Suggests:       fontconfig
237 Obsoletes:      libpostproc
238 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
239
240 %define         specflags       -fno-strict-aliasing
241
242 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
243 %define         specflags_ia32  -fomit-frame-pointer
244 # -mmmx is needed to enable <mmintrin.h> code.
245 %define         specflags_i586  -mmmx
246 %define         specflags_i686  -mmmx
247 %define         specflags_ppc   -fPIC
248
249 %description
250 FFmpeg is a complete solution to record, convert and stream audio and
251 video. It is a command line tool to convert one video file format to
252 another. It also supports grabbing and encoding in real time from a TV
253 card.
254
255 %description -l pl.UTF-8
256 FFmpeg to kompletne rozwiÄ…zanie nagrywania, konwersji i transmisji
257 strumieni dźwiÄ™ku i obrazu. Jest to dziaÅ‚ajÄ…ce z linii poleceÅ„
258 narzÄ™dzie do konwersji obrazu z jednego formatu do innego. ObsÅ‚uguje
259 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
260 telewizyjnej.
261
262 %package libs
263 Summary:        ffmpeg libraries
264 Summary(pl.UTF-8):      Biblioteki ffmpeg
265 Group:          Libraries
266 Requires:       SDL2 >= 2.0.1
267 Requires:       aom >= 1.0.0
268 Requires:       celt >= 0.11.0
269 %{?with_dav1d:Requires: dav1d >= 0.2.1}
270 %{?with_avs2:Requires:  davs2 >= 1.6}
271 %{?with_flite:Requires: flite >= 1.4}
272 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
273 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
274 Requires:       gnutls-libs >= 3.0.20
275 %endif
276 %{?with_kvazaar:Requires:       kvazaar-libs >= 0.8.1}
277 %{?with_libmysofa:Requires:     libmysofa >= 0.7}
278 %{?with_openmpt:Requires: libopenmpt >= 0.4.5}
279 Requires:       libtheora >= 1.0-0.beta3
280 %if %{with va}
281 Requires:       libva >= 1.0.3
282 Requires:       libva-drm >= 1.0.3
283 Requires:       libva-x11 >= 1.0.3
284 %endif
285 Requires:       libvdpau >= 0.2
286 %{?with_vpx:Requires:   libvpx >= 1.4.0}
287 %{?with_webp:Requires:  libwebp >= 0.4.0}
288 %{?with_x264:Requires:  libx264 >= 0.1.3-1.20111212_2245}
289 %{?with_x265:Requires:  libx265 >= 1.8}
290 Requires:       libxcb >= 1.4
291 Requires:       lame-libs >= 3.98.3
292 %{?with_openh264:Requires:      openh264 >= 1.3}
293 Requires:       openjpeg2 >= 2.1
294 %{?with_rkmpp:Requires: rockchip-mpp >= 1.3.7}
295 %{?with_rubberband:Requires:    rubberband-libs >= 1.8.1}
296 %{?with_shine:Requires: shine >= 3.0.0}
297 Requires:       speex >= 1:1.2-rc1
298 %{?with_srt:Requires:   srt >= 1.3}
299 Requires:       twolame-libs >= 0.3.10
300 %{?with_vapoursynth:Requires:   vapoursynth >= 42}
301 %{?with_vidstab:Requires:       vid.stab >= 0.98}
302 %{?with_vmaf:Requires:  vmaf-libs >= 1.3.9}
303 %{?with_avs2:Requires:  xavs2 >= 1.3}
304 Requires:       xvid >= 1:1.1.0
305 %{?with_zimg:Requires:  zimg >= 2.7.0}
306 %{?with_zvbi:Requires:  zvbi >= 0.2.28}
307
308 %description libs
309 This package contains the ffmpeg shared libraries:
310 - the codec library (libavcodec). It supports most existing encoding
311   formats (MPEG, DivX, MPEG4, AC3, DV...),
312 - demuxer library (libavformat). It supports most existing file
313   formats (AVI, MPEG, OGG, Matroska, ASF...),
314 - video postprocessing library (libpostproc).
315
316 %description libs -l pl.UTF-8
317 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
318 - bibliotekÄ™ kodeków (libavcodec); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
319   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
320 - bibliotekÄ™ demuksera (libavformat); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
321   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
322 - bibliotekÄ™ postprocessingu (libpostproc).
323
324 %package devel
325 Summary:        ffmpeg header files
326 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
327 Group:          Development/Libraries
328 Requires:       %{name}-libs = %{version}-%{release}
329 # Libs.private from *.pc
330 %{?with_openal:Requires:        OpenAL-devel >= 1.1}
331 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
332 %{?with_opengl:Requires:        OpenGL-devel}
333 Requires:       SDL2-devel >= 2.0.1
334 Requires:       alsa-lib-devel
335 Requires:       aom-devel >= 1.0.0
336 %{?with_aribb24:Requires:       aribb24-devel}
337 %{?with_avs2:Requires:  davs2-devel >= 1.6}
338 Requires:       bzip2-devel
339 Requires:       celt-devel >= 0.11.0
340 %{?with_codec2:Requires:        codec2-devel}
341 %{?with_dav1d:Requires: dav1d-devel >= 0.2.1}
342 %{?with_fdk_aac:Requires:       fdk-aac-devel}
343 %{?with_flite:Requires: flite-devel >= 1.4}
344 Requires:       fontconfig-devel
345 Requires:       freetype-devel
346 %{?with_fribidi:Requires:       fribidi-devel}
347 %{?with_gme:Requires:   game-music-emu-devel}
348 Requires:       gnutls-devel
349 Requires:       jack-audio-connection-kit-devel
350 %{?with_kvazaar:Requires:       kvazaar-devel >= 0.8.1}
351 Requires:       lame-libs-devel >= 3.98.3
352 %{?with_lensfun:Requires:       lensfun-devel}
353 Requires:       libass-devel
354 Requires:       libavc1394-devel
355 Requires:       libbluray-devel
356 %{?with_bs2b:Requires:  libbs2b-devel}
357 %{?with_caca:Requires:  libcaca-devel}
358 Requires:       libcdio-paranoia-devel >= 0.90-2
359 %{?with_chromaprint:Requires:   libchromaprint-devel}
360 Requires:       libcrystalhd-devel
361 Requires:       libdc1394-devel >= 2
362 %{?with_libdrm:Requires:        libdrm-devel}
363 Requires:       libgsm-devel
364 Requires:       libiec61883-devel
365 %{?with_libklvanc:Requires:     libklvanc-devel}
366 Requires:       libmodplug-devel
367 %{?with_libmysofa:Requires:     libmysofa-devel >= 0.7}
368 %{?with_openmpt:Requires: libopenmpt-devel >= 0.4.5}
369 Requires:       libraw1394-devel >= 2
370 %{?with_librsvg:Requires:       librsvg-devel >= 2}
371 Requires:       librtmp-devel
372 %{?with_smb:Requires:   libsmbclient-devel}
373 %{?with_ssh:Requires:   libssh-devel}
374 Requires:       libstdc++-devel
375 Requires:       libtheora-devel >= 1.0-0.beta3
376 Requires:       libv4l-devel
377 %{?with_va:Requires:    libva-devel >= 1.0.3}
378 %{?with_va:Requires:    libva-drm-devel >= 1.0.3}
379 %{?with_va:Requires:    libva-x11-devel >= 1.0.3}
380 Requires:       libvdpau-devel >= 0.2
381 Requires:       libvorbis-devel
382 %{?with_vpx:Requires:   libvpx-devel >= 1.4.0}
383 %{?with_webp:Requires:  libwebp-devel >= 0.4.0}
384 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
385 %{?with_x265:Requires:  libx265-devel >= 1.8}
386 # libxcb xcb-shm xcb-xfixes xcb-shape
387 Requires:       libxcb-devel >= 1.4
388 %{?with_libxml2:Requires:       libxml2-devel >= 2}
389 %{?with_lv2:Requires:   lilv-devel}
390 %{?with_mfx:Requires:   mfx_dispatch-devel}
391 Requires:       opencore-amr-devel
392 %{?with_opencv:Requires:        opencv-devel >= 2}
393 %{?with_openh264:Requires:      openh264-devel >= 1.3}
394 Requires:       openjpeg2-devel >= 2.1
395 Requires:       opus-devel
396 %{?with_pulseaudio:Requires:    pulseaudio-devel}
397 %{?with_rkmpp:Requires: rockchip-mpp-devel >= 1.3.7}
398 %{?with_rubberband:Requires:    rubberband-devel >= 1.8.1}
399 %{?with_shine:Requires: shine-devel >= 3.0.0}
400 %{?with_snappy:Requires:        snappy-devel}
401 %{?with_soxr:Requires:  soxr-devel}
402 Requires:       speex-devel >= 1:1.2-rc1
403 %{?with_srt:Requires:   srt-devel >= 1.3}
404 %{?with_tesseract:Requires:     tesseract-devel}
405 Requires:       twolame-devel >= 0.3.10
406 %{?with_vapoursynth:Requires:   vapoursynth-devel >= 42}
407 %{?with_vidstab:Requires:       vid.stab-devel >= 0.98}
408 Requires:       vo-amrwbenc-devel
409 %{?with_vmaf:Requires:  vmaf-devel >= 1.3.9}
410 %{?with_wavpack:Requires:       wavpack-devel}
411 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
412 Requires:       xavs-devel
413 %{?with_avs2:Requires:  xavs2-devel >= 1.3}
414 Requires:       xorg-lib-libX11-devel
415 Requires:       xorg-lib-libXext-devel
416 Requires:       xorg-lib-libXv-devel
417 Requires:       xvid-devel >= 1:1.1.0
418 Requires:       xz-devel
419 %{?with_zmq:Requires:   zeromq-devel}
420 %{?with_zimg:Requires:  zimg-devel >= 2.7.0}
421 Requires:       zlib-devel
422 %{?with_zvbi:Requires:  zvbi-devel >= 0.2.28}
423 Obsoletes:      libpostproc-devel
424
425 %description devel
426 ffmpeg header files.
427
428 %description devel -l pl.UTF-8
429 Pliki nagłówkowe ffmpeg.
430
431 %package static
432 Summary:        ffmpeg static libraries
433 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
434 Group:          Development/Libraries
435 Requires:       %{name}-devel = %{version}-%{release}
436
437 %description static
438 ffmpeg static libraries (libavcodec and libavformat).
439
440 %description static -l pl.UTF-8
441 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
442
443 %package ffplay
444 Summary:        FFplay - SDL-based media player
445 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
446 Group:          Applications/Multimedia
447 Requires:       %{name}-libs = %{version}-%{release}
448
449 %description ffplay
450 FFplay is a very simple and portable media player using the FFmpeg
451 libraries and the SDL library. It is mostly used as a test bench for
452 the various APIs of FFmpeg.
453
454 %description ffplay -l pl.UTF-8
455 FFplay to bardzo prosty i przenoÅ›ny odtwarzacz mediów używajÄ…cy
456 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
457 testowania różnych API FFmpeg.
458
459 %package doc
460 Summary:        FFmpeg documentation in HTML format
461 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
462 Group:          Documentation
463 %if "%{_rpmversion}" >= "5"
464 BuildArch:      noarch
465 %endif
466
467 %description doc
468 FFmpeg documentation in HTML format.
469
470 %description doc -l pl.UTF-8
471 Dokumentacja pakietu FFmpeg w formacie HTML.
472
473 %prep
474 %setup -q
475 %patch0 -p1
476
477 # package the grep result for mplayer, the result formatted as ./mplayer/configure
478 cat <<EOF > ffmpeg-avconfig
479 #! /bin/sh
480 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
481 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
482 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
483 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
484 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
485 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
486 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
487 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
488 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
489 EOF
490 cat <<'EOF' >> ffmpeg-avconfig
491
492 case "$1" in
493 --decoders)
494         echo $libavdecoders_all
495         ;;
496 --encoders)
497         echo $libavencoders_all
498         ;;
499 --parsers)
500         echo $libavparsers_all
501         ;;
502 --bsfs)
503         echo $libavbsfs_all
504         ;;
505 --demuxers)
506         echo $libavdemuxers_all
507         ;;
508 --muxers)
509         echo $libavmuxers_all
510         ;;
511 --protocols)
512         echo $libavprotocols_all
513         ;;
514 --hwaccels)
515         echo $libavhwaccels_all
516         ;;
517 --filters)
518         echo $libavfilters_all
519         ;;
520 *)
521         cat <<USAGE
522 Usage: $0 [OPTION]
523 Options:
524   --decoders
525   --encoders
526   --parsers
527   --bsfs
528   --demuxers
529   --muxers
530   --protocols
531   --hwaccels
532   --filters
533 USAGE
534         exit 1;;
535 esac
536
537 exit 0
538 EOF
539
540 %build
541 # notes:
542 # - it's not autoconf configure
543 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
544 ./configure \
545         --arch=%{_target_base_arch} \
546         --prefix=%{_prefix} \
547         --libdir=%{_libdir} \
548         --shlibdir=%{_libdir} \
549         --mandir=%{_mandir} \
550         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
551         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
552         --cc="%{__cc}" \
553         --disable-debug \
554         --disable-optimizations \
555         --disable-stripping \
556         %{!?with_doc:--disable-doc} \
557         --enable-avfilter \
558         --enable-avresample \
559         %{?with_chromaprint:--enable-chromaprint} \
560         %{?with_cudasdk:--enable-cuda-nvcc} \
561         %{?with_decklink:--enable-decklink} \
562         %{!?with_ffnvcodec:--disable-ffnvcodec} \
563         --enable-gnutls \
564         --enable-gpl \
565         --enable-version3 \
566         %{?with_frei0r:--enable-frei0r} \
567         %{?with_ladspa:--enable-ladspa} \
568         --enable-libaom \
569         %{?with_aribb24:--enable-libaribb24} \
570         --enable-libass \
571         --enable-libbluray \
572         %{?with_bs2b:--enable-libbs2b} \
573         %{?with_caca:--enable-libcaca} \
574         --enable-libcelt \
575         --enable-libcdio \
576         %{?with_codec2:--enable-libcodec2} \
577         %{?with_dav1d:--enable-libdav1d} \
578         %{?with_avs2:--enable-libdavs2} \
579         --enable-libdc1394 \
580         %{?with_libdrm:--enable-libdrm} \
581         %{?with_flite:--enable-libflite} \
582         --enable-libfontconfig \
583         --enable-libfreetype \
584         %{?with_fribidi:--enable-libfribidi} \
585         %{?with_gme:--enable-libgme} \
586         --enable-libgsm \
587         --enable-libiec61883 \
588         %{?with_ilbc:--enable-libilbc} \
589         --enable-libjack \
590         %{?with_kvazaar:--enable-libkvazaar} \
591         %{?with_libklvanc:--enable-libklvanc} \
592         %{?with_lensfun:--enable-liblensfun} \
593         %{?with_mfx:--enable-libmfx} \
594         --enable-libmodplug \
595         --enable-libmp3lame \
596         %{?with_libmysofa:--enable-libmysofa} \
597         --enable-libopencore-amrnb \
598         --enable-libopencore-amrwb \
599         %{?with_opencv:--enable-libopencv} \
600         %{?with_openh264:--enable-libopenh264} \
601         --enable-libopenjpeg \
602         %{?with_openmpt:--enable-libopenmpt} \
603         --enable-libopus \
604         %{?with_pulseaudio:--enable-libpulse} \
605         %{?with_librsvg:--enable-librsvg} \
606         --enable-librtmp \
607         %{?with_srt:--enable-libsrt} \
608         %{?with_libxml2:--enable-libxml2} \
609         %{?with_rubberband:--enable-librubberband} \
610         %{?with_shine:--enable-libshine} \
611         %{?with_smb:--enable-libsmbclient} \
612         %{?with_snappy:--enable-libsnappy} \
613         %{?with_soxr:--enable-libsoxr} \
614         --enable-libspeex \
615         %{?with_ssh:--enable-libssh} \
616         %{?with_tesseract:--enable-libtesseract} \
617         --enable-libtheora \
618         --enable-libtwolame \
619         --enable-libv4l2 \
620         %{?with_vidstab:--enable-libvidstab} \
621         %{?with_vmaf:--enable-libvmaf} \
622         --enable-libvo-amrwbenc \
623         --enable-libvorbis \
624         %{?with_vpx:--enable-libvpx} \
625         %{?with_wavpack:--enable-libwavpack} \
626         %{?with_webp:--enable-libwebp} \
627         %{?with_x264:--enable-libx264} \
628         %{?with_x265:--enable-libx265} \
629         --enable-libxavs \
630         %{?with_avs2:--enable-libxavs2} \
631         --enable-libxcb \
632         --enable-libxvid \
633         %{?with_zimg:--enable-libzimg} \
634         %{?with_zmq:--enable-libzmq} \
635         %{?with_zvbi:--enable-libzvbi} \
636         %{?with_lv2:--enable-lv2} \
637         %{?with_omx:--enable-omx} \
638         %{?with_openal:--enable-openal} \
639         %{?with_opencl:--enable-opencl} \
640         %{?with_opengl:--enable-opengl} \
641         %{?with_pocketsphinx:--enable-pocketsphinx} \
642         --enable-postproc \
643         --enable-pthreads \
644         %{?with_rkmpp:--enable-rkmpp} \
645         --enable-shared \
646         --enable-swscale \
647         %{!?with_va:--disable-vaapi} \
648         %{?with_vapoursynth:--enable-vapoursynth} \
649 %ifnarch %{ix86} %{x8664}
650         --disable-mmx \
651 %endif
652 %ifarch i386 i486
653         --disable-mmx \
654 %endif
655 %ifarch x32
656         --disable-asm \
657 %endif
658 %if %{with nonfree}
659         --enable-nonfree \
660         %{?with_fdk_aac:--enable-libfdk-aac} \
661         %{?with_npp:--enable-libnpp} \
662 %endif
663         --enable-runtime-cpudetect
664
665 %{__make} \
666         V=1
667
668 # CC_O to add -c to commandline. makefile should be patched
669 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
670
671 %{?with_tests:%{__make} check V=1}
672
673 %install
674 rm -rf $RPM_BUILD_ROOT
675 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
676         $RPM_BUILD_ROOT%{_includedir}/ffmpeg
677
678 %{__make} install install-headers \
679         DESTDIR=$RPM_BUILD_ROOT \
680         V=1
681
682 # install nonstandard, non-public headers manually
683 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
684 for a in libavutil/*/{asm,bswap}.h; do
685         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
686 done
687 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
688
689 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
690
691 # install as ffmpeg-avconfig to avoid with possible programs looking for
692 # ffmpeg-config and expecting --libs output from it which is not implemented
693 # simple to do (by querying pkgconfig), but why?
694 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
695
696 # packaged as %doc in -doc
697 %if %{with doc}
698 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
699 %endif
700
701 install -d $RPM_BUILD_ROOT%{_examplesdir}
702 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
703
704 %clean
705 rm -rf $RPM_BUILD_ROOT
706
707 %post   libs -p /sbin/ldconfig
708 %postun libs -p /sbin/ldconfig
709
710 %files
711 %defattr(644,root,root,755)
712 %doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
713 %attr(755,root,root) %{_bindir}/ffmpeg
714 %attr(755,root,root) %{_bindir}/ffprobe
715 %attr(755,root,root) %{_bindir}/qt-faststart
716 %dir %{_datadir}/ffmpeg
717 %{_datadir}/ffmpeg/*.ffpreset
718 %{_datadir}/ffmpeg/ffprobe.xsd
719 %if %{with doc}
720 %{_mandir}/man1/ffmpeg.1*
721 %{_mandir}/man1/ffmpeg-all.1*
722 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
723 %{_mandir}/man1/ffmpeg-codecs.1*
724 %{_mandir}/man1/ffmpeg-devices.1*
725 %{_mandir}/man1/ffmpeg-filters.1*
726 %{_mandir}/man1/ffmpeg-formats.1*
727 %{_mandir}/man1/ffmpeg-protocols.1*
728 %{_mandir}/man1/ffmpeg-resampler.1*
729 %{_mandir}/man1/ffmpeg-scaler.1*
730 %{_mandir}/man1/ffmpeg-utils.1*
731 %{_mandir}/man1/ffprobe.1*
732 %{_mandir}/man1/ffprobe-all.1*
733 %endif
734
735 %files libs
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
738 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
739 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
741 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
743 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
745 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
747 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
748 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
749 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
750 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
751 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
752 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
753 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
755
756 %files devel
757 %defattr(644,root,root,755)
758 %doc doc/optimization.txt
759 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
760 %attr(755,root,root) %{_libdir}/libavcodec.so
761 %attr(755,root,root) %{_libdir}/libavdevice.so
762 %attr(755,root,root) %{_libdir}/libavfilter.so
763 %attr(755,root,root) %{_libdir}/libavformat.so
764 %attr(755,root,root) %{_libdir}/libavresample.so
765 %attr(755,root,root) %{_libdir}/libavutil.so
766 %attr(755,root,root) %{_libdir}/libpostproc.so
767 %attr(755,root,root) %{_libdir}/libswresample.so
768 %attr(755,root,root) %{_libdir}/libswscale.so
769 %{_includedir}/ffmpeg
770 %{_includedir}/libavcodec
771 %{_includedir}/libavdevice
772 %{_includedir}/libavfilter
773 %{_includedir}/libavformat
774 %{_includedir}/libavresample
775 %{_includedir}/libavutil
776 %{_includedir}/libpostproc
777 %{_includedir}/libswresample
778 %{_includedir}/libswscale
779 %{_pkgconfigdir}/libavcodec.pc
780 %{_pkgconfigdir}/libavdevice.pc
781 %{_pkgconfigdir}/libavfilter.pc
782 %{_pkgconfigdir}/libavformat.pc
783 %{_pkgconfigdir}/libavresample.pc
784 %{_pkgconfigdir}/libavutil.pc
785 %{_pkgconfigdir}/libpostproc.pc
786 %{_pkgconfigdir}/libswresample.pc
787 %{_pkgconfigdir}/libswscale.pc
788 %if %{with doc}
789 %{_mandir}/man3/libavcodec.3*
790 %{_mandir}/man3/libavdevice.3*
791 %{_mandir}/man3/libavfilter.3*
792 %{_mandir}/man3/libavformat.3*
793 %{_mandir}/man3/libavutil.3*
794 %{_mandir}/man3/libswresample.3*
795 %{_mandir}/man3/libswscale.3*
796 %endif
797 %{_examplesdir}/%{name}-%{version}
798
799 %files static
800 %defattr(644,root,root,755)
801 %{_libdir}/libavcodec.a
802 %{_libdir}/libavdevice.a
803 %{_libdir}/libavfilter.a
804 %{_libdir}/libavformat.a
805 %{_libdir}/libavresample.a
806 %{_libdir}/libavutil.a
807 %{_libdir}/libpostproc.a
808 %{_libdir}/libswresample.a
809 %{_libdir}/libswscale.a
810
811 %files ffplay
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_bindir}/ffplay
814 %if %{with doc}
815 %{_mandir}/man1/ffplay.1*
816 %{_mandir}/man1/ffplay-all.1*
817 %endif
818
819 %if %{with doc}
820 %files doc
821 %defattr(644,root,root,755)
822 %doc doc/*.html
823 %endif
This page took 3.132003 seconds and 2 git commands to generate.