]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- release 2
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO:
2 # - libtensorflow [-ltensorflow tensorflow/c/c_api.h]
3 # - AMF >= 1.4.4.1 (available at https://github.com/GPUOpen-LibrariesAndSDKs/AMF, where is original source?)
4 #
5 # How to deal with ffmpeg/opencv/chromaprint checken-egg problem:
6 #       1. make-request -r --with bootstrap ffmpeg.spec
7 #       2  bump release of opencv.spec and chromaprint.spec
8 #       3. make-request -r opencv.spec chromaprint.spec
9 #       4. bump release of ffmpeg.spec
10 #       5. make-request -r ffmpeg.spec
11 #
12 # Conditional build:
13 %bcond_with     bootstrap       # disable features to able to build without installed ffmpeg
14 %bcond_with     nonfree         # unblock non free options of package (currently: cuda_nvcc, decklib, fdk_aac, npp, openssl, libressl/libtls)
15 %bcond_without  aribb24         # ARIB text and caption decoding via libaribb24
16 %bcond_without  avs2            # AVS2 de/encoding via libdavs2/libxavs2
17 %bcond_without  bs2b            # BS2B audio filter support
18 %bcond_without  caca            # textual display using libcaca
19 %bcond_without  codec2          # codec2 support using libcodec2
20 %bcond_without  chromaprint     # audio fingerprinting with chromaprint
21 %bcond_with     cudasdk         # NVIDIA CUDA code using nvcc from CUDA SDK [BR: cuda.h, non-free]
22 %bcond_without  dav1d           # AV1 decoding via libdav1d
23 %bcond_with     decklink        # Blackmagic DeckLink I/O support (requires nonfree)
24 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
25 %bcond_without  ffnvcodec       # NVIDIA codecs support using ffnvcodec headers (covered: cuda cuvid nvdec nvenc)
26 %bcond_without  flite           # flite voice synthesis support
27 %bcond_without  frei0r          # frei0r video filtering
28 %bcond_without  fribidi         # fribidi support
29 %bcond_without  gme             # Game Music Emu support
30 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
31 %bcond_without  kvazaar         # Kvazaar HEVC encoder support
32 %bcond_without  ladspa          # LADSPA audio filtering
33 %bcond_without  lensfun         # lensfun lens correction
34 %bcond_with     libdrm          # Linux Direct Rendering Manager code
35 %bcond_with     libklvanc       # Kernel Labs VANC processing (in decklink driver)
36 %bcond_without  libmysofa       # sofalizer filter
37 %bcond_with     librsvg         # SVG rasterization via librsvg
38 %bcond_with     libxml2         # XML parsing using libxml2
39 %bcond_without  lv2             # LV2 audio filtering
40 %bcond_with     mfx             # MFX hardware acceleration support
41 %bcond_with     npp             # NVIDIA Performance Primitives-based code (requires nonfree) [BR: libnppc+libnppi, npp.h]
42 %bcond_without  omx             # OpenMAX IL support
43 %bcond_without  openal          # OpenAL 1.1 capture support
44 %bcond_without  opencl          # OpenCL 1.2 code
45 %bcond_without  opencv          # OpenCV video filtering
46 %bcond_without  opengl          # OpenGL rendering support
47 %bcond_with     openh264        # OpenH264 H.264 encoder
48 %bcond_without  openmpt         # OpenMPT module decoder
49 %bcond_with     pocketsphinx    # asr filter using PocketSphinx
50 %bcond_without  pulseaudio      # PulseAudio input support
51 %bcond_with     rkmpp           # Rockchip Media Process Platform code [implies libdrm]
52 %bcond_without  rubberband      # rubberband filter
53 %bcond_without  shine           # shine fixed-point MP3 encoder
54 %bcond_without  snappy          # Snappy compression support (needed for hap encoding)
55 %bcond_without  srt             # Haivision SRT protocol support
56 %bcond_without  ssh             # SFTP protocol support via libssh
57 %bcond_with     smb             # SMB support via libsmbclient
58 %bcond_without  soxr            # SoX Resampler support
59 %bcond_with     tesseract       # OCR filter based on Tesseract
60 %bcond_without  vmaf            # VMAF filter support
61 %bcond_without  x264            # H.264 x264 encoder
62 %bcond_without  x265            # H.265/HEVC x265 encoder
63 %bcond_without  va              # VAAPI (Video Acceleration API)
64 %bcond_without  vapoursynth     # VapourSynth demuxer
65 %bcond_without  vidstab         # vid.stab video stabilization support
66 %bcond_without  vpx             # VP8, a high-quality video codec
67 %bcond_without  wavpack         # wavpack encoding support
68 %bcond_without  webp            # WebP encoding support
69 %bcond_without  zimg            # zscale filter based on z.lib
70 %bcond_without  zmq             # 0MQ message passing
71 %bcond_without  zvbi            # teletext via libzvbi
72 %bcond_without  doc             # don't build docs
73 %bcond_with     tests           # "make check" (some tests fail as of 2.5)
74
75 %if %{with bootstrap}
76 %undefine       with_opencv
77 %undefine       with_chromaprint
78 %endif
79 %if %{with rkmpp}
80 %define         with_libdrm     1
81 %endif
82
83 %ifnarch %{ix86} %{x8664}
84 %undefine       with_ffnvcodec
85 %endif
86 %ifnarch %{ix86} %{x8664} %{arm}
87 %undefine       with_x265
88 %endif
89 %ifarch i386 i486
90 %undefine       with_x265
91 %endif
92 Summary:        FFmpeg - a very fast video and audio converter
93 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
94 Name:           ffmpeg
95 Version:        4.2.2
96 Release:        2
97 # LGPL or GPL, chosen at configure time (GPL version is more featured)
98 # GPL: frei0r libcdio libdavs2 rubberband vidstab x264 x265 xavs xavs2 xvid
99 # v3 (allows *GPLv3 or Apache-licensed libs): gmp lensfun opencore-amr vmaf vo-*enc rkmpp
100 # GPLv3: smbclient
101 License:        GPL v3+ with LGPL v3+ parts
102 Group:          Applications/Multimedia
103 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.xz
104 # Source0-md5:  348956fc2faa57a2f79bbb84ded9fbc3
105 Patch0:         %{name}-omx-libnames.patch
106 URL:            http://www.ffmpeg.org/
107 %{?with_decklink:BuildRequires: Blackmagic_DeckLink_SDK >= 10.9.5}
108 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
109 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
110 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
111 # libomxil-bellagio-devel or limoi-core-devel (just headers, library is dlopened at runtime)
112 %{?with_omx:BuildRequires:      OpenMAX-IL-devel}
113 BuildRequires:  SDL2-devel >= 2.0.1
114 BuildRequires:  SDL2-devel < 2.1.0
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  aom-devel >= 1.0.0
117 %{?with_aribb24:BuildRequires:  aribb24-devel}
118 BuildRequires:  bzip2-devel
119 BuildRequires:  celt-devel >= 0.11.0
120 %{?with_codec2:BuildRequires:   codec2-devel}
121 %{?with_dav1d:BuildRequires:    dav1d-devel >= 0.2.1}
122 %{?with_avs2:BuildRequires:     davs2-devel >= 1.6}
123 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
124 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
125 BuildRequires:  fontconfig-devel
126 BuildRequires:  freetype-devel
127 %{?with_frei0r:BuildRequires:   frei0r-devel}
128 %{?with_fribidi:BuildRequires:  fribidi-devel}
129 %{?with_gme:BuildRequires:      game-music-emu-devel}
130 %ifarch ppc
131 # require version with altivec support fixed
132 BuildRequires:  gcc >= 5:3.3.2-3
133 %endif
134 BuildRequires:  gmp-devel
135 BuildRequires:  gnutls-devel
136 BuildRequires:  jack-audio-connection-kit-devel
137 %{?with_kvazaar:BuildRequires:  kvazaar-devel >= 0.8.1}
138 %{?with_ladspa:BuildRequires:   ladspa-devel}
139 BuildRequires:  lame-libs-devel >= 3.98.3
140 %{?with_lensfun:BuildRequires:  lensfun-devel}
141 BuildRequires:  libass-devel
142 BuildRequires:  libavc1394-devel
143 %{?with_bs2b:BuildRequires:     libbs2b-devel}
144 BuildRequires:  libbluray-devel
145 %{?with_caca:BuildRequires:     libcaca-devel}
146 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
147 %{?with_chromaprint:BuildRequires:      libchromaprint-devel}
148 BuildRequires:  libcrystalhd-devel
149 BuildRequires:  libdc1394-devel >= 2
150 %{?with_libdrm:BuildRequires:   libdrm-devel}
151 BuildRequires:  libgsm-devel
152 BuildRequires:  libiec61883-devel
153 %{?with_libklvanc:BuildRequires:        libklvanc-devel}
154 BuildRequires:  libmodplug-devel
155 %{?with_libmysofa:BuildRequires:        libmysofa-devel >= 0.7}
156 %{?with_openmpt:BuildRequires: libopenmpt-devel >= 0.4.5}
157 BuildRequires:  libraw1394-devel >= 2
158 %{?with_librsvg:BuildRequires:  librsvg-devel >= 2}
159 BuildRequires:  librtmp-devel
160 %{?with_ssh:BuildRequires:      libssh-devel}
161 %{?with_smb:BuildRequires:      libsmbclient-devel}
162 BuildRequires:  libtheora-devel >= 1.0-0.beta3
163 BuildRequires:  libtool >= 2:1.4d-3
164 BuildRequires:  libv4l-devel
165 %if %{with va}
166 BuildRequires:  libva-devel >= 1.0.3
167 BuildRequires:  libva-drm-devel >= 1.0.3
168 BuildRequires:  libva-x11-devel >= 1.0.3
169 %endif
170 BuildRequires:  libvdpau-devel >= 0.2
171 BuildRequires:  libvorbis-devel
172 %{?with_vpx:BuildRequires:      libvpx-devel >= 1.4.0}
173 %{?with_webp:BuildRequires:     libwebp-devel >= 0.4.0}
174 # X264_BUILD >= 118
175 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
176 # X265_BUILD >= 68
177 %{?with_x265:BuildRequires:     libx265-devel >= 1.8}
178 # libxcb xcb-shm xcb-xfixes xcb-shape
179 BuildRequires:  libxcb-devel >= 1.4
180 %{?with_libxml2:BuildRequires:  libxml2-devel >= 2}
181 %{?with_lv2:BuildRequires:      lilv-devel}
182 %{?with_lv2:BuildRequires:      lv2-devel}
183 %{?with_mfx:BuildRequires:      mfx_dispatch-devel}
184 %ifarch %{ix86}
185 %ifnarch i386 i486
186 BuildRequires:  nasm
187 %endif
188 %endif
189 %{?with_ffnvcodec:BuildRequires:        nv-codec-headers >= 9.0.18.0}
190 # amrnb,amrwb
191 BuildRequires:  opencore-amr-devel
192 %{?with_opencv:BuildRequires:   opencv-devel >= 2}
193 %{?with_openh264:BuildRequires: openh264-devel >= 1.3}
194 BuildRequires:  openjpeg2-devel >= 2.1
195 BuildRequires:  opus-devel
196 BuildRequires:  perl-Encode
197 BuildRequires:  perl-tools-pod
198 %{?with_pocketsphinx:BuildRequires:     pocketsphinx-devel > 0.8}
199 BuildRequires:  pkgconfig
200 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
201 %{?with_rkmpp:BuildRequires:    rockchip-mpp-devel >= 1.3.7}
202 BuildRequires:  rpmbuild(macros) >= 1.470
203 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.8.1}
204 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
205 %{?with_snappy:BuildRequires:   snappy-devel}
206 %{?with_soxr:BuildRequires:     soxr-devel}
207 BuildRequires:  speex-devel >= 1:1.2-rc1
208 %{?with_srt:BuildRequires:      srt-devel >= 1.3}
209 %{?with_tesseract:BuildRequires:        tesseract-devel}
210 %{?with_doc:BuildRequires:      tetex}
211 %{?with_doc:BuildRequires:      texi2html}
212 %{?with_doc:BuildRequires:      texinfo}
213 BuildRequires:  twolame-devel >= 0.3.10
214 %{?with_vapoursynth:BuildRequires:      vapoursynth-devel >= 42}
215 %{?with_vidstab:BuildRequires:  vid.stab-devel >= 0.98}
216 %{?with_vmaf:BuildRequires:     vmaf-devel >= 1.3.9}
217 BuildRequires:  vo-amrwbenc-devel
218 %{?with_wavpack:BuildRequires:  wavpack-devel}
219 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
220 BuildRequires:  xavs-devel
221 %{?with_avs2:BuildRequires:     xavs2-devel >= 1.3}
222 BuildRequires:  xorg-lib-libX11-devel
223 BuildRequires:  xorg-lib-libXext-devel
224 BuildRequires:  xorg-lib-libXv-devel
225 BuildRequires:  xvid-devel >= 1:1.1.0
226 BuildRequires:  xz-devel
227 BuildRequires:  yasm
228 %{?with_zmq:BuildRequires:      zeromq-devel}
229 %{?with_zimg:BuildRequires:     zimg-devel >= 2.7.0}
230 BuildRequires:  zlib-devel
231 %{?with_zvbi:BuildRequires:     zvbi-devel >= 0.2.28}
232 %{?with_autoreqdep:BuildConflicts:      libpostproc}
233 # overflows maximum hash table size
234 BuildConflicts: pdksh < 5.2.14-57
235 Requires:       %{name}-libs = %{version}-%{release}
236 Obsoletes:      libpostproc
237 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
238
239 %define         specflags       -fno-strict-aliasing
240
241 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
242 %define         specflags_ia32  -fomit-frame-pointer
243 # -mmmx is needed to enable <mmintrin.h> code.
244 %define         specflags_i586  -mmmx
245 %define         specflags_i686  -mmmx
246 %define         specflags_ppc   -fPIC
247
248 %description
249 FFmpeg is a complete solution to record, convert and stream audio and
250 video. It is a command line tool to convert one video file format to
251 another. It also supports grabbing and encoding in real time from a TV
252 card.
253
254 %description -l pl.UTF-8
255 FFmpeg to kompletne rozwiÄ…zanie nagrywania, konwersji i transmisji
256 strumieni dźwiÄ™ku i obrazu. Jest to dziaÅ‚ajÄ…ce z linii poleceÅ„
257 narzÄ™dzie do konwersji obrazu z jednego formatu do innego. ObsÅ‚uguje
258 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
259 telewizyjnej.
260
261 %package libs
262 Summary:        ffmpeg libraries
263 Summary(pl.UTF-8):      Biblioteki ffmpeg
264 Group:          Libraries
265 Requires:       SDL2 >= 2.0.1
266 Requires:       aom >= 1.0.0
267 Requires:       celt >= 0.11.0
268 %{?with_dav1d:Requires: dav1d >= 0.2.1}
269 %{?with_avs2:Requires:  davs2 >= 1.6}
270 %{?with_flite:Requires: flite >= 1.4}
271 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
272 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
273 Requires:       gnutls-libs >= 3.0.20
274 %endif
275 %{?with_kvazaar:Requires:       kvazaar-libs >= 0.8.1}
276 %{?with_libmysofa:Requires:     libmysofa >= 0.7}
277 %{?with_openmpt:Requires: libopenmpt >= 0.4.5}
278 Requires:       libtheora >= 1.0-0.beta3
279 %if %{with va}
280 Requires:       libva >= 1.0.3
281 Requires:       libva-drm >= 1.0.3
282 Requires:       libva-x11 >= 1.0.3
283 %endif
284 Requires:       libvdpau >= 0.2
285 %{?with_vpx:Requires:   libvpx >= 1.4.0}
286 %{?with_webp:Requires:  libwebp >= 0.4.0}
287 %{?with_x264:Requires:  libx264 >= 0.1.3-1.20111212_2245}
288 %{?with_x265:Requires:  libx265 >= 1.8}
289 Requires:       libxcb >= 1.4
290 Requires:       lame-libs >= 3.98.3
291 %{?with_openh264:Requires:      openh264 >= 1.3}
292 Requires:       openjpeg2 >= 2.1
293 %{?with_rkmpp:Requires: rockchip-mpp >= 1.3.7}
294 %{?with_rubberband:Requires:    rubberband-libs >= 1.8.1}
295 %{?with_shine:Requires: shine >= 3.0.0}
296 Requires:       speex >= 1:1.2-rc1
297 %{?with_srt:Requires:   srt >= 1.3}
298 Requires:       twolame-libs >= 0.3.10
299 %{?with_vapoursynth:Requires:   vapoursynth >= 42}
300 %{?with_vidstab:Requires:       vid.stab >= 0.98}
301 %{?with_vmaf:Requires:  vmaf-libs >= 1.3.9}
302 %{?with_avs2:Requires:  xavs2 >= 1.3}
303 Requires:       xvid >= 1:1.1.0
304 %{?with_zimg:Requires:  zimg >= 2.7.0}
305 %{?with_zvbi:Requires:  zvbi >= 0.2.28}
306
307 %description libs
308 This package contains the ffmpeg shared libraries:
309 - the codec library (libavcodec). It supports most existing encoding
310   formats (MPEG, DivX, MPEG4, AC3, DV...),
311 - demuxer library (libavformat). It supports most existing file
312   formats (AVI, MPEG, OGG, Matroska, ASF...),
313 - video postprocessing library (libpostproc).
314
315 %description libs -l pl.UTF-8
316 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
317 - bibliotekÄ™ kodeków (libavcodec); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
318   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
319 - bibliotekÄ™ demuksera (libavformat); obsÅ‚uguje wiÄ™kszość istniejÄ…cych
320   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
321 - bibliotekÄ™ postprocessingu (libpostproc).
322
323 %package devel
324 Summary:        ffmpeg header files
325 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
326 Group:          Development/Libraries
327 Requires:       %{name}-libs = %{version}-%{release}
328 # Libs.private from *.pc
329 %{?with_openal:Requires:        OpenAL-devel >= 1.1}
330 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
331 %{?with_opengl:Requires:        OpenGL-devel}
332 Requires:       SDL2-devel >= 2.0.1
333 Requires:       alsa-lib-devel
334 Requires:       aom-devel >= 1.0.0
335 %{?with_aribb24:Requires:       aribb24-devel}
336 %{?with_avs2:Requires:  davs2-devel >= 1.6}
337 Requires:       bzip2-devel
338 Requires:       celt-devel >= 0.11.0
339 %{?with_codec2:Requires:        codec2-devel}
340 %{?with_dav1d:Requires: dav1d-devel >= 0.2.1}
341 %{?with_fdk_aac:Requires:       fdk-aac-devel}
342 %{?with_flite:Requires: flite-devel >= 1.4}
343 Requires:       fontconfig-devel
344 Requires:       freetype-devel
345 %{?with_fribidi:Requires:       fribidi-devel}
346 %{?with_gme:Requires:   game-music-emu-devel}
347 Requires:       gnutls-devel
348 Requires:       jack-audio-connection-kit-devel
349 %{?with_kvazaar:Requires:       kvazaar-devel >= 0.8.1}
350 Requires:       lame-libs-devel >= 3.98.3
351 %{?with_lensfun:Requires:       lensfun-devel}
352 Requires:       libass-devel
353 Requires:       libavc1394-devel
354 Requires:       libbluray-devel
355 %{?with_bs2b:Requires:  libbs2b-devel}
356 %{?with_caca:Requires:  libcaca-devel}
357 Requires:       libcdio-paranoia-devel >= 0.90-2
358 %{?with_chromaprint:Requires:   libchromaprint-devel}
359 Requires:       libcrystalhd-devel
360 Requires:       libdc1394-devel >= 2
361 %{?with_libdrm:Requires:        libdrm-devel}
362 Requires:       libgsm-devel
363 Requires:       libiec61883-devel
364 %{?with_libklvanc:Requires:     libklvanc-devel}
365 Requires:       libmodplug-devel
366 %{?with_libmysofa:Requires:     libmysofa-devel >= 0.7}
367 %{?with_openmpt:Requires: libopenmpt-devel >= 0.4.5}
368 Requires:       libraw1394-devel >= 2
369 %{?with_librsvg:Requires:       librsvg-devel >= 2}
370 Requires:       librtmp-devel
371 %{?with_smb:Requires:   libsmbclient-devel}
372 %{?with_ssh:Requires:   libssh-devel}
373 Requires:       libstdc++-devel
374 Requires:       libtheora-devel >= 1.0-0.beta3
375 Requires:       libv4l-devel
376 %{?with_va:Requires:    libva-devel >= 1.0.3}
377 %{?with_va:Requires:    libva-drm-devel >= 1.0.3}
378 %{?with_va:Requires:    libva-x11-devel >= 1.0.3}
379 Requires:       libvdpau-devel >= 0.2
380 Requires:       libvorbis-devel
381 %{?with_vpx:Requires:   libvpx-devel >= 1.4.0}
382 %{?with_webp:Requires:  libwebp-devel >= 0.4.0}
383 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
384 %{?with_x265:Requires:  libx265-devel >= 1.8}
385 # libxcb xcb-shm xcb-xfixes xcb-shape
386 Requires:       libxcb-devel >= 1.4
387 %{?with_libxml2:Requires:       libxml2-devel >= 2}
388 %{?with_lv2:Requires:   lilv-devel}
389 %{?with_mfx:Requires:   mfx_dispatch-devel}
390 Requires:       opencore-amr-devel
391 %{?with_opencv:Requires:        opencv-devel >= 2}
392 %{?with_openh264:Requires:      openh264-devel >= 1.3}
393 Requires:       openjpeg2-devel >= 2.1
394 Requires:       opus-devel
395 %{?with_pulseaudio:Requires:    pulseaudio-devel}
396 %{?with_rkmpp:Requires: rockchip-mpp-devel >= 1.3.7}
397 %{?with_rubberband:Requires:    rubberband-devel >= 1.8.1}
398 %{?with_shine:Requires: shine-devel >= 3.0.0}
399 %{?with_snappy:Requires:        snappy-devel}
400 %{?with_soxr:Requires:  soxr-devel}
401 Requires:       speex-devel >= 1:1.2-rc1
402 %{?with_srt:Requires:   srt-devel >= 1.3}
403 %{?with_tesseract:Requires:     tesseract-devel}
404 Requires:       twolame-devel >= 0.3.10
405 %{?with_vapoursynth:Requires:   vapoursynth-devel >= 42}
406 %{?with_vidstab:Requires:       vid.stab-devel >= 0.98}
407 Requires:       vo-amrwbenc-devel
408 %{?with_vmaf:Requires:  vmaf-devel >= 1.3.9}
409 %{?with_wavpack:Requires:       wavpack-devel}
410 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
411 Requires:       xavs-devel
412 %{?with_avs2:Requires:  xavs2-devel >= 1.3}
413 Requires:       xorg-lib-libX11-devel
414 Requires:       xorg-lib-libXext-devel
415 Requires:       xorg-lib-libXv-devel
416 Requires:       xvid-devel >= 1:1.1.0
417 Requires:       xz-devel
418 %{?with_zmq:Requires:   zeromq-devel}
419 %{?with_zimg:Requires:  zimg-devel >= 2.7.0}
420 Requires:       zlib-devel
421 %{?with_zvbi:Requires:  zvbi-devel >= 0.2.28}
422 Obsoletes:      libpostproc-devel
423
424 %description devel
425 ffmpeg header files.
426
427 %description devel -l pl.UTF-8
428 Pliki nagłówkowe ffmpeg.
429
430 %package static
431 Summary:        ffmpeg static libraries
432 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
433 Group:          Development/Libraries
434 Requires:       %{name}-devel = %{version}-%{release}
435
436 %description static
437 ffmpeg static libraries (libavcodec and libavformat).
438
439 %description static -l pl.UTF-8
440 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
441
442 %package ffplay
443 Summary:        FFplay - SDL-based media player
444 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
445 Group:          Applications/Multimedia
446 Requires:       %{name}-libs = %{version}-%{release}
447
448 %description ffplay
449 FFplay is a very simple and portable media player using the FFmpeg
450 libraries and the SDL library. It is mostly used as a test bench for
451 the various APIs of FFmpeg.
452
453 %description ffplay -l pl.UTF-8
454 FFplay to bardzo prosty i przenoÅ›ny odtwarzacz mediów używajÄ…cy
455 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
456 testowania różnych API FFmpeg.
457
458 %package doc
459 Summary:        FFmpeg documentation in HTML format
460 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
461 Group:          Documentation
462 %if "%{_rpmversion}" >= "5"
463 BuildArch:      noarch
464 %endif
465
466 %description doc
467 FFmpeg documentation in HTML format.
468
469 %description doc -l pl.UTF-8
470 Dokumentacja pakietu FFmpeg w formacie HTML.
471
472 %prep
473 %setup -q
474 %patch0 -p1
475
476 # package the grep result for mplayer, the result formatted as ./mplayer/configure
477 cat <<EOF > ffmpeg-avconfig
478 #! /bin/sh
479 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
480 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
481 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
482 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
483 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
484 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
485 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
486 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
487 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
488 EOF
489 cat <<'EOF' >> ffmpeg-avconfig
490
491 case "$1" in
492 --decoders)
493         echo $libavdecoders_all
494         ;;
495 --encoders)
496         echo $libavencoders_all
497         ;;
498 --parsers)
499         echo $libavparsers_all
500         ;;
501 --bsfs)
502         echo $libavbsfs_all
503         ;;
504 --demuxers)
505         echo $libavdemuxers_all
506         ;;
507 --muxers)
508         echo $libavmuxers_all
509         ;;
510 --protocols)
511         echo $libavprotocols_all
512         ;;
513 --hwaccels)
514         echo $libavhwaccels_all
515         ;;
516 --filters)
517         echo $libavfilters_all
518         ;;
519 *)
520         cat <<USAGE
521 Usage: $0 [OPTION]
522 Options:
523   --decoders
524   --encoders
525   --parsers
526   --bsfs
527   --demuxers
528   --muxers
529   --protocols
530   --hwaccels
531   --filters
532 USAGE
533         exit 1;;
534 esac
535
536 exit 0
537 EOF
538
539 %build
540 # notes:
541 # - it's not autoconf configure
542 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
543 ./configure \
544         --arch=%{_target_base_arch} \
545         --prefix=%{_prefix} \
546         --libdir=%{_libdir} \
547         --shlibdir=%{_libdir} \
548         --mandir=%{_mandir} \
549         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}%{?with_decklink: -I/usr/include/decklink}" \
550         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
551         --cc="%{__cc}" \
552         --disable-debug \
553         --disable-optimizations \
554         --disable-stripping \
555         %{!?with_doc:--disable-doc} \
556         --enable-avfilter \
557         --enable-avresample \
558         %{?with_chromaprint:--enable-chromaprint} \
559         %{?with_cudasdk:--enable-cuda-nvcc} \
560         %{?with_decklink:--enable-decklink} \
561         %{!?with_ffnvcodec:--disable-ffnvcodec} \
562         --enable-gnutls \
563         --enable-gpl \
564         --enable-version3 \
565         %{?with_frei0r:--enable-frei0r} \
566         %{?with_ladspa:--enable-ladspa} \
567         --enable-libaom \
568         %{?with_aribb24:--enable-libaribb24} \
569         --enable-libass \
570         --enable-libbluray \
571         %{?with_bs2b:--enable-libbs2b} \
572         %{?with_caca:--enable-libcaca} \
573         --enable-libcelt \
574         --enable-libcdio \
575         %{?with_codec2:--enable-libcodec2} \
576         %{?with_dav1d:--enable-libdav1d} \
577         %{?with_avs2:--enable-libdavs2} \
578         --enable-libdc1394 \
579         %{?with_libdrm:--enable-libdrm} \
580         %{?with_flite:--enable-libflite} \
581         --enable-libfontconfig \
582         --enable-libfreetype \
583         %{?with_fribidi:--enable-libfribidi} \
584         %{?with_gme:--enable-libgme} \
585         --enable-libgsm \
586         --enable-libiec61883 \
587         %{?with_ilbc:--enable-libilbc} \
588         --enable-libjack \
589         %{?with_kvazaar:--enable-libkvazaar} \
590         %{?with_libklvanc:--enable-libklvanc} \
591         %{?with_lensfun:--enable-liblensfun} \
592         %{?with_mfx:--enable-libmfx} \
593         --enable-libmodplug \
594         --enable-libmp3lame \
595         %{?with_libmysofa:--enable-libmysofa} \
596         --enable-libopencore-amrnb \
597         --enable-libopencore-amrwb \
598         %{?with_opencv:--enable-libopencv} \
599         %{?with_openh264:--enable-libopenh264} \
600         --enable-libopenjpeg \
601         %{?with_openmpt:--enable-libopenmpt} \
602         --enable-libopus \
603         %{?with_pulseaudio:--enable-libpulse} \
604         %{?with_librsvg:--enable-librsvg} \
605         --enable-librtmp \
606         %{?with_srt:--enable-libsrt} \
607         %{?with_libxml2:--enable-libxml2} \
608         %{?with_rubberband:--enable-librubberband} \
609         %{?with_shine:--enable-libshine} \
610         %{?with_smb:--enable-libsmbclient} \
611         %{?with_snappy:--enable-libsnappy} \
612         %{?with_soxr:--enable-libsoxr} \
613         --enable-libspeex \
614         %{?with_ssh:--enable-libssh} \
615         %{?with_tesseract:--enable-libtesseract} \
616         --enable-libtheora \
617         --enable-libtwolame \
618         --enable-libv4l2 \
619         %{?with_vidstab:--enable-libvidstab} \
620         %{?with_vmaf:--enable-libvmaf} \
621         --enable-libvo-amrwbenc \
622         --enable-libvorbis \
623         %{?with_vpx:--enable-libvpx} \
624         %{?with_wavpack:--enable-libwavpack} \
625         %{?with_webp:--enable-libwebp} \
626         %{?with_x264:--enable-libx264} \
627         %{?with_x265:--enable-libx265} \
628         --enable-libxavs \
629         %{?with_avs2:--enable-libxavs2} \
630         --enable-libxcb \
631         --enable-libxvid \
632         %{?with_zimg:--enable-libzimg} \
633         %{?with_zmq:--enable-libzmq} \
634         %{?with_zvbi:--enable-libzvbi} \
635         %{?with_lv2:--enable-lv2} \
636         %{?with_omx:--enable-omx} \
637         %{?with_openal:--enable-openal} \
638         %{?with_opencl:--enable-opencl} \
639         %{?with_opengl:--enable-opengl} \
640         %{?with_pocketsphinx:--enable-pocketsphinx} \
641         --enable-postproc \
642         --enable-pthreads \
643         %{?with_rkmpp:--enable-rkmpp} \
644         --enable-shared \
645         --enable-swscale \
646         %{!?with_va:--disable-vaapi} \
647         %{?with_vapoursynth:--enable-vapoursynth} \
648 %ifnarch %{ix86} %{x8664}
649         --disable-mmx \
650 %endif
651 %ifarch i386 i486
652         --disable-mmx \
653 %endif
654 %ifarch x32
655         --disable-asm \
656 %endif
657 %if %{with nonfree}
658         --enable-nonfree \
659         %{?with_fdk_aac:--enable-libfdk-aac} \
660         %{?with_npp:--enable-libnpp} \
661 %endif
662         --enable-runtime-cpudetect
663
664 %{__make} \
665         V=1
666
667 # CC_O to add -c to commandline. makefile should be patched
668 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
669
670 %{?with_tests:%{__make} check V=1}
671
672 %install
673 rm -rf $RPM_BUILD_ROOT
674 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
675         $RPM_BUILD_ROOT%{_includedir}/ffmpeg
676
677 %{__make} install install-headers \
678         DESTDIR=$RPM_BUILD_ROOT \
679         V=1
680
681 # install nonstandard, non-public headers manually
682 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
683 for a in libavutil/*/{asm,bswap}.h; do
684         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
685 done
686 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
687
688 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
689
690 # install as ffmpeg-avconfig to avoid with possible programs looking for
691 # ffmpeg-config and expecting --libs output from it which is not implemented
692 # simple to do (by querying pkgconfig), but why?
693 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
694
695 # packaged as %doc in -doc
696 %if %{with doc}
697 %{__rm} $RPM_BUILD_ROOT%{_docdir}/ffmpeg/*.html
698 %endif
699
700 install -d $RPM_BUILD_ROOT%{_examplesdir}
701 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ffmpeg/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
702
703 %clean
704 rm -rf $RPM_BUILD_ROOT
705
706 %post   libs -p /sbin/ldconfig
707 %postun libs -p /sbin/ldconfig
708
709 %files
710 %defattr(644,root,root,755)
711 %doc CREDITS LICENSE.md MAINTAINERS README.md RELEASE_NOTES doc/APIchanges
712 %attr(755,root,root) %{_bindir}/ffmpeg
713 %attr(755,root,root) %{_bindir}/ffprobe
714 %attr(755,root,root) %{_bindir}/qt-faststart
715 %dir %{_datadir}/ffmpeg
716 %{_datadir}/ffmpeg/*.ffpreset
717 %{_datadir}/ffmpeg/ffprobe.xsd
718 %if %{with doc}
719 %{_mandir}/man1/ffmpeg.1*
720 %{_mandir}/man1/ffmpeg-all.1*
721 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
722 %{_mandir}/man1/ffmpeg-codecs.1*
723 %{_mandir}/man1/ffmpeg-devices.1*
724 %{_mandir}/man1/ffmpeg-filters.1*
725 %{_mandir}/man1/ffmpeg-formats.1*
726 %{_mandir}/man1/ffmpeg-protocols.1*
727 %{_mandir}/man1/ffmpeg-resampler.1*
728 %{_mandir}/man1/ffmpeg-scaler.1*
729 %{_mandir}/man1/ffmpeg-utils.1*
730 %{_mandir}/man1/ffprobe.1*
731 %{_mandir}/man1/ffprobe-all.1*
732 %endif
733
734 %files libs
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.58
738 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.58
740 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.7
742 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.58
744 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.4
746 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
747 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.56
748 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.55
750 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
751 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.3
752 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
753 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.5
754
755 %files devel
756 %defattr(644,root,root,755)
757 %doc doc/optimization.txt
758 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
759 %attr(755,root,root) %{_libdir}/libavcodec.so
760 %attr(755,root,root) %{_libdir}/libavdevice.so
761 %attr(755,root,root) %{_libdir}/libavfilter.so
762 %attr(755,root,root) %{_libdir}/libavformat.so
763 %attr(755,root,root) %{_libdir}/libavresample.so
764 %attr(755,root,root) %{_libdir}/libavutil.so
765 %attr(755,root,root) %{_libdir}/libpostproc.so
766 %attr(755,root,root) %{_libdir}/libswresample.so
767 %attr(755,root,root) %{_libdir}/libswscale.so
768 %{_includedir}/ffmpeg
769 %{_includedir}/libavcodec
770 %{_includedir}/libavdevice
771 %{_includedir}/libavfilter
772 %{_includedir}/libavformat
773 %{_includedir}/libavresample
774 %{_includedir}/libavutil
775 %{_includedir}/libpostproc
776 %{_includedir}/libswresample
777 %{_includedir}/libswscale
778 %{_pkgconfigdir}/libavcodec.pc
779 %{_pkgconfigdir}/libavdevice.pc
780 %{_pkgconfigdir}/libavfilter.pc
781 %{_pkgconfigdir}/libavformat.pc
782 %{_pkgconfigdir}/libavresample.pc
783 %{_pkgconfigdir}/libavutil.pc
784 %{_pkgconfigdir}/libpostproc.pc
785 %{_pkgconfigdir}/libswresample.pc
786 %{_pkgconfigdir}/libswscale.pc
787 %if %{with doc}
788 %{_mandir}/man3/libavcodec.3*
789 %{_mandir}/man3/libavdevice.3*
790 %{_mandir}/man3/libavfilter.3*
791 %{_mandir}/man3/libavformat.3*
792 %{_mandir}/man3/libavutil.3*
793 %{_mandir}/man3/libswresample.3*
794 %{_mandir}/man3/libswscale.3*
795 %endif
796 %{_examplesdir}/%{name}-%{version}
797
798 %files static
799 %defattr(644,root,root,755)
800 %{_libdir}/libavcodec.a
801 %{_libdir}/libavdevice.a
802 %{_libdir}/libavfilter.a
803 %{_libdir}/libavformat.a
804 %{_libdir}/libavresample.a
805 %{_libdir}/libavutil.a
806 %{_libdir}/libpostproc.a
807 %{_libdir}/libswresample.a
808 %{_libdir}/libswscale.a
809
810 %files ffplay
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_bindir}/ffplay
813 %if %{with doc}
814 %{_mandir}/man1/ffplay.1*
815 %{_mandir}/man1/ffplay-all.1*
816 %endif
817
818 %if %{with doc}
819 %files doc
820 %defattr(644,root,root,755)
821 %doc doc/*.html
822 %endif
This page took 0.108633 seconds and 3 git commands to generate.