]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
- added webp and opengl support
[packages/ffmpeg.git] / ffmpeg.spec
1 #
2 # How to deal with ffmpeg/opencv checken-egg problem:
3 #       1. make-request -r --without opencv ffmpeg.spec
4 #       2. make-request -r opencv.spec
5 #       3. bump release of ffmpeg.spec
6 #       4. make-request -r ffmpeg.spec
7 #
8 # Conditional build:
9 %bcond_with     nonfree         # non free options of package (currently: faac)
10 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
11 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
12 %bcond_without  caca            # textual display using libcaca
13 %bcond_without  flite           # flite voice synthesis support
14 %bcond_without  frei0r          # frei0r video filtering
15 %bcond_without  gme             # Game Music Emu support
16 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
17 %bcond_without  ladspa          # LADSPA audio filtering
18 %bcond_without  ssh             # SFTP protocol support via libssh
19 %bcond_without  openal          # OpenAL 1.1 capture support
20 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, not available in Mesa yet]
21 %bcond_without  opengl          # OpenGL rendering support
22 %bcond_without  opencv          # OpenCV video filtering
23 %bcond_without  pulseaudio      # PulseAudio input support
24 %bcond_without  quvi            # quvi input support
25 %bcond_without  shine           # shine fixed-point MP3 encoder
26 %bcond_without  soxr            # SoX Resampler support
27 %bcond_without  x264            # H.264 x264 encoder
28 %bcond_with     x265            # HEVC x265 encoder
29 %bcond_without  utvideo         # Ut Video decoder
30 %bcond_without  va              # VAAPI (Video Acceleration API)
31 %bcond_without  vidstab         # vid.stab video stabilization support
32 %bcond_without  vpx             # VP8, a high-quality video codec
33 %bcond_without  wavpack         # wavpack encoding support
34 %bcond_without  webp            # WebP encoding support
35 %bcond_without  zmq             # 0MQ message passing
36 %bcond_without  zvbi            # teletext via libzvbi
37 %bcond_without  doc             # don't build docs
38
39 Summary:        FFmpeg - a very fast video and audio converter
40 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
41 Name:           ffmpeg
42 Version:        2.2
43 Release:        1
44 # LGPL or GPL, chosen at configure time (GPL version is more featured)
45 # (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
46 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
47 License:        GPL v3+ with LGPL v3+ parts
48 Group:          Applications/Multimedia
49 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
50 # Source0-md5:  744febca199548c9393b1f1ed05ccdd8
51 Source1:        ffserver.init
52 Source2:        ffserver.sysconfig
53 Source3:        ffserver.conf
54 Patch0:         %{name}-opencv24.patch
55 URL:            http://www.ffmpeg.org/
56 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
57 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
58 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
59 BuildRequires:  SDL-devel >= 1.2.1
60 BuildRequires:  alsa-lib-devel
61 BuildRequires:  bzip2-devel
62 BuildRequires:  celt-devel >= 0.11.0
63 %{?with_nonfree:BuildRequires:  faac-devel}
64 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
65 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  freetype-devel
68 %{?with_frei0r:BuildRequires:   frei0r-devel}
69 %{?with_gme:BuildRequires:      game-music-emu-devel}
70 %ifarch ppc
71 # require version with altivec support fixed
72 BuildRequires:  gcc >= 5:3.3.2-3
73 %endif
74 BuildRequires:  gnutls-devel
75 BuildRequires:  jack-audio-connection-kit-devel
76 %{?with_ladspa:BuildRequires:   ladspa-devel}
77 BuildRequires:  lame-libs-devel >= 3.98.3
78 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
79 BuildRequires:  libass-devel
80 BuildRequires:  libavc1394-devel
81 BuildRequires:  libbluray-devel
82 %{?with_caca:BuildRequires:     libcaca-devel}
83 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
84 BuildRequires:  libdc1394-devel >= 2
85 BuildRequires:  libgsm-devel
86 BuildRequires:  libiec61883-devel
87 BuildRequires:  libmodplug-devel
88 BuildRequires:  libnut-devel
89 %{?with_quvi:BuildRequires:     libquvi-devel}
90 BuildRequires:  libraw1394-devel >= 2
91 BuildRequires:  librtmp-devel
92 %{?with_ssh:BuildRequires:      libssh-devel}
93 BuildRequires:  libtheora-devel >= 1.0-0.beta3
94 BuildRequires:  libtool >= 2:1.4d-3
95 BuildRequires:  libv4l-devel
96 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
97 BuildRequires:  libvdpau-devel >= 0.2
98 BuildRequires:  libvorbis-devel
99 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
100 %{?with_webp:BuildRequires:     libwebp-devel}
101 # X264_BUILD >= 118
102 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
103 # X265_BUILD >= 7
104 %{?with_x265:BuildRequires:     libx265-devel}
105 %ifarch %{ix86}
106 %ifnarch i386 i486
107 BuildRequires:  nasm
108 %endif
109 %endif
110 BuildRequires:  opencore-amr-devel
111 %{?with_opencv:BuildRequires:   opencv-devel}
112 BuildRequires:  openjpeg-devel >= 1.5
113 BuildRequires:  opus-devel
114 BuildRequires:  perl-Encode
115 BuildRequires:  perl-tools-pod
116 BuildRequires:  pkgconfig
117 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
118 BuildRequires:  rpmbuild(macros) >= 1.470
119 BuildRequires:  schroedinger-devel
120 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
121 %{?with_soxr:BuildRequires:     soxr-devel}
122 BuildRequires:  speex-devel >= 1:1.2-rc1
123 %{?with_doc:BuildRequires:      tetex}
124 %{?with_doc:BuildRequires:      texi2html}
125 %{?with_doc:BuildRequires:      texinfo}
126 BuildRequires:  twolame-devel
127 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
128 %{?with_vidstab:BuildRequires:  vid.stab-devel >= 0.98}
129 BuildRequires:  vo-aacenc-devel
130 BuildRequires:  vo-amrwbenc-devel
131 %{?with_wavpack:BuildRequires:  wavpack-devel}
132 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
133 BuildRequires:  xavs-devel
134 BuildRequires:  xorg-lib-libX11-devel
135 BuildRequires:  xorg-lib-libXext-devel
136 BuildRequires:  xorg-lib-libXfixes-devel
137 BuildRequires:  xvid-devel >= 1:1.1.0
138 BuildRequires:  yasm
139 %{?with_zmq:BuildRequires:      zeromq-devel}
140 %{?with_zvbi:BuildRequires:     zvbi-devel}
141 BuildRequires:  zlib-devel
142 %{?with_autoreqdep:BuildConflicts:      libpostproc}
143 # overflows maximum hash table size
144 BuildConflicts: pdksh < 5.2.14-57
145 Requires:       %{name}-libs = %{version}-%{release}
146 %{?with_utvideo:Requires:       utvideo >= 12}
147 %{?with_ilbc:Requires:  webrtc-libilbc}
148 Requires:       xvid >= 1:1.1.0
149 Obsoletes:      libpostproc
150 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
151
152 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
153
154 %define         specflags       -fno-strict-aliasing
155
156 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
157 %define         specflags_ia32  -fomit-frame-pointer
158 # -mmmx is needed to enable <mmintrin.h> code.
159 %define         specflags_i586  -mmmx
160 %define         specflags_i686  -mmmx
161 %define         specflags_ppc   -fPIC
162
163 %description
164 FFmpeg is a complete solution to record, convert and stream audio and
165 video. It is a command line tool to convert one video file format to
166 another. It also supports grabbing and encoding in real time from a TV
167 card.
168
169 %description -l pl.UTF-8
170 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
171 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
172 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
173 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
174 telewizyjnej.
175
176 %package libs
177 Summary:        ffmpeg libraries
178 Summary(pl.UTF-8):      Biblioteki ffmpeg
179 %if "%(rpm -q --qf '%{V}' gnutls-devel)" >= "3.0.20"
180 # uses gnutls_certificate_set_x509_system_trust if >= 3.0.20
181 Requires:       gnutls-libs >= 3.0.20
182 %endif
183 Group:          Libraries
184
185 %description libs
186 This package contains the ffmpeg shared libraries:
187 - the codec library (libavcodec). It supports most existing encoding
188   formats (MPEG, DivX, MPEG4, AC3, DV...),
189 - demuxer library (libavformat). It supports most existing file
190   formats (AVI, MPEG, OGG, Matroska, ASF...),
191 - video postprocessing library (libpostproc).
192
193 %description libs -l pl.UTF-8
194 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
195 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
196   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
197 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
198   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
199 - bibliotekę postprocessingu (libpostproc).
200
201 %package devel
202 Summary:        ffmpeg header files
203 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
204 Group:          Development/Libraries
205 Requires:       %{name}-libs = %{version}-%{release}
206 # Libs.private from *.pc (unreasonably they are all the same)
207 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
208 Requires:       SDL-devel >= 1.2.1
209 Requires:       alsa-lib-devel
210 Requires:       bzip2-devel
211 Requires:       celt-devel >= 0.11.0
212 %{?with_nonfree:Requires:       faac-devel}
213 %{?with_fdk_aac:Requires:       fdk-aac-devel}
214 %{?with_flite:Requires: flite-devel >= 1.4}
215 Requires:       fontconfig-devel
216 Requires:       freetype-devel
217 %{?with_gme:Requires:   game-music-emu-devel}
218 Requires:       jack-audio-connection-kit-devel
219 Requires:       lame-libs-devel >= 3.98.3
220 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
221 Requires:       libass-devel
222 Requires:       libavc1394-devel
223 Requires:       libbluray-devel
224 %{?with_caca:Requires:  libcaca-devel}
225 Requires:       libcdio-paranoia-devel >= 0.90-2
226 Requires:       libdc1394-devel >= 2
227 Requires:       libgsm-devel
228 Requires:       libiec61883-devel
229 Requires:       libmodplug-devel
230 Requires:       libnut-devel
231 %{?with_quvi:Requires:  libquvi-devel}
232 Requires:       libraw1394-devel >= 2
233 Requires:       librtmp-devel
234 Requires:       libtheora-devel >= 1.0-0.beta3
235 %{?with_va:Requires:    libva-devel >= 1.0.3}
236 Requires:       libvorbis-devel
237 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
238 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
239 Requires:       opencore-amr-devel
240 %{?with_opencv:Requires:        opencv-devel}
241 Requires:       openjpeg-devel >= 1.5
242 Requires:       schroedinger-devel
243 %{?with_shine:Requires: shine-devel >= 3.0.0}
244 %{?with_soxr:Requires:  soxr-devel}
245 Requires:       speex-devel >= 1:1.2-rc1
246 Requires:       twolame-devel
247 %{?with_utvideo:Requires:       utvideo-devel >= 12}
248 %{?with_vidstab:Requires:       vid.stab-devel >= 0.98}
249 Requires:       vo-aacenc-devel
250 Requires:       vo-amrwbenc-devel
251 %{?with_wavpack:Requires:       wavpack-devel}
252 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
253 Requires:       xavs-devel
254 Requires:       xorg-lib-libXext-devel
255 Requires:       xorg-lib-libXfixes-devel
256 Requires:       xvid-devel >= 1:1.1.0
257 %{?with_zmq:Requires:   zeromq-devel}
258 Requires:       zlib-devel
259 Obsoletes:      libpostproc-devel
260
261 %description devel
262 ffmpeg header files.
263
264 %description devel -l pl.UTF-8
265 Pliki nagłówkowe ffmpeg.
266
267 %package static
268 Summary:        ffmpeg static libraries
269 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
270 Group:          Development/Libraries
271 Requires:       %{name}-devel = %{version}-%{release}
272
273 %description static
274 ffmpeg static libraries (libavcodec and libavformat).
275
276 %description static -l pl.UTF-8
277 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
278
279 %package ffplay
280 Summary:        FFplay - SDL-based media player
281 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
282 Group:          Applications/Multimedia
283 Requires:       %{name}-libs = %{version}-%{release}
284
285 %description ffplay
286 FFplay is a very simple and portable media player using the FFmpeg
287 libraries and the SDL library. It is mostly used as a test bench for
288 the various APIs of FFmpeg.
289
290 %description ffplay -l pl.UTF-8
291 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
292 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
293 testowania różnych API FFmpeg.
294
295 %package ffserver
296 Summary:        FFserver video server
297 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
298 Group:          Daemons
299 Requires(post,preun):   /sbin/chkconfig
300 Requires:       %{name}-libs = %{version}-%{release}
301 Requires:       rc-scripts >= 0.4.0.10
302
303 %description ffserver
304 FFserver is a streaming server for both audio and video. It supports
305 several live feeds, streaming from files and time shifting on live
306 feeds (you can seek to positions in the past on each live feed,
307 provided you specify a big enough feed storage in ffserver.conf).
308
309 %description ffserver -l pl.UTF-8
310 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
311 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
312 czasie dla źródeł na żywo (można przeskakiwać na położenia w
313 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
314 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
315
316 %package doc
317 Summary:        FFmpeg documentation in HTML format
318 Summary(pl.UTF-8):      Dokumentacja pakietu FFmpeg w formacie HTML
319 Group:          Documentation
320 %if "%{_rpmversion}" >= "5"
321 BuildArch:      noarch
322 %endif
323
324 %description doc
325 FFmpeg documentation in HTML format.
326
327 %description doc -l pl.UTF-8
328 Dokumentacja pakietu FFmpeg w formacie HTML.
329
330 %prep
331 %setup -q
332 %patch0 -p1
333
334 # package the grep result for mplayer, the result formatted as ./mplayer/configure
335 cat <<EOF > ffmpeg-avconfig
336 #! /bin/sh
337 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
338 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
339 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
340 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
341 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
342 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
343 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
344 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
345 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
346 EOF
347 cat <<'EOF' >> ffmpeg-avconfig
348
349 case "$1" in
350 --decoders)
351         echo $libavdecoders_all
352         ;;
353 --encoders)
354         echo $libavencoders_all
355         ;;
356 --parsers)
357         echo $libavparsers_all
358         ;;
359 --bsfs)
360         echo $libavbsfs_all
361         ;;
362 --demuxers)
363         echo $libavdemuxers_all
364         ;;
365 --muxers)
366         echo $libavmuxers_all
367         ;;
368 --protocols)
369         echo $libavprotocols_all
370         ;;
371 --hwaccels)
372         echo $libavhwaccels_all
373         ;;
374 --filters)
375         echo $libavfilters_all
376         ;;
377 *)
378         cat <<USAGE
379 Usage: $0 [OPTION]
380 Options:
381   --decoders
382   --encoders
383   --parsers
384   --bsfs
385   --demuxers
386   --muxers
387   --protocols
388   --hwaccels
389   --filters
390 USAGE
391         exit 1;;
392 esac
393
394 exit 0
395 EOF
396
397 %build
398 # notes:
399 # - it's not autoconf configure
400 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
401 ./configure \
402         --arch=%{_target_base_arch} \
403         --prefix=%{_prefix} \
404         --libdir=%{_libdir} \
405         --shlibdir=%{_libdir} \
406         --mandir=%{_mandir} \
407         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
408         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
409         --cc="%{__cc}" \
410         --disable-debug \
411         --disable-optimizations \
412         --disable-stripping \
413         --enable-avfilter \
414         --enable-avresample \
415         --enable-gnutls \
416         --enable-gpl \
417         --enable-version3 \
418         --enable-fontconfig \
419         %{?with_frei0r:--enable-frei0r} \
420         %{?with_ladspa:--enable-ladspa} \
421         %{?with_aacplus:--enable-libaacplus} \
422         --enable-libass \
423         --enable-libbluray \
424         %{?with_caca:--enable-libcaca} \
425         --enable-libcelt \
426         --enable-libcdio \
427         --enable-libdc1394 \
428         %{?with_fdk_aac:--enable-libfdk-aac} \
429         %{?with_flite:--enable-libflite} \
430         --enable-libfreetype \
431         %{?with_gme:--enable-libgme} \
432         --enable-libgsm \
433         --enable-libiec61883 \
434         %{?with_ilbc:--enable-libilbc} \
435         --enable-libmodplug \
436         --enable-libmp3lame \
437         --enable-libnut \
438         --enable-libopencore-amrnb \
439         --enable-libopencore-amrwb \
440         %{?with_opencv:--enable-libopencv} \
441         --enable-libopenjpeg \
442         --enable-libopus \
443         %{?with_pulseaudio:--enable-libpulse} \
444         %{?with_quvi:--enable-libquvi} \
445         --enable-librtmp \
446         --enable-libschroedinger \
447         %{?with_shine:--enable-libshine} \
448         %{?with_soxr:--enable-libsoxr} \
449         --enable-libspeex \
450         %{?with_ssh:--enable-libssh} \
451         --enable-libtheora \
452         --enable-libtwolame \
453         %{?with_utvideo:--enable-libutvideo} \
454         --enable-libv4l2 \
455         %{?with_vidstab:--enable-libvidstab} \
456         --enable-libvo-aacenc \
457         --enable-libvo-amrwbenc \
458         --enable-libvorbis \
459         %{?with_vpx:--enable-libvpx} \
460         %{?with_wavpack:--enable-libwavpack} \
461         %{?with_webp:--enable-libwebp} \
462         %{?with_x264:--enable-libx264} \
463         --enable-libxavs \
464         --enable-libxvid \
465         %{?with_zmq:--enable-libzmq} \
466         %{?with_zvbi:--enable-libzvbi} \
467         %{?with_openal:--enable-openal} \
468         %{?with_opencl:--enable-opencl} \
469         %{?with_opengl:--enable-opengl} \
470         --enable-postproc \
471         --enable-pthreads \
472         --enable-shared \
473         --enable-swscale \
474         %{!?with_va:--disable-vaapi} \
475         --enable-x11grab \
476 %ifnarch %{ix86} %{x8664}
477         --disable-mmx \
478 %endif
479 %ifarch i386 i486
480         --disable-mmx \
481 %endif
482 %if %{with nonfree}
483         --enable-nonfree \
484         --enable-libfaac \
485 %endif
486         --enable-runtime-cpudetect
487
488 %{__make} \
489         V=1
490
491 # CC_O to add -c to commandline. makefile should be patched
492 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
497         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
498         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
499
500 %{__make} install install-headers \
501         DESTDIR=$RPM_BUILD_ROOT \
502         V=1
503
504 # install nonstandard, non-public headers manually
505 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
506 for a in libavutil/*/bswap.h; do
507         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
508 done
509 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
510 # for lim-omx ffmpeg components
511 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
512
513 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
514 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
515 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
516 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
517 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
518
519 # install as ffmpeg-avconfig to avoid with possible programs looking for
520 # ffmpeg-config and expecting --libs output from it which is not implemented
521 # simple to do (by querying pkgconfig), but why?
522 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
523
524 %clean
525 rm -rf $RPM_BUILD_ROOT
526
527 %post   libs -p /sbin/ldconfig
528 %postun libs -p /sbin/ldconfig
529
530 %pre ffserver
531 %groupadd -g 167 ffserver
532 %useradd -g ffserver -u 167 ffserver
533
534 %post ffserver
535 /sbin/chkconfig --add ffserver
536 %service ffserver restart
537
538 %preun ffserver
539 if [ "$1" = 0 ]; then
540         %service ffserver stop
541         /sbin/chkconfig --del ffserver
542 fi
543
544 %postun ffserver
545 if [ "$1" = 0 ]; then
546         %userremove ffserver
547         %groupremove ffserver
548 fi
549
550 %files
551 %defattr(644,root,root,755)
552 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
553 %attr(755,root,root) %{_bindir}/ffmpeg
554 %attr(755,root,root) %{_bindir}/ffprobe
555 %attr(755,root,root) %{_bindir}/qt-faststart
556 %dir %{_datadir}/ffmpeg
557 %{_datadir}/ffmpeg/*.ffpreset
558 %{_datadir}/ffmpeg/ffprobe.xsd
559 %if %{with doc}
560 %{_mandir}/man1/ffmpeg.1*
561 %{_mandir}/man1/ffmpeg-all.1*
562 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
563 %{_mandir}/man1/ffmpeg-codecs.1*
564 %{_mandir}/man1/ffmpeg-devices.1*
565 %{_mandir}/man1/ffmpeg-filters.1*
566 %{_mandir}/man1/ffmpeg-formats.1*
567 %{_mandir}/man1/ffmpeg-protocols.1*
568 %{_mandir}/man1/ffmpeg-resampler.1*
569 %{_mandir}/man1/ffmpeg-scaler.1*
570 %{_mandir}/man1/ffmpeg-utils.1*
571 %{_mandir}/man1/ffprobe.1*
572 %{_mandir}/man1/ffprobe-all.1*
573 %endif
574
575 %files libs
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
579 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
580 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
581 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.4
583 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
584 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
585 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
586 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
587 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
588 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
589 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
590 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
591 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
592 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
593 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
594 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
595
596 %files devel
597 %defattr(644,root,root,755)
598 %doc doc/optimization.txt
599 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
600 %attr(755,root,root) %{_libdir}/libavcodec.so
601 %attr(755,root,root) %{_libdir}/libavdevice.so
602 %attr(755,root,root) %{_libdir}/libavfilter.so
603 %attr(755,root,root) %{_libdir}/libavformat.so
604 %attr(755,root,root) %{_libdir}/libavresample.so
605 %attr(755,root,root) %{_libdir}/libavutil.so
606 %attr(755,root,root) %{_libdir}/libpostproc.so
607 %attr(755,root,root) %{_libdir}/libswresample.so
608 %attr(755,root,root) %{_libdir}/libswscale.so
609 %{_includedir}/ffmpeg
610 %{_includedir}/libavcodec
611 %{_includedir}/libavdevice
612 %{_includedir}/libavfilter
613 %{_includedir}/libavformat
614 %{_includedir}/libavresample
615 %{_includedir}/libavutil
616 %{_includedir}/libpostproc
617 %{_includedir}/libswresample
618 %{_includedir}/libswscale
619 %{_pkgconfigdir}/libavcodec.pc
620 %{_pkgconfigdir}/libavdevice.pc
621 %{_pkgconfigdir}/libavfilter.pc
622 %{_pkgconfigdir}/libavformat.pc
623 %{_pkgconfigdir}/libavresample.pc
624 %{_pkgconfigdir}/libavutil.pc
625 %{_pkgconfigdir}/libpostproc.pc
626 %{_pkgconfigdir}/libswresample.pc
627 %{_pkgconfigdir}/libswscale.pc
628 %if %{with doc}
629 %{_mandir}/man3/libavcodec.3*
630 %{_mandir}/man3/libavdevice.3*
631 %{_mandir}/man3/libavfilter.3*
632 %{_mandir}/man3/libavformat.3*
633 %{_mandir}/man3/libavutil.3*
634 %{_mandir}/man3/libswresample.3*
635 %{_mandir}/man3/libswscale.3*
636 %endif
637
638 %files static
639 %defattr(644,root,root,755)
640 %{_libdir}/libavcodec.a
641 %{_libdir}/libavdevice.a
642 %{_libdir}/libavfilter.a
643 %{_libdir}/libavformat.a
644 %{_libdir}/libavresample.a
645 %{_libdir}/libavutil.a
646 %{_libdir}/libpostproc.a
647 %{_libdir}/libswresample.a
648 %{_libdir}/libswscale.a
649
650 %files ffplay
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_bindir}/ffplay
653 %if %{with doc}
654 %{_mandir}/man1/ffplay.1*
655 %{_mandir}/man1/ffplay-all.1*
656 %endif
657
658 %files ffserver
659 %defattr(644,root,root,755)
660 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
661 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
662 %attr(755,root,root) %{_sbindir}/ffserver
663 %attr(754,root,root) /etc/rc.d/init.d/ffserver
664 %if %{with doc}
665 %{_mandir}/man1/ffserver.1*
666 %{_mandir}/man1/ffserver-all.1*
667 %endif
668 %dir %attr(770,root,ffserver) /var/cache/ffserver
669 %dir %attr(770,root,ffserver) /var/log/ffserver
670
671 %if %{with doc}
672 %files doc
673 %defattr(644,root,root,755)
674 %doc doc/*.html
675 %endif
This page took 0.119969 seconds and 3 git commands to generate.