]> git.pld-linux.org Git - packages/ffcall.git/blame - ffcall.spec
- updated to 1.13 release
[packages/ffcall.git] / ffcall.spec
CommitLineData
cac2c25e 1Summary: Libraries for building foreign function call interfaces
8445a4fb 2Summary(pl.UTF-8): Biblioteki do tworzenia interfejsów wywołań obcych funkcji
cac2c25e 3Name: ffcall
db689769
JB
4Version: 1.13
5Release: 1
cac2c25e 6Epoch: 1
db689769 7License: GPL v2+
cac2c25e 8Group: Libraries
db689769
JB
9Source0: http://ftp.gnu.org/gnu/libffcall/libffcall-%{version}.tar.gz
10# Source0-md5: cb3051a80726b5e7b9031c4038a56afc
264bd3ff 11Patch0: %{name}-make-jN.patch
561c751d 12URL: http://savannah.gnu.org/projects/libffcall
cac2c25e
JB
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
69522ab0 15%undefine __cxx
16
cac2c25e
JB
17%description
18This is a collection of four libraries which can be used to build
19foreign function call interfaces in embedded interpreters.
20
21The four packages are:
22- avcall - calling C functions with variable arguments
23- vacall - C functions accepting variable argument prototypes
24- trampoline - closures as first-class C functions
25- callback - closures with variable arguments as first-class C
26 functions (a reentrant combination of vacall and trampoline)
27
28This version B includes some minor configuration changes so that files
29are installed in the proper place. Also it compiles on cygwin and
30mingw32.
31
304739ce
JR
32%description -l pl.UTF-8
33To jest zestaw czterech bibliotek, których można użyć do tworzenia
34interfejsów wywołań obcych procedur we wbudowanych interpreterach.
cac2c25e
JB
35
36Te cztery pakiety to:
304739ce
JR
37- avcall - wywoływanie funkcji w C ze zmiennymi argumentami
38- vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
39- trampoline - domknięcia jako funkcje C pierwszej klasy
40- callback - domknięcia ze zmiennymi argumentami jako funkcje C
41 pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
42
43Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
44pliki instalują się we właściwych miejscach. A także kompiluje się pod
cac2c25e
JB
45cygwinem i mingw32.
46
47%package devel
48Summary: Development files for ffcall libraries
8445a4fb 49Summary(pl.UTF-8): Pliki dla programistów używających bibliotek ffcall
cac2c25e 50Group: Development/Libraries
87c4ec88 51Requires: %{name} = %{epoch}:%{version}-%{release}
cac2c25e
JB
52
53%description devel
54Development files for ffcall libraries: headers and static trampoline
55and vacall libraries.
56
304739ce
JR
57%description devel -l pl.UTF-8
58Pliki dla programistów używających bibliotek ffcall: nagłówki i
cac2c25e
JB
59statyczne biblioteki trampoline oraz vacall.
60
61%package static
62Summary: Static versions of avcall and callback libraries
8445a4fb 63Summary(pl.UTF-8): Statyczne wersje bibliotek avcall i callback
cac2c25e 64Group: Development/Libraries
87c4ec88 65Requires: %{name}-devel = %{epoch}:%{version}-%{release}
cac2c25e
JB
66
67%description static
68Static versions of avcall and callback libraries.
69
304739ce 70%description static -l pl.UTF-8
cac2c25e
JB
71Statyczne wersje bibliotek avcall i callback.
72
73%prep
db689769 74%setup -q -n libffcall-%{version}
264bd3ff 75%patch0 -p1
cac2c25e
JB
76
77%build
87c4ec88 78%configure \
cac2c25e
JB
79 --enable-shared
80
264bd3ff 81%{__make}
cac2c25e
JB
82
83%install
84rm -rf $RPM_BUILD_ROOT
db689769 85#install -d $RPM_BUILD_ROOT%{_mandir}
cac2c25e
JB
86
87%{__make} install \
88 DESTDIR=$RPM_BUILD_ROOT
89
f11a7762 90# don't need those since we have man pages
69522ab0 91%{__rm} $RPM_BUILD_ROOT%{_datadir}/html/*.html
f11a7762 92
cac2c25e 93%clean
2ccfaad5 94rm -rf $RPM_BUILD_ROOT
cac2c25e
JB
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(644,root,root,755)
d43a7efd 101%doc ChangeLog NEWS PLATFORMS README
bbb36a01 102%attr(755,root,root) %{_libdir}/libavcall.so.*.*.*
d43a7efd 103%attr(755,root,root) %ghost %{_libdir}/libavcall.so.0
bbb36a01 104%attr(755,root,root) %{_libdir}/libcallback.so.*.*.*
d43a7efd 105%attr(755,root,root) %ghost %{_libdir}/libcallback.so.0
db689769
JB
106%attr(755,root,root) %{_libdir}/libtrampoline.so.*.*.*
107%attr(755,root,root) %ghost %{_libdir}/libtrampoline.so.0
cac2c25e
JB
108
109%files devel
110%defattr(644,root,root,755)
87c4ec88 111%doc */*.html
bbb36a01 112%attr(755,root,root) %{_libdir}/libavcall.so
113%attr(755,root,root) %{_libdir}/libcallback.so
db689769 114%attr(755,root,root) %{_libdir}/libtrampoline.so
bbb36a01 115%{_libdir}/libavcall.la
116%{_libdir}/libcallback.la
db689769 117%{_libdir}/libtrampoline.la
cac2c25e 118%{_libdir}/libvacall.a
d43a7efd
JB
119%{_includedir}/avcall.h
120%{_includedir}/callback.h
121%{_includedir}/trampoline*.h
122%{_includedir}/vacall*.h
123%{_mandir}/man3/avcall.3*
124%{_mandir}/man3/callback.3*
125%{_mandir}/man3/trampoline*.3*
126%{_mandir}/man3/vacall.3*
cac2c25e
JB
127
128%files static
129%defattr(644,root,root,755)
130%{_libdir}/libavcall.a
131%{_libdir}/libcallback.a
db689769 132%{_libdir}/libtrampoline.a
This page took 0.087494 seconds and 4 git commands to generate.