]> git.pld-linux.org Git - packages/ffcall.git/blame - ffcall.spec
- x32 rebuild
[packages/ffcall.git] / ffcall.spec
CommitLineData
561c751d 1%define snap 20090629
0ddbb027 2%define rel 2
561c751d 3
cac2c25e 4Summary: Libraries for building foreign function call interfaces
8445a4fb 5Summary(pl.UTF-8): Biblioteki do tworzenia interfejsów wywołań obcych funkcji
cac2c25e 6Name: ffcall
561c751d 7Version: 1.11
67fbe573 8Release: 0.%{snap}.%{rel}
cac2c25e
JB
9Epoch: 1
10License: GPL
11Group: Libraries
561c751d 12# cvs -d:pserver:anonymous@cvs.sv.gnu.org:/sources/libffcall co .
13Source0: %{name}-%{snap}.tar.bz2
14# Source0-md5: a5190885da8e701a012bb282bfb3c51b
264bd3ff 15Patch0: %{name}-make-jN.patch
6bbe77a9 16Patch1: %{name}-sparcv9.patch
ab1059b7 17# https://savannah.gnu.org/bugs/index.php?22081
18Patch2: %{name}-sparc64.patch
561c751d 19URL: http://savannah.gnu.org/projects/libffcall
cac2c25e
JB
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
69522ab0 22%undefine __cxx
23
cac2c25e
JB
24%description
25This is a collection of four libraries which can be used to build
26foreign function call interfaces in embedded interpreters.
27
28The four packages are:
29- avcall - calling C functions with variable arguments
30- vacall - C functions accepting variable argument prototypes
31- trampoline - closures as first-class C functions
32- callback - closures with variable arguments as first-class C
33 functions (a reentrant combination of vacall and trampoline)
34
35This version B includes some minor configuration changes so that files
36are installed in the proper place. Also it compiles on cygwin and
37mingw32.
38
304739ce
JR
39%description -l pl.UTF-8
40To jest zestaw czterech bibliotek, których można użyć do tworzenia
41interfejsów wywołań obcych procedur we wbudowanych interpreterach.
cac2c25e
JB
42
43Te cztery pakiety to:
304739ce
JR
44- avcall - wywoływanie funkcji w C ze zmiennymi argumentami
45- vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
46- trampoline - domknięcia jako funkcje C pierwszej klasy
47- callback - domknięcia ze zmiennymi argumentami jako funkcje C
48 pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
49
50Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
51pliki instalują się we właściwych miejscach. A także kompiluje się pod
cac2c25e
JB
52cygwinem i mingw32.
53
54%package devel
55Summary: Development files for ffcall libraries
8445a4fb 56Summary(pl.UTF-8): Pliki dla programistów używających bibliotek ffcall
cac2c25e 57Group: Development/Libraries
87c4ec88 58Requires: %{name} = %{epoch}:%{version}-%{release}
cac2c25e
JB
59
60%description devel
61Development files for ffcall libraries: headers and static trampoline
62and vacall libraries.
63
304739ce
JR
64%description devel -l pl.UTF-8
65Pliki dla programistów używających bibliotek ffcall: nagłówki i
cac2c25e
JB
66statyczne biblioteki trampoline oraz vacall.
67
68%package static
69Summary: Static versions of avcall and callback libraries
8445a4fb 70Summary(pl.UTF-8): Statyczne wersje bibliotek avcall i callback
cac2c25e 71Group: Development/Libraries
87c4ec88 72Requires: %{name}-devel = %{epoch}:%{version}-%{release}
cac2c25e
JB
73
74%description static
75Static versions of avcall and callback libraries.
76
304739ce 77%description static -l pl.UTF-8
cac2c25e
JB
78Statyczne wersje bibliotek avcall i callback.
79
80%prep
561c751d 81%setup -q -n %{name}-%{snap}
264bd3ff 82%patch0 -p1
6bbe77a9 83%patch1 -p1
ab1059b7 84%patch2 -p0
cac2c25e
JB
85
86%build
87c4ec88 87%configure \
cac2c25e
JB
88 --enable-shared
89
264bd3ff 90%{__make}
cac2c25e
JB
91
92%install
93rm -rf $RPM_BUILD_ROOT
94install -d $RPM_BUILD_ROOT%{_mandir}
95
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
f11a7762 99# don't need those since we have man pages
69522ab0 100%{__rm} $RPM_BUILD_ROOT%{_datadir}/html/*.html
f11a7762 101
cac2c25e 102%clean
2ccfaad5 103rm -rf $RPM_BUILD_ROOT
cac2c25e
JB
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
d43a7efd 110%doc ChangeLog NEWS PLATFORMS README
bbb36a01 111%attr(755,root,root) %{_libdir}/libavcall.so.*.*.*
d43a7efd 112%attr(755,root,root) %ghost %{_libdir}/libavcall.so.0
bbb36a01 113%attr(755,root,root) %{_libdir}/libcallback.so.*.*.*
d43a7efd 114%attr(755,root,root) %ghost %{_libdir}/libcallback.so.0
cac2c25e
JB
115
116%files devel
117%defattr(644,root,root,755)
87c4ec88 118%doc */*.html
bbb36a01 119%attr(755,root,root) %{_libdir}/libavcall.so
120%attr(755,root,root) %{_libdir}/libcallback.so
121%{_libdir}/libavcall.la
122%{_libdir}/libcallback.la
cac2c25e
JB
123%{_libdir}/libtrampoline.a
124%{_libdir}/libvacall.a
d43a7efd
JB
125%{_includedir}/avcall.h
126%{_includedir}/callback.h
127%{_includedir}/trampoline*.h
128%{_includedir}/vacall*.h
129%{_mandir}/man3/avcall.3*
130%{_mandir}/man3/callback.3*
131%{_mandir}/man3/trampoline*.3*
132%{_mandir}/man3/vacall.3*
cac2c25e
JB
133
134%files static
135%defattr(644,root,root,755)
136%{_libdir}/libavcall.a
137%{_libdir}/libcallback.a
This page took 0.77074 seconds and 4 git commands to generate.