]> git.pld-linux.org Git - packages/fetch-crl.git/blob - fetch-crl.spec
- up to 3.0.7, previous fixes applied
[packages/fetch-crl.git] / fetch-crl.spec
1 # TODO
2 # - pldize initscript
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Downloads Certificate Revocation Lists
5 Name:           fetch-crl
6 Version:        3.0.7
7 Release:        1
8 License:        ASL 2.0
9 Group:          Applications/System
10 URL:            http://www.nikhef.nl/grid/gridwiki/index.php/FetchCRL3
11 Source0:        http://dist.eugridpma.info/distribution/util/fetch-crl3/%{name}-%{version}.tar.gz
12 # Source0-md5:  d15773dd28110214f7d5302f073e97c1
13 BuildRequires:  rpm-perlprov >= 4.1-13
14 Requires:       openssl
15 Obsoletes:      fetch-crl3
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This tool and associated cron entry ensure that Certificate Revocation
21 Lists (CRLs) are periodically retrieved from the web sites of the
22 respective Certification Authorities. It assumes that the installed CA
23 files follow the hash.crl_url convention.
24
25 %prep
26 %setup -q
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}.d,/etc/{cron.d,rc.d/init.d}}
31 %{__make} install \
32         PREFIX=$RPM_BUILD_ROOT%{_usr} \
33         ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
34         CACHE=$RPM_BUILD_ROOT%{_var}/cache
35
36 install -p fetch-crl-cron.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-cron
37 install -p fetch-crl-boot.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-boot
38 cp -p fetch-crl-cron.cron $RPM_BUILD_ROOT/etc/cron.d/%{name}
39
40 # Remove some files that have been duplicated as docs.
41 rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 /sbin/chkconfig --add %{name}-cron
48 /sbin/chkconfig --add %{name}-boot
49
50 %preun
51 if [ $1 = 0 ]; then
52         %service %{name}-cron stop
53         %service %{name}-boot stop
54         /sbin/chkconfig --del %{name}-cron
55         /sbin/chkconfig --del %{name}-boot
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES NOTICE README fetch-crl.cnf.example
61 %dir %{_sysconfdir}/%{name}.d
62 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
63 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
64 %attr(755,root,root) %{_sbindir}/%{name}
65 %attr(754,root,root) /etc/rc.d/init.d/fetch-crl-boot
66 %attr(754,root,root) /etc/rc.d/init.d/fetch-crl-cron
67 %{_mandir}/man8/%{name}.8*
68 %dir %{_var}/cache/%{name}
This page took 0.082982 seconds and 3 git commands to generate.