]> git.pld-linux.org Git - packages/festival.git/blob - festival.spec
af6637cd243bb9726c88560cffb77173a90d5270
[packages/festival.git] / festival.spec
1 # TODO: kill ELF binary from %{_datadir}, see files
2 Summary:        The Festival speech sythesis system
3 Summary(pl):    System syntezy mowy Festival
4 Name:           festival
5 Version:        1.4.4
6 %define         _snap   20030803
7 Release:        0.%{_snap}.2
8 License:        BSD-like (except for festival.el, which is on GPL)
9 Group:          Applications/Sound
10 #Source0:       http://www.cstr.ed.ac.uk/download/festival/%{version}/%{name}-%{version}-release.tar.gz
11 Source0:        http://www.festvox.org/packed/festival/latest/festival-%{version}-current%{_snap}.tar.gz
12 # Source0-md5:  ffaa7533b3f50791aabfbf1cee09ca85
13 Source1:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us1.tar.gz
14 # Source1-md5:  d0c3e727003e715a65daf01003101813
15 Source2:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us2.tar.gz
16 # Source2-md5:  fbcc8baacbff3aa2aaaf5a93701bb5e0
17 Source3:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us3.tar.gz
18 # Source3-md5:  06dbfe2edaab6ffa31deeaf522e0c33e
19 Source4:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_en1.tar.gz
20 # Source4-md5:  66e3bc07751d7e31826185649c5ada5a
21 Patch0:         %{name}-config.patch
22 Patch1:         %{name}-asterisk.patch
23 URL:            http://www.cstr.ed.ac.uk/projects/festival/
24 BuildRequires:  automake
25 BuildRequires:  speech_tools-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %ifarch alpha
29 %define         fostype alpha_Linux
30 %else
31 %define         fostype unknown_Linux
32 %endif
33
34 %description
35 Festival offers a general framework for building speech synthesis
36 systems as well as including examples of various modules. As a whole
37 it offers full text to speech through a number APIs: from shell level,
38 though a Scheme command interpreter, as a C++ library, from Java, and
39 an Emacs interface. Festival is multi-lingual, though English is the
40 most advanced.
41
42 %description -l pl
43 Festival jest platform± przeznaczon± do budowania systemów syntezy
44 mowy oraz do ³atwego testowania ró¿nych modu³ów sk³adaj±cych siê na
45 syntezator mowy. Mo¿na te¿ u¿ywaæ programu jako maszynki czytaj±cej
46 pliki tekstowe. Festival jest wielojêzyczny, lecz jêzyk angielski jest
47 najbardziej zaawansowany.
48
49 %package devel
50 Summary:        Festival developement enviroment
51 Summary(pl):    Festival - ¶rodowidko rozwojowe
52 Group:          Applications/Sound
53
54 %description devel
55 Festival developement enviroment.
56
57 %description devel -l pl
58 Festival - ¶rodowisko rozwojowe.
59
60 %package voices-english-mbrola-us
61 Summary:        Festival's files for voices us1, us2, us3
62 Summary(pl):    Pliki Festival do g³osów us1, us2, us3
63 Group:          Applications/Sound
64 Requires:       mbrola
65
66 %description voices-english-mbrola-us
67 Files needed to use us1, us2, us3 voices from mbrola packages.
68
69 %description voices-english-mbrola-us -l pl
70 Pliki potrzebne do u¿ycia g³osów us1, us2, us3 z pakietu mbrola.
71
72 %package voices-english-mbrola-en
73 Summary:        Festival's files for voice en1
74 Summary(pl):    Pliki Festival do g³osu en1
75 Group:          Applications/Sound
76 Requires:       mbrola
77
78 %description voices-english-mbrola-en
79 Files needed to use en1 voice from mbrola packages.
80
81 %description voices-english-mbrola-en -l pl
82 Pliki potrzebne do u¿ycia g³osu en1 z pakietu mbrola.
83
84 %prep
85 %setup -q -n %{name} -b1 -b2 -b3 -b4
86 %patch0 -p1
87 %patch1 -p1
88
89 %build
90 cp -f /usr/share/automake/config.* .
91 %{__perl} -pi -e 's,^EST=.*,EST=%{_libdir}/speech_tools,' config/config.in
92 %configure2_13
93 %{__make} \
94         CC="%{__cc}" \
95         CXX="%{__cxx}" \
96         ECHO_N='printf "%%s"' \
97         OPTIMISE_CCFLAGS="%{rpmcflags}" \
98         OPTIMISE_CXXFLAGS="%{rpmcflags}" \
99         OPTIMISE_LINK="%{rpmldflags}" \
100         REQUIRED_LIBDEPS= 
101 # REQUIRED_LIBDPES is workaround not to need static speech_tools libraries
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/lib/{voices/english,dicts},%{_libdir},%{_includedir}/%{name},%{_mandir}/man1}
106
107 # bin
108 install bin/festival_server* bin/text2wave $RPM_BUILD_ROOT%{_bindir}
109 install src/main/festival{,_client} $RPM_BUILD_ROOT%{_bindir}
110
111 # devel
112 install src/lib/libFestival.a $RPM_BUILD_ROOT%{_libdir}
113 install src/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
114
115 # data
116 cp -r lib config examples $RPM_BUILD_ROOT%{_datadir}/%{name}
117 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name Makefile -exec rm \{\} \;
118
119 install doc/festival{,_client}.1 $RPM_BUILD_ROOT%{_mandir}/man1
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc ACKNOWLEDGMENTS COPYING NEWS README
127 %{_mandir}/man1/*
128 %attr(755,root,root) %{_bindir}/*
129 %dir %{_datadir}/%{name}
130 %dir %{_datadir}/%{name}/lib
131 %dir %{_datadir}/%{name}/lib/dicts
132 %dir %{_datadir}/%{name}/lib/voices
133 %dir %{_datadir}/%{name}/lib/voices/english
134 %dir %{_datadir}/%{name}/lib/etc
135 %dir %{_datadir}/%{name}/lib/etc/%{fostype}
136 # XXX: ELF binary, fix it!
137 %attr(755,root,root) %{_datadir}/%{name}/lib/etc/%{fostype}/audsp
138 %{_datadir}/%{name}/lib/etc/email_filter
139 %{_datadir}/%{name}/lib/*.scm
140 %{_datadir}/%{name}/lib/Sable.v0_2.dtd
141 %{_datadir}/%{name}/lib/festival.el
142 %{_datadir}/%{name}/lib/sable-latin.ent
143 %{_datadir}/%{name}/lib/scfg_wsj_wp20.gram
144 %{_datadir}/%{name}/lib/sec.*.ngrambin
145 %{_datadir}/%{name}/lib/speech.properties
146 %{_datadir}/%{name}/examples
147
148 %files devel
149 %defattr(644,root,root,755)
150 %{_includedir}/%{name}
151 %{_libdir}/libFestival.a
152 %{_datadir}/%{name}/config
153
154 # no mbrola on amd64
155 %ifarch %{ix86} ppc alpha sparc
156 %files voices-english-mbrola-us
157 %defattr(644,root,root,755)
158 %{_datadir}/%{name}/lib/voices/english/us1_mbrola
159 %{_datadir}/%{name}/lib/voices/english/us2_mbrola
160 %{_datadir}/%{name}/lib/voices/english/us3_mbrola
161
162 %files voices-english-mbrola-en
163 %defattr(644,root,root,755)
164 %{_datadir}/%{name}/lib/voices/english/en1_mbrola
165 %endif
This page took 0.04354 seconds and 2 git commands to generate.