]> git.pld-linux.org Git - packages/festival.git/blob - festival.spec
8cbc61ab24ea11fc21ad3ba450af3a5d20ebf35d
[packages/festival.git] / festival.spec
1 Summary:        The Festival speech sythesis system
2 Summary(pl):    System syntezy mowy Festival
3 Name:           festival
4 Version:        1.4.2
5 Release:        4
6 License:        GPL
7 Group:          Applications/Sound
8 Source0:        http://www.cstr.ed.ac.uk/download/festival/%{version}/%{name}-%{version}-release.tar.gz
9 Source1:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us1.tar.gz
10 Source2:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us2.tar.gz
11 Source3:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us3.tar.gz
12 Source4:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_en1.tar.gz
13 Patch0:         %{name}-config.patch
14 URL:            http://www.cstr.ed.ac.uk/projects/festival/
15 BuildRequires:  automake
16 BuildRequires:  speech_tools-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %ifarch alpha
20 %define         fostype alpha_Linux
21 %else
22 %define         fostype unknown_Linux
23 %endif
24
25 %description
26 Festival offers a general framework for building speech synthesis
27 systems as well as including examples of various modules. As a whole
28 it offers full text to speech through a number APIs: from shell level,
29 though a Scheme command interpreter, as a C++ library, from Java, and
30 an Emacs interface. Festival is multi-lingual, though English is the
31 most advanced.
32
33 %description -l pl
34 Festival jest platform± przeznaczon± do budowania systemów syntezy
35 mowy oraz do ³atwego testowania ró¿nych modu³ów sk³adaj±cych siê na
36 syntezator mowy. Mo¿na te¿ u¿ywaæ programu jako maszynki czytaj±cej
37 pliki tekstowe. Festival jest wielojêzyczny, lecz jêzyk angielski jest
38 najbardziej zaawansowany.
39
40 %package devel
41 Summary:        Festival developement enviroment
42 Summary(pl):    Festival - ¶rodowidko rozwojowe
43 Group:          Applications/Sound
44
45 %description devel
46 Festival developement enviroment.
47
48 %description devel -l pl
49 Festival - ¶rodowisko rozwojowe.
50
51 %package voices-english-mbrola-us
52 Summary:        Festival's files for voices us1, us2, us3
53 Summary(pl):    Pliki Festival do g³osów us1, us2, us3
54 Group:          Applications/Sound
55 Requires:       mbrola
56
57 %description voices-english-mbrola-us
58 Files needed to use us1, us2, us3 voices from mbrola packages.
59
60 %description voices-english-mbrola-us -l pl
61 Pliki potrzebne do u¿ycia g³osów us1, us2, us3 z pakietu mbrola.
62
63 %package voices-english-mbrola-en
64 Summary:        Festival's files for voice en1
65 Summary(pl):    Pliki Festival do g³osu en1
66 Group:          Applications/Sound
67 Requires:       mbrola
68
69 %description voices-english-mbrola-en
70 Files needed to use en1 voice from mbrola packages.
71
72 %description voices-english-mbrola-en -l pl
73 Pliki potrzebne do u¿ycia g³osu en1 z pakietu mbrola.
74
75 %prep
76 %setup -q -n %{name} -b1 -b2 -b3 -b4
77 %patch0 -p1
78
79 %build
80 cp -f /usr/share/automake/config.* .
81 %configure2_13
82 %{__make} \
83         CC="%{__cc}" \
84         CXX="%{__cxx}" \
85         OPTIMISE_CCFLAGS="%{rpmcflags}" \
86         OPTIMISE_CXXFLAGS="%{rpmcflags}" \
87         OPTIMISE_LINK="%{rpmldflags}" \
88         REQUIRED_LIBDEPS=
89 # REQUIRED_LIBDPES is workaround not to need static speech_tools libraries
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/lib/{voices/english,dicts},%{_libdir},%{_includedir}/%{name},%{_mandir}/man1}
94
95 # bin
96 install bin/festival_server* bin/text2wave $RPM_BUILD_ROOT%{_bindir}
97 install src/main/festival{,_client} $RPM_BUILD_ROOT%{_bindir}
98
99 # devel
100 install src/lib/libFestival.a $RPM_BUILD_ROOT%{_libdir}
101 install src/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
102
103 # data
104 cp -r lib config examples $RPM_BUILD_ROOT%{_datadir}/%{name}
105 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name Makefile -exec rm \{\} \;
106
107 install doc/festival{,_client}.1 $RPM_BUILD_ROOT%{_mandir}/man1
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc ACKNOWLEDGMENTS COPYING NEWS README
115 %{_mandir}/man1/*
116 %attr(755,root,root) %{_bindir}/*
117 %dir %{_datadir}/%{name}
118 %dir %{_datadir}/%{name}/lib
119 %dir %{_datadir}/%{name}/lib/dicts
120 %dir %{_datadir}/%{name}/lib/voices
121 %dir %{_datadir}/%{name}/lib/voices/english
122 %dir %{_datadir}/%{name}/lib/etc
123 %dir %{_datadir}/%{name}/lib/etc/%{fostype}
124 %attr(755,root,root) %{_datadir}/%{name}/lib/etc/%{fostype}/audsp
125 %{_datadir}/%{name}/lib/etc/email_filter
126 %{_datadir}/%{name}/lib/*.scm
127 %{_datadir}/%{name}/lib/Sable.v0_2.dtd
128 %{_datadir}/%{name}/lib/festival.el
129 %{_datadir}/%{name}/lib/sable-latin.ent
130 %{_datadir}/%{name}/lib/scfg_wsj_wp20.gram
131 %{_datadir}/%{name}/lib/sec.*.ngrambin
132 %{_datadir}/%{name}/lib/speech.properties
133 %{_datadir}/%{name}/examples
134
135 %files devel
136 %defattr(644,root,root,755)
137 %{_includedir}/%{name}
138 %{_libdir}/*
139 %{_datadir}/%{name}/config
140
141 %files voices-english-mbrola-us
142 %defattr(644,root,root,755)
143 %{_datadir}/%{name}/lib/voices/english/us1_mbrola
144 %{_datadir}/%{name}/lib/voices/english/us2_mbrola
145 %{_datadir}/%{name}/lib/voices/english/us3_mbrola
146
147 %files voices-english-mbrola-en
148 %defattr(644,root,root,755)
149 %{_datadir}/%{name}/lib/voices/english/en1_mbrola
This page took 0.051291 seconds and 2 git commands to generate.