]> git.pld-linux.org Git - packages/festival.git/blob - festival.spec
4448dcc73c5e3db57b79b2aeda70642730feeb86
[packages/festival.git] / festival.spec
1 Summary:        The Festival speech sythesis system
2 Summary(pl):    System syntezy mowy Festival
3 Name:           festival
4 Version:        1.4.2
5 Release:        5
6 License:        GPL
7 Group:          Applications/Sound
8 Source0:        http://www.cstr.ed.ac.uk/download/festival/%{version}/%{name}-%{version}-release.tar.gz
9 # Source0-md5:  4a46160fdda29188e0c4ee51b41c5695
10 Source1:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us1.tar.gz
11 # Source1-md5:  d0c3e727003e715a65daf01003101813
12 Source2:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us2.tar.gz
13 # Source2-md5:  fbcc8baacbff3aa2aaaf5a93701bb5e0
14 Source3:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_us3.tar.gz
15 # Source3-md5:  06dbfe2edaab6ffa31deeaf522e0c33e
16 Source4:        http://www.cstr.ed.ac.uk/download/festival/%{version}/festvox_en1.tar.gz
17 # Source4-md5:  66e3bc07751d7e31826185649c5ada5a
18 Patch0:         %{name}-config.patch
19 Patch1:         %{name}-asterisk.patch
20 URL:            http://www.cstr.ed.ac.uk/projects/festival/
21 BuildRequires:  automake
22 BuildRequires:  speech_tools-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %ifarch alpha
26 %define         fostype alpha_Linux
27 %else
28 %define         fostype unknown_Linux
29 %endif
30
31 %description
32 Festival offers a general framework for building speech synthesis
33 systems as well as including examples of various modules. As a whole
34 it offers full text to speech through a number APIs: from shell level,
35 though a Scheme command interpreter, as a C++ library, from Java, and
36 an Emacs interface. Festival is multi-lingual, though English is the
37 most advanced.
38
39 %description -l pl
40 Festival jest platform± przeznaczon± do budowania systemów syntezy
41 mowy oraz do ³atwego testowania ró¿nych modu³ów sk³adaj±cych siê na
42 syntezator mowy. Mo¿na te¿ u¿ywaæ programu jako maszynki czytaj±cej
43 pliki tekstowe. Festival jest wielojêzyczny, lecz jêzyk angielski jest
44 najbardziej zaawansowany.
45
46 %package devel
47 Summary:        Festival developement enviroment
48 Summary(pl):    Festival - ¶rodowidko rozwojowe
49 Group:          Applications/Sound
50
51 %description devel
52 Festival developement enviroment.
53
54 %description devel -l pl
55 Festival - ¶rodowisko rozwojowe.
56
57 %package voices-english-mbrola-us
58 Summary:        Festival's files for voices us1, us2, us3
59 Summary(pl):    Pliki Festival do g³osów us1, us2, us3
60 Group:          Applications/Sound
61 Requires:       mbrola
62
63 %description voices-english-mbrola-us
64 Files needed to use us1, us2, us3 voices from mbrola packages.
65
66 %description voices-english-mbrola-us -l pl
67 Pliki potrzebne do u¿ycia g³osów us1, us2, us3 z pakietu mbrola.
68
69 %package voices-english-mbrola-en
70 Summary:        Festival's files for voice en1
71 Summary(pl):    Pliki Festival do g³osu en1
72 Group:          Applications/Sound
73 Requires:       mbrola
74
75 %description voices-english-mbrola-en
76 Files needed to use en1 voice from mbrola packages.
77
78 %description voices-english-mbrola-en -l pl
79 Pliki potrzebne do u¿ycia g³osu en1 z pakietu mbrola.
80
81 %prep
82 %setup -q -n %{name} -b1 -b2 -b3 -b4
83 %patch0 -p1
84 %patch1 -p1
85 %build
86 cp -f /usr/share/automake/config.* .
87 %configure2_13
88 %{__make} \
89         CC="%{__cc}" \
90         CXX="%{__cxx}" \
91         OPTIMISE_CCFLAGS="%{rpmcflags}" \
92         OPTIMISE_CXXFLAGS="%{rpmcflags}" \
93         OPTIMISE_LINK="%{rpmldflags}" \
94         REQUIRED_LIBDEPS=
95 # REQUIRED_LIBDPES is workaround not to need static speech_tools libraries
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/lib/{voices/english,dicts},%{_libdir},%{_includedir}/%{name},%{_mandir}/man1}
100
101 # bin
102 install bin/festival_server* bin/text2wave $RPM_BUILD_ROOT%{_bindir}
103 install src/main/festival{,_client} $RPM_BUILD_ROOT%{_bindir}
104
105 # devel
106 install src/lib/libFestival.a $RPM_BUILD_ROOT%{_libdir}
107 install src/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
108
109 # data
110 cp -r lib config examples $RPM_BUILD_ROOT%{_datadir}/%{name}
111 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name Makefile -exec rm \{\} \;
112
113 install doc/festival{,_client}.1 $RPM_BUILD_ROOT%{_mandir}/man1
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc ACKNOWLEDGMENTS COPYING NEWS README
121 %{_mandir}/man1/*
122 %attr(755,root,root) %{_bindir}/*
123 %dir %{_datadir}/%{name}
124 %dir %{_datadir}/%{name}/lib
125 %dir %{_datadir}/%{name}/lib/dicts
126 %dir %{_datadir}/%{name}/lib/voices
127 %dir %{_datadir}/%{name}/lib/voices/english
128 %dir %{_datadir}/%{name}/lib/etc
129 %dir %{_datadir}/%{name}/lib/etc/%{fostype}
130 %attr(755,root,root) %{_datadir}/%{name}/lib/etc/%{fostype}/audsp
131 %{_datadir}/%{name}/lib/etc/email_filter
132 %{_datadir}/%{name}/lib/*.scm
133 %{_datadir}/%{name}/lib/Sable.v0_2.dtd
134 %{_datadir}/%{name}/lib/festival.el
135 %{_datadir}/%{name}/lib/sable-latin.ent
136 %{_datadir}/%{name}/lib/scfg_wsj_wp20.gram
137 %{_datadir}/%{name}/lib/sec.*.ngrambin
138 %{_datadir}/%{name}/lib/speech.properties
139 %{_datadir}/%{name}/examples
140
141 %files devel
142 %defattr(644,root,root,755)
143 %{_includedir}/%{name}
144 %{_libdir}/*
145 %{_datadir}/%{name}/config
146
147 %files voices-english-mbrola-us
148 %defattr(644,root,root,755)
149 %{_datadir}/%{name}/lib/voices/english/us1_mbrola
150 %{_datadir}/%{name}/lib/voices/english/us2_mbrola
151 %{_datadir}/%{name}/lib/voices/english/us3_mbrola
152
153 %files voices-english-mbrola-en
154 %defattr(644,root,root,755)
155 %{_datadir}/%{name}/lib/voices/english/en1_mbrola
This page took 0.077868 seconds and 2 git commands to generate.