]> git.pld-linux.org Git - packages/fence.git/blob - fence.spec
- up to 1.02.00
[packages/fence.git] / fence.spec
1 Summary:        I/O fencing system
2 Summary(pl):    System barier I/O
3 Name:           fence
4 Version:        1.02.00
5 Release:        1
6 Epoch:          1
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
10 # Source0-md5:  131c34c8b66d8d7d74384839ed4091d0
11 URL:            http://sources.redhat.com/cluster/fence/
12 BuildRequires:  cman-devel
13 BuildRequires:  perl-base
14 BuildRequires:  rpm-pythonprov
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sbindir        /sbin
18
19 %description
20 The Fence system does I/O fencing of cluster members. Any member may
21 join the default fence domain after which it will be fenced if it
22 fails without leaving the fence domain cleanly. The lock_dlm GFS lock
23 module will not permit GFS to be mounted until the node has joined a
24 fence domain.
25
26 The fence daemon, fenced, is usually started by running "fence_tool
27 join". Once started, fenced joins the default fence domain and the
28 node is subject to being fenced if it fails. A collection of fence
29 agents are used by fenced to interface with hardware devices (usually
30 to shut off its path to shared storage or cycle its power source.)
31
32 %description -l pl
33 System Fence odpowiada za bariery I/O dla cz³onków klastra. Ka¿dy z
34 cz³onków mo¿e do³±czyæ do domy¶lnej domeny barier, po czym bêdzie
35 odgrodzony je¶li zawiedzie nie opuszczaj±c czysto domeny barier. Modu³
36 blokuj±cy GFS-a lock_dlm nie pozwoli na podmontowanie GFS-a dopóki
37 wêze³ nie do³±czy do domeny barier.
38
39 Demon fence, fenced, jest zwykle uruchamiany przez fence_tool join. Po
40 uruchomieniu fenced do³±cza do domy¶lnej domeny barier, a wêze³ jest
41 przedmiotem odgrodzenia je¶li zawiedzie. fenced wykorzystuje zbiór
42 agentów fence do komunikacji z urz±dzeniami sprzêtowymi (zwykle do
43 odcinania drogi do dzielonej pamiêci lub wy³±czania i w³±czania
44 zasilania).
45
46 %prep
47 %setup -q -n cluster-%{version}
48 cd %{name}
49
50 %{__perl} -pi -e 's/-Wall/%{rpmcflags} -Wall/' make/defines.mk.input
51 %{__perl} -pi -e 's/-O2 //' fence_node/Makefile fence_tool/Makefile fenced/Makefile
52
53 %build
54 cd %{name}
55 ./configure \
56         --incdir=%{_includedir} \
57         --libdir=%{_libdir} \
58         --mandir=%{_mandir} \
59         --prefix=%{_prefix} \
60         --sbindir=%{_sbindir}
61 %{__make} \
62         CC="%{__cc}"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 cd %{name}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_sbindir}/*
77 #%attr(754,root,root) /etc/rc.d/init.d/fenced
78 %{_mandir}/man?/*
This page took 0.06136 seconds and 4 git commands to generate.