]> git.pld-linux.org Git - packages/fence.git/blob - fence.spec
- updated to 1.26, use optflags
[packages/fence.git] / fence.spec
1 Summary:        I/O fencing system
2 Summary(pl):    System barier I/O
3 Name:           fence
4 Version:        1.26
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        http://people.redhat.com/cfeist/cluster/tgz/%{name}-%{version}.tar.gz
9 # Source0-md5:  aee9109313966a88d007e944f991c1e6
10 URL:            http://sources.redhat.com/cluster/fence/
11 BuildRequires:  cman-devel
12 BuildRequires:  perl-base
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _sbindir        /sbin
16
17 %description
18 The Fence system does I/O fencing of cluster members. Any member may
19 join the default fence domain after which it will be fenced if it
20 fails without leaving the fence domain cleanly. The lock_dlm GFS lock
21 module will not permit GFS to be mounted until the node has joined a
22 fence domain. 
23
24 The fence daemon, fenced, is usually started by running "fence_tool
25 join". Once started, fenced joins the default fence domain and the
26 node is subject to being fenced if it fails. A collection of fence
27 agents are used by fenced to interface with hardware devices (usually
28 to shut off its path to shared storage or cycle its power source.)
29
30 %description -l pl
31 System Fence odpowiada za bariery I/O dla cz³onków klastra. Ka¿dy z
32 cz³onków mo¿e do³±czyæ do domy¶lnej domeny barier, po czym bêdzie
33 odgrodzony je¶li zawiedzie nie opuszczaj±c czysto domeny barier.
34 Modu³ blokuj±cy GFS-a lock_dlm nie pozwoli na podmontowanie GFS-a
35 dopóki wêze³ nie do³±czy do domeny barier.
36
37 Demon fence, fenced, jest zwykle uruchamiany przez fence_tool join. Po
38 uruchomieniu fenced do³±cza do domy¶lnej domeny barier, a wêze³ jest
39 przedmiotem odgrodzenia je¶li zawiedzie. fenced wykorzystuje zbiór
40 agentów fence do komunikacji z urz±dzeniami sprzêtowymi (zwykle do
41 odcinania drogi do dzielonej pamiêci lub wy³±czania i w³±czania
42 zasilania).
43
44 %prep
45 %setup -q
46
47 %{__perl} -pi -e 's/-Wall/%{rpmcflags} -Wall/' make/defines.mk.input
48 %{__perl} -pi -e 's/-O2 //' fence_node/Makefile fence_tool/Makefile fenced/Makefile
49
50 %build
51 ./configure \
52         --incdir=%{_includedir} \
53         --libdir=%{_libdir} \
54         --mandir=%{_mandir} \
55         --prefix=%{_prefix} \
56         --sbindir=%{_sbindir}
57 %{__make} \
58         CC="%{__cc}"
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_sbindir}/*
72 #%attr(754,root,root) /etc/rc.d/init.d/fenced
73 %{_mandir}/man?/*
This page took 0.134809 seconds and 3 git commands to generate.