]> git.pld-linux.org Git - packages/femfind.git/blob - femfind.spec
- release 2: updated for perl-5.8, BR: rpm-perlprov, minor cleanup
[packages/femfind.git] / femfind.spec
1 #
2 # TODO:
3 # - include apache configuration to config
4 # - pre/post play
5 # - logrotate file
6 # - fix ownership of the perl_vendorlib/FemFind directory
7 #
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        FemFind - crawl your network resources
10 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
11 Name:           FemFind
12 Version:        0.74
13 Release:        2
14 License:        GPL v2
15 Group:          Networking/Utilities
16 Source0:        http://www.codefactory.de/downloads/%{name}-%{version}.tar.gz
17 Patch0:         %{name}-config.patch
18 URL:            http://femfind.sourceforge.net/
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _wwwsite        /home/services/httpd/html/FemFind
23 %define         _cgisite        /home/services/httpd/cgi-bin/femfind
24
25 %description
26 FemFind is a crawler for SMB shares which can be found on Windows or
27 Unix systems running Samba. Additionally FemFind crawls FTP servers
28 and provides a web interface and a Windows client as frontends.
29
30 %description -l pl
31 FemFind jest programem przeszukuj±cym zasoby sieci udostêpnione
32 poprzez protokó³ SMB na maszynach Windowsowych lub Uniksowych z
33 dzia³aj±c± Samb±. Dodatkowo FemFind przeszukuje serwery FTP, dostarcza
34 interfejs webowy oraz klienta Windowsowego jako frontend.
35
36 %package -n perl-FemFind-ConfigReader
37 Summary:        FemFind - crawl your network resources
38 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
39 Group:          Development/Languages/Perl
40
41 %description -n perl-FemFind-ConfigReader
42 FemFind::ConfigReader perl module for FemFind.
43
44 %description -n perl-FemFind-ConfigReader -l pl
45 Perlowy modu³ FemFind::ConfigReader dla FemFinda.
46
47 %package -n perl-FemFind-Helper
48 Summary:        FemFind - crawl your network resources
49 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
50 Group:          Development/Languages/Perl
51
52 %description -n perl-FemFind-Helper
53 FemFind::Helper perl module for FemFind.
54
55 %description -n perl-FemFind-Helper -l pl
56 Perlowy modu³ FemFind::Helper dla FemFinda.
57
58 %package -n FemFind-cgi
59 Summary:        FemFind - crawl your network resources
60 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
61 Group:          Networking/Utilities
62
63 %description -n FemFind-cgi
64 CGI scripts for FemFind frontend.
65
66 %description -n FemFind-cgi -l pl
67 Skrypty CGI do frontendu FemFinda.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 cd modules
75 cd ConfigReader
76 %{__perl} Makefile.PL \
77         INSTALLDIRS=vendor
78 %{__make}
79 cd ..
80 cd Helper
81 %{__perl} Makefile.PL \
82         INSTALLDIRS=vendor
83 %{__make}
84 cd ..
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{_bindir},%{_sbindir}}
89 install -d $RPM_BUILD_ROOT{%{_wwwsite},%{_cgisite}/german,/var/{lib/femfind,log}}
90
91 %{__make} install \
92         -C modules/ConfigReader \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %{__make} install \
96         -C modules/Helper \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install femfind.conf    $RPM_BUILD_ROOT%{_sysconfdir}
100 install makedb.pl       $RPM_BUILD_ROOT%{_sbindir}
101 install crawler.pl      $RPM_BUILD_ROOT%{_bindir}
102 install german/*        $RPM_BUILD_ROOT%{_cgisite}/german
103 install cgi-bin/femfind/*       $RPM_BUILD_ROOT%{_cgisite}
104 install htdocs/femfind/*        $RPM_BUILD_ROOT%{_wwwsite}
105
106 touch $RPM_BUILD_ROOT/var/log/femfind.log
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 echo "Remember to init database running %{_sbindir}/makedb.pl"
113
114 %files
115 %defattr(644,root,root,755)
116 %doc README
117 %dir /var/lib/femfind
118 %ghost /var/log/femfind.log
119 %attr(644,root,root) %config(noreplace) %{_sysconfdir}/femfind.conf
120 %attr(755,root,root) %{_sbindir}/makedb.pl
121 %attr(755,root,root) %{_bindir}/crawler.pl
122
123 %files -n perl-FemFind-ConfigReader
124 %defattr(644,root,root,755)
125 # ??? see Helper
126 %{perl_vendorlib}/FemFind/*.pm
127 %{_mandir}/man3/FemFind::ConfigReader.*
128
129 %files -n perl-FemFind-Helper
130 %defattr(644,root,root,755)
131 # ??? see ConfigReader
132 %{perl_vendorlib}/FemFind/*.pm
133 %{_mandir}/man3/FemFind::Helper.*
134
135 %files -n FemFind-cgi
136 %defattr(644,root,root,755)
137 %dir %{_cgisite}
138 %dir %{_wwwsite}
139 %dir %{_cgisite}/german
140 %attr(755,root,root) %{_cgisite}/german/*.pl
141 %{_cgisite}/german/*.html
142 %attr(755,root,root) %{_cgisite}/*.pl
143 %{_cgisite}/*.html
144 %{_cgisite}/ftp_list
145 %{_wwwsite}/*
This page took 0.070163 seconds and 3 git commands to generate.