]> git.pld-linux.org Git - packages/femfind.git/blob - femfind.spec
- fix improper usage of %%{_sysconfdir}
[packages/femfind.git] / femfind.spec
1 # TODO:
2 # - include apache configuration to config
3 # - pre/post play
4 # - logrotate file
5
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        FemFind - crawl your network resources
8 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
9 Name:           FemFind
10 Version:        0.74
11 Release:        1
12 License:        GPL v2
13 Group:          Networking/Utilities
14 Source0:        http://www.codefactory.de/downloads/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-config.patch
16 URL:            http://femfind.sourceforge.net/
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _wwwsite        /home/httpd/html/FemFind
20 %define         _cgisite        /home/httpd/cgi-bin/femfind
21
22 %description
23 FemFind is a crawler for SMB shares which can be found on Windows or
24 Unix systems running Samba. Additionally FemFind crawls FTP servers
25 and provides a web interface and a Windows client as frontends.
26
27 %description -l pl
28 FemFind jest programem przeszukuj±cym zasoby sieci udostêpnione
29 poprzez protokó³ SMB na maszynach Windowsowych lub Uniksowych z
30 dzia³aj±c± Samb±. Dodatkowo FemFind przeszukuje serwery FTP, dostarcza
31 interfejs webowy oraz klienta Windowsowego jako frontend.
32
33 %package -n perl-FemFind-ConfigReader
34 Summary:        FemFind - crawl your network resources
35 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
36 Group:          Development/Languages/Perl
37
38 %description -n perl-FemFind-ConfigReader
39 FemFind::ConfigReader perl module for FemFind.
40
41 %description -n perl-FemFind-ConfigReader -l pl
42 Perlowy modu³ FemFind::ConfigReader dla FemFinda.
43
44 %package -n perl-FemFind-Helper
45 Summary:        FemFind - crawl your network resources
46 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
47 Group:          Development/Languages/Perl
48
49 %description -n perl-FemFind-Helper
50 FemFind::Helper perl module for FemFind.
51
52 %description -n perl-FemFind-Helper -l pl
53 Perlowy modu³ FemFind::Helper dla FemFinda.
54
55 %package -n FemFind-cgi
56 Summary:        FemFind - crawl your network resources
57 Summary(pl):    FemFind - przeszukiwanie zasobów sieciowych
58 Group:          Networking/Utilities
59
60 %description -n FemFind-cgi
61 CGI scripts for FemFind frontend.
62
63 %description -n FemFind-cgi -l pl
64 Skrypty CGI do frontendu FemFinda.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 cd modules
72 cd ConfigReader
73         perl Makefile.PL
74         %{__make}
75 cd ..
76 cd Helper
77         perl Makefile.PL
78         %{__make}
79 cd ..
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{_bindir},%{_sbindir}}
84 install -d $RPM_BUILD_ROOT{%{_wwwsite},%{_cgisite}/german,/var/{lib/femfind,log}}
85
86 for i in Helper ConfigReader; do
87         cd modules/$i
88         %{__make} install DESTDIR=$RPM_BUILD_ROOT
89         cd ../../
90 done
91
92 install femfind.conf    $RPM_BUILD_ROOT%{_sysconfdir}
93 install makedb.pl       $RPM_BUILD_ROOT%{_sbindir}
94 install crawler.pl      $RPM_BUILD_ROOT%{_bindir}
95 install german/*        $RPM_BUILD_ROOT%{_cgisite}/german
96 install cgi-bin/femfind/*       $RPM_BUILD_ROOT%{_cgisite}
97 install htdocs/femfind/*        $RPM_BUILD_ROOT%{_wwwsite}
98
99 touch $RPM_BUILD_ROOT/var/log/femfind.log
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 echo "Remember to init database running %{_sbindir}/makedb.pl"
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README
110 %dir /var/lib/femfind
111 %ghost /var/log/femfind.log
112 %attr(644,root,root) %config(noreplace) %{_sysconfdir}/femfind.conf
113 %attr(755,root,root) %{_sbindir}/makedb.pl
114 %attr(755,root,root) %{_bindir}/crawler.pl
115
116 %files -n perl-FemFind-ConfigReader
117 %defattr(644,root,root,755)
118 %{perl_sitelib}/FemFind/*.pm
119
120 %files -n perl-FemFind-Helper
121 %defattr(644,root,root,755)
122 %{perl_sitelib}/FemFind/*.pm
123 %{_mandir}/man3/FemFind::Helper.3pm.gz
124
125 %files -n FemFind-cgi
126 %defattr(644,root,root,755)
127 %dir %{_cgisite}
128 %dir %{_wwwsite}
129 %attr(755,root,root) %{_cgisite}/german/*.pl
130 %attr(644,root,root) %{_cgisite}/german/*.html
131 %attr(755,root,root) %{_cgisite}/*.pl
132 %attr(644,root,root) %{_cgisite}/*.html
133 %attr(644,root,root) %{_cgisite}/ftp_list
134 %attr(644,root,root) %{_wwwsite}/*
This page took 0.1176 seconds and 3 git commands to generate.