]> git.pld-linux.org Git - packages/femfind.git/blob - femfind.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/femfind.git] / femfind.spec
1 #
2 # TODO:
3 # - webapps
4 # - include apache configuration to config
5 # - pre/post play
6 # - logrotate file
7 # - fix ownership of the perl_vendorlib/FemFind directory
8 #
9 Summary:        FemFind - crawl your network resources
10 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
11 Name:           FemFind
12 Version:        0.74
13 Release:        2
14 License:        GPL v2
15 Group:          Networking/Utilities
16 Source0:        http://www.codefactory.de/downloads/%{name}-%{version}.tar.gz
17 # Source0-md5:  57de716507fb23ddb4fed17cd77cd038
18 Patch0:         %{name}-config.patch
19 URL:            http://femfind.sourceforge.net/
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _wwwsite        /home/services/httpd/html/FemFind
24 %define         _cgisite        /home/services/httpd/cgi-bin/femfind
25
26 %description
27 FemFind is a crawler for SMB shares which can be found on Windows or
28 Unix systems running Samba. Additionally FemFind crawls FTP servers
29 and provides a web interface and a Windows client as frontends.
30
31 %description -l pl.UTF-8
32 FemFind jest programem przeszukującym zasoby sieci udostępnione
33 poprzez protokół SMB na maszynach windowsowych lub uniksowych z
34 działającą Sambą. Dodatkowo FemFind przeszukuje serwery FTP, dostarcza
35 interfejs WWW oraz klienta windowsowego jako frontend.
36
37 %package -n perl-FemFind-ConfigReader
38 Summary:        FemFind - crawl your network resources
39 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
40 Group:          Development/Languages/Perl
41
42 %description -n perl-FemFind-ConfigReader
43 FemFind::ConfigReader perl module for FemFind.
44
45 %description -n perl-FemFind-ConfigReader -l pl.UTF-8
46 Perlowy moduł FemFind::ConfigReader dla FemFinda.
47
48 %package -n perl-FemFind-Helper
49 Summary:        FemFind - crawl your network resources
50 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
51 Group:          Development/Languages/Perl
52
53 %description -n perl-FemFind-Helper
54 FemFind::Helper perl module for FemFind.
55
56 %description -n perl-FemFind-Helper -l pl.UTF-8
57 Perlowy moduł FemFind::Helper dla FemFinda.
58
59 %package -n FemFind-cgi
60 Summary:        FemFind - crawl your network resources
61 Summary(pl.UTF-8):      FemFind - przeszukiwanie zasobów sieciowych
62 Group:          Networking/Utilities
63
64 %description -n FemFind-cgi
65 CGI scripts for FemFind frontend.
66
67 %description -n FemFind-cgi -l pl.UTF-8
68 Skrypty CGI do frontendu FemFinda.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 cd modules
76 cd ConfigReader
77 %{__perl} Makefile.PL \
78         INSTALLDIRS=vendor
79 %{__make}
80 cd ..
81 cd Helper
82 %{__perl} Makefile.PL \
83         INSTALLDIRS=vendor
84 %{__make}
85 cd ..
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{_bindir},%{_sbindir}}
90 install -d $RPM_BUILD_ROOT{%{_wwwsite},%{_cgisite}/german,/var/{lib/femfind,log}}
91
92 %{__make} install \
93         -C modules/ConfigReader \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %{__make} install \
97         -C modules/Helper \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install femfind.conf    $RPM_BUILD_ROOT%{_sysconfdir}
101 install makedb.pl       $RPM_BUILD_ROOT%{_sbindir}
102 install crawler.pl      $RPM_BUILD_ROOT%{_bindir}
103 install german/*        $RPM_BUILD_ROOT%{_cgisite}/german
104 install cgi-bin/femfind/*       $RPM_BUILD_ROOT%{_cgisite}
105 install htdocs/femfind/*        $RPM_BUILD_ROOT%{_wwwsite}
106
107 touch $RPM_BUILD_ROOT/var/log/femfind.log
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 echo "Remember to init database running %{_sbindir}/makedb.pl"
114
115 %files
116 %defattr(644,root,root,755)
117 %doc README
118 %dir /var/lib/femfind
119 %ghost /var/log/femfind.log
120 %config(noreplace) %{_sysconfdir}/femfind.conf
121 %attr(755,root,root) %{_sbindir}/makedb.pl
122 %attr(755,root,root) %{_bindir}/crawler.pl
123
124 %files -n perl-FemFind-ConfigReader
125 %defattr(644,root,root,755)
126 # ??? see Helper
127 %{perl_vendorlib}/FemFind/*.pm
128 %{_mandir}/man3/FemFind::ConfigReader.*
129
130 %files -n perl-FemFind-Helper
131 %defattr(644,root,root,755)
132 # ??? see ConfigReader
133 %{perl_vendorlib}/FemFind/*.pm
134 %{_mandir}/man3/FemFind::Helper.*
135
136 %files -n FemFind-cgi
137 %defattr(644,root,root,755)
138 %dir %{_cgisite}
139 %dir %{_wwwsite}
140 %dir %{_cgisite}/german
141 %attr(755,root,root) %{_cgisite}/german/*.pl
142 %{_cgisite}/german/*.html
143 %attr(755,root,root) %{_cgisite}/*.pl
144 %{_cgisite}/*.html
145 %{_cgisite}/ftp_list
146 %{_wwwsite}/*
This page took 0.062683 seconds and 3 git commands to generate.