]> git.pld-linux.org Git - packages/fedmsg.git/blame - fedmsg.spec
up to 0.16.2
[packages/fedmsg.git] / fedmsg.spec
CommitLineData
700057e3 1#
5fff4a25
ER
2# TODO
3# - pldize initscripts
4# - add initscript post scriptlets
5# - --daemonize crashes (works under systemd only): https://github.com/fedora-infra/fedmsg/issues/302
6
700057e3
ER
7# Conditional build:
8%bcond_with tests # build with tests
9
10Summary: Tools for Fedora Infrastructure real-time messaging
11Name: fedmsg
76ff4d87 12Version: 0.16.2
5fff4a25 13Release: 1
700057e3
ER
14License: LGPL v2+
15Group: Applications/Networking
16Source0: http://pypi.python.org/packages/source/f/fedmsg/%{name}-%{version}.tar.gz
76ff4d87 17# Source0-md5: 43fc8257724252b38b34608b0c9a2218
700057e3 18Source1: %{name}-tmpfiles.conf
d803d01c 19Patch1: config.patch
5fff4a25 20URL: https://github.com/fedora-infra/fedmsg
700057e3 21BuildRequires: python-devel
700057e3 22BuildRequires: python-setuptools
de043d79 23BuildRequires: rpm-pythonprov
d5a32506 24BuildRequires: rpmbuild(macros) >= 1.219
700057e3
ER
25%if %{with tests}
26BuildRequires: python-mock
27BuildRequires: python-nose
28BuildRequires: python-six
29# Only for the test-replay test which is patched out
30BuildRequires: python-M2Crypto
31BuildRequires: python-arrow
32BuildRequires: python-bunch
33BuildRequires: python-daemon
34BuildRequires: python-fabulous
35BuildRequires: python-fedora
36BuildRequires: python-m2ext
37BuildRequires: python-moksha-hub >= 1.3.2
38BuildRequires: python-psutil
39BuildRequires: python-pygments
40BuildRequires: python-requests
41#BuidlRequires: python-sqlalchemy
42%endif
43Requires: python-M2Crypto
44Requires: python-arrow
45#Requires: python-daemon
46#Requires: python-fabulous
47#Requires: python-fedora
48Requires: python-kitchen
49Requires: python-m2ext
50Requires: python-moksha-hub >= 1.3.2
51Requires: python-psutil
52Requires: python-pygments
53Requires: python-requests
54#Requires: python-simplejson
55Requires: python-six
56Requires: python-zmq
57BuildArch: noarch
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60%description
61Python API used around Fedora Infrastructure to send and receive
62messages with zeromq. Includes some CLI tools.
63
64%package announce
65Summary: The fedmsg-announce command
66Group: Applications/Networking
67Requires: %{name} = %{version}-%{release}
68
69%description announce
70This package contains the fedmsg-announce command for sending
71announcements.
72
73%package collectd
74Summary: A fedmsg plugin for collectd
75Group: Applications/Networking
76Requires: %{name} = %{version}-%{release}
77
78%description collectd
79This package contains the fedmsg-collectd command which produces
80output suitable for consumption by a collectd plugin.
81
82%package hub
83Summary: The FedMsg Hub
84Group: Applications/Networking
85Requires: %{name} = %{version}-%{release}
86
87%description hub
88This package contains configuration and init scripts for the FedMsg
89hub.
90
91%package relay
92Summary: The FedMsg Relay
93Group: Applications/Networking
94Requires: %{name} = %{version}-%{release}
95
96%description relay
97This package contains configuration and init scripts for the FedMsg
98relay.
99
100%package irc
101Summary: The FedMsg IRC Bot
102Group: Applications/Networking
103Requires: %{name} = %{version}-%{release}
104
105%description irc
106This package contains configuration and init scripts for the FedMsg
107IRC bot.
108
109%package gateway
110Summary: The FedMsg Gateway daemon
111Group: Applications/Networking
112Requires: %{name} = %{version}-%{release}
113
114%description gateway
115This package contains configuration and init scripts for the FedMsg
116Gateway. It will rebroadcast messages from the bus to a specially
117designated ZMQ pub socket. Useful for repeating messages outside a
118firewall.
119
120%prep
121%setup -q
d803d01c 122%patch1 -p1
700057e3
ER
123
124# This only got shipped with fedmsg-0.6.3
125rm -f fedmsg.d/_tweet-real.py
126
127# These are failing in mock for fedora. Investigate why.
128# We probably just need a new BuildReq
129rm -f fedmsg/tests/test_replay.py
130rm -f fedmsg/tests/test_crypto_gpg.py
131
132# Also, sqlalchemy is required for those tests we're knocking out,
133# so knock it out too.
134sed -i "/'sqlalchemy.*$/d" setup.py
135
136# Temporarily disable signature validation while the timestamp precision bug is
137# worked out upstream. -- https://github.com/fedora-infra/fedmsg/pull/186
138sed -i "s/validate_signatures=True/validate_signatures=False/g" fedmsg.d/ssl.py
139
140# Copy the development config into the tests dir for the check section
141cp -rf fedmsg.d fedmsg/tests/
142
143%build
144%{__python} setup.py build
145
146# Create this temporary symlink that's only needed for the test suite.
147ln -s fedmsg/tests/test_certs dev_certs
148
149# Unfortunately, neither of these tests will run on koji since they require
150# some network connectivity. With a note of sadness, we destroy them.
151rm fedmsg/tests/test_hub.py
152rm fedmsg/tests/test_threads.py
153
154%if %{with tests}
155%check
156%if 0%{?rhel} && 0%{?rhel} <= 6
157# Check section removed until a RHEL6 bug with python-repoze-what-plugins-sql
158# can be fixed. It causes a fatal error in the test suite.
159# https://bugzilla.redhat.com/show_bug.cgi?id=813925
160%else
161PYTHONPATH=$(pwd) python setup.py test
162%endif
163%endif
164
165%install
166rm -rf $RPM_BUILD_ROOT
167%{__python} setup.py install \
168 --skip-build \
169 --optimize=2 \
170 --install-data=%{_datadir} \
171 --root $RPM_BUILD_ROOT
172
173%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/fedmsg/tests
174
d5a32506
ER
175%py_postclean
176
700057e3
ER
177install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,rc.d/init.d},%{_sysconfdir}/fedmsg.d,%{systemdtmpfilesdir},%{systemdunitdir},/var/{run,log}/fedmsg}
178cp -p fedmsg.d/*.py $RPM_BUILD_ROOT%{_sysconfdir}/fedmsg.d
179
180cp -p initsys/sysv/fedmsg-hub.init $RPM_BUILD_ROOT/etc/rc.d/init.d/fedmsg-hub
181cp -p initsys/sysv/fedmsg-relay.init $RPM_BUILD_ROOT/etc/rc.d/init.d/fedmsg-relay
182cp -p initsys/sysv/fedmsg-irc.init $RPM_BUILD_ROOT/etc/rc.d/init.d/fedmsg-irc
183cp -p initsys/sysv/fedmsg-gateway.init $RPM_BUILD_ROOT/etc/rc.d/init.d/fedmsg-gateway
184
185cp -p initsys/systemd/fedmsg-hub.service $RPM_BUILD_ROOT%{systemdunitdir}
186cp -p initsys/systemd/fedmsg-relay.service $RPM_BUILD_ROOT%{systemdunitdir}
187cp -p initsys/systemd/fedmsg-irc.service $RPM_BUILD_ROOT%{systemdunitdir}
188cp -p initsys/systemd/fedmsg-gateway.service $RPM_BUILD_ROOT%{systemdunitdir}
189
190# Logrotate configuration
191cp -p logrotate $RPM_BUILD_ROOT/etc/logrotate.d/fedmsg
192
193# tmpfiles.d
194cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
195
196%clean
197rm -rf $RPM_BUILD_ROOT
198
199%pre
200%groupadd -g 313 -r fedmsg
201%useradd -u 313 -r -s /sbin/nologin -d %{_datadir}/%{name} -M -c 'FedMsg' -g fedmsg fedmsg
202
203%preun hub
204if [ $1 -eq 0 ]; then
205 %service fedmsg-hub stop
206 /sbin/chkconfig --del fedmsg-hub
207fi
208
209%preun relay
210if [ $1 -eq 0 ]; then
211 %service fedmsg-relay stop
212 /sbin/chkconfig --del fedmsg-relay
213fi
214
215%preun irc
216if [ $1 -eq 0 ]; then
217 %service fedmsg-irc stop
218 /sbin/chkconfig --del fedmsg-irc
219fi
220
221%preun gateway
222if [ $1 -eq 0 ]; then
223 %service fedmsg-gateway stop
224 /sbin/chkconfig --del fedmsg-gateway
225fi
226
227%files
228%defattr(644,root,root,755)
229%doc doc/* README.rst LICENSE
230%dir %{_sysconfdir}/fedmsg.d
231%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fedmsg.d/base.py*
232%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fedmsg.d/endpoints.py*
233%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fedmsg.d/logging.py*
234%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fedmsg.d/ssl.py*
235%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/fedmsg
236%attr(755,root,root) %{_bindir}/fedmsg-logger
237%attr(755,root,root) %{_bindir}/fedmsg-tail
238%attr(755,root,root) %{_bindir}/fedmsg-trigger
239%attr(755,root,root) %{_bindir}/fedmsg-config
240%attr(755,root,root) %{_bindir}/fedmsg-dg-replay
241%attr(755,fedmsg,fedmsg) %dir /var/log/fedmsg
242%attr(775,fedmsg,fedmsg) %dir /var/run/fedmsg
243%dir %{py_sitescriptdir}/fedmsg
244%{py_sitescriptdir}/fedmsg/*.py[co]
245%{py_sitescriptdir}/fedmsg/commands
246%{py_sitescriptdir}/fedmsg/consumers
247%{py_sitescriptdir}/fedmsg/crypto
248%{py_sitescriptdir}/fedmsg/encoding
249%{py_sitescriptdir}/fedmsg/meta
250%{py_sitescriptdir}/fedmsg/replay
251%{py_sitescriptdir}/fedmsg/text
252%{py_sitescriptdir}/fedmsg-%{version}-py*.egg-info
253%{systemdtmpfilesdir}/%{name}.conf
254
255%files announce
256%defattr(644,root,root,755)
257%attr(755,root,root) %{_bindir}/fedmsg-announce
258
259%files collectd
260%defattr(644,root,root,755)
261%attr(755,root,root) %{_bindir}/fedmsg-collectd
262
263%files hub
264%defattr(644,root,root,755)
265%attr(755,root,root) %{_bindir}/fedmsg-hub
266%attr(754,root,root) /etc/rc.d/init.d/fedmsg-hub
267%{systemdunitdir}/fedmsg-hub.service
268
269%files relay
270%defattr(644,root,root,755)
271%attr(755,root,root) %{_bindir}/fedmsg-relay
272%attr(754,root,root) /etc/rc.d/init.d/fedmsg-relay
273%{systemdunitdir}/fedmsg-relay.service
274%config(noreplace) %{_sysconfdir}/fedmsg.d/relay.py*
275
276%files irc
277%defattr(644,root,root,755)
278%attr(755,root,root) %{_bindir}/fedmsg-irc
279%attr(754,root,root) /etc/rc.d/init.d/fedmsg-irc
280%{systemdunitdir}/fedmsg-irc.service
281
282%config(noreplace) %{_sysconfdir}/fedmsg.d/ircbot.py*
283
284%files gateway
285%defattr(644,root,root,755)
286%attr(755,root,root) %{_bindir}/fedmsg-gateway
287%attr(754,root,root) /etc/rc.d/init.d/fedmsg-gateway
288%{systemdunitdir}/fedmsg-gateway.service
289%config(noreplace) %{_sysconfdir}/fedmsg.d/gateway.py*
This page took 0.596672 seconds and 4 git commands to generate.