]> git.pld-linux.org Git - packages/fedmsg-notify.git/commitdiff
setup distro_specific/_pld
authorElan Ruusamäe <glen@delfi.ee>
Wed, 11 Nov 2015 20:01:35 +0000 (22:01 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 11 Nov 2015 20:01:35 +0000 (22:01 +0200)
_pld.py [new file with mode: 0644]
fedmsg-notify.spec

diff --git a/_pld.py b/_pld.py
new file mode 100644 (file)
index 0000000..6940bfd
--- /dev/null
+++ b/_pld.py
@@ -0,0 +1,22 @@
+# This file is a part of fedmsg-notify.
+#
+# Authors: Elan Ruusamäe <glen@pld-linux.org>
+
+import logging
+
+log = logging.getLogger('moksha.hub')
+
+def get_installed_packages():
+    """Retrieve the packages installed on the system"""
+    return []
+
+def get_user_packages(usernames):
+    """Retrieve the packages maintained by `usernames`"""
+    return []
+
+def get_reported_bugs():
+    """
+    Not implemented on PLD Linux, just return empty set
+    """
+
+    return set()
index f470742bc5e7afe8bad35f25df54d7b4eb43f08e..f574e86736bd0202aca7ed049cf57cdb140ca237 100644 (file)
@@ -1,11 +1,12 @@
 Summary:       Fedmsg Desktop Notifications
 Name:          fedmsg-notify
 Version:       0.5.5
 Summary:       Fedmsg Desktop Notifications
 Name:          fedmsg-notify
 Version:       0.5.5
-Release:       0.2
+Release:       0.3
 License:       GPL v3+
 Group:         X11/Applications/Networking
 Source0:       https://github.com/fedora-infra/fedmsg-notify/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: fc6fe17a2c385c99e0165df5b0a7560e
 License:       GPL v3+
 Group:         X11/Applications/Networking
 Source0:       https://github.com/fedora-infra/fedmsg-notify/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: fc6fe17a2c385c99e0165df5b0a7560e
+Source1:       _pld.py
 Patch0:                pld.patch
 URL:           https://github.com/fedora-infra/fedmsg-notify
 BuildRequires: desktop-file-utils
 Patch0:                pld.patch
 URL:           https://github.com/fedora-infra/fedmsg-notify
 BuildRequires: desktop-file-utils
@@ -35,7 +36,7 @@ to enable/disable the service.
 %patch0 -p1
 
 # install pld
 %patch0 -p1
 
 # install pld
-touch fedmsg_notify/distro_specific/_pld.py
+cp -p %{SOURCE1} fedmsg_notify/distro_specific
 # skip fedora and debian
 mv fedmsg_notify/distro_specific/_debian.py .
 mv fedmsg_notify/distro_specific/_fedora.py .
 # skip fedora and debian
 mv fedmsg_notify/distro_specific/_debian.py .
 mv fedmsg_notify/distro_specific/_fedora.py .
This page took 0.142394 seconds and 4 git commands to generate.