]> git.pld-linux.org Git - packages/feathercoin.git/commitdiff
patch adding some missing header includes
authorJan Palus <atler@pld-linux.org>
Tue, 21 Feb 2023 12:14:55 +0000 (13:14 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 21 Feb 2023 12:14:55 +0000 (13:14 +0100)
feathercoin.spec
missing-includes.patch [new file with mode: 0644]

index 2b2d562c947e23b6d381a0ee2034f40a02a32bfb..f338dfab5edb2b56be00ab6cae80e11a23ea47e8 100644 (file)
@@ -18,6 +18,7 @@ Patch0:               lib.patch
 Patch1:                qt-5.15.patch
 Patch2:                %{name}-includes.patch
 Patch3:                %{name}-univalue.patch
+Patch4:                missing-includes.patch
 URL:           https://www.feathercoin.com/
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5
@@ -112,6 +113,7 @@ Oparty na Qt portfel Feathercoin.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
diff --git a/missing-includes.patch b/missing-includes.patch
new file mode 100644 (file)
index 0000000..f8ab45d
--- /dev/null
@@ -0,0 +1,48 @@
+diff -ur Feathercoin-0.19.1.orig/src/bench/block_assemble.cpp Feathercoin-0.19.1/src/bench/block_assemble.cpp
+--- Feathercoin-0.19.1.orig/src/bench/block_assemble.cpp       2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/src/bench/block_assemble.cpp    2023-02-21 12:29:11.836557718 +0100
+@@ -10,6 +10,7 @@
+ #include <validation.h>
++#include <array>
+ #include <list>
+ #include <vector>
+diff -ur Feathercoin-0.19.1.orig/src/net_processing.cpp Feathercoin-0.19.1/src/net_processing.cpp
+--- Feathercoin-0.19.1.orig/src/net_processing.cpp     2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/src/net_processing.cpp  2023-02-21 12:27:04.349114113 +0100
+@@ -30,8 +30,20 @@
+ #include <util/strencodings.h>
+ #include <util/validation.h>
++#include <algorithm>
++#include <array>
++#include <atomic>
++#include <chrono>
++#include <deque>
++#include <iostream>
++#include <list>
++#include <map>
+ #include <memory>
++#include <set>
++#include <string>
+ #include <typeinfo>
++#include <utility>
++#include <vector>
+ #if defined(NDEBUG)
+ # error "Feathercoin cannot be compiled without assertions."
+diff -ur Feathercoin-0.19.1.orig/src/qt/sendcoinsdialog.cpp Feathercoin-0.19.1/src/qt/sendcoinsdialog.cpp
+--- Feathercoin-0.19.1.orig/src/qt/sendcoinsdialog.cpp 2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/src/qt/sendcoinsdialog.cpp      2023-02-21 12:28:52.529773392 +0100
+@@ -32,6 +32,9 @@
+ #include <QSettings>
+ #include <QTextDocument>
++#include <algorithm>
++#include <array>
++
+ static const std::array<int, 9> confTargets = { {2, 4, 6, 12, 24, 48, 144, 504, 1008} };
+ int getConfTargetForIndex(int index) {
+     if (index+1 > static_cast<int>(confTargets.size())) {
This page took 0.158264 seconds and 4 git commands to generate.