]> git.pld-linux.org Git - packages/feathercoin.git/commitdiff
- updated to 0.19.1 auto/th/feathercoin-0.19.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Sep 2020 19:05:26 +0000 (21:05 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Sep 2020 19:05:26 +0000 (21:05 +0200)
- updated includes patch
- added univalue patch (fix build with system libunivalue)
- requires newer libsecp256k1 now

feathercoin-includes.patch
feathercoin-univalue.patch [new file with mode: 0644]
feathercoin.spec
lib.patch

index f5e5005978e2b212fc2f0ce04a5c406df13a5f9e..351ae9bb3135d8488d107555a2f21339a9b92f58 100644 (file)
@@ -1,10 +1,10 @@
---- Feathercoin-0.18.3/src/httpserver.cpp.orig 2020-02-12 16:59:36.000000000 +0100
-+++ Feathercoin-0.18.3/src/httpserver.cpp      2020-08-01 08:15:43.332321225 +0200
-@@ -14,6 +14,7 @@
- #include <sync.h>
- #include <ui_interface.h>
+--- Feathercoin-0.19.1/src/util/translation.h.orig     2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/src/util/translation.h  2020-09-22 18:56:30.333268791 +0200
+@@ -7,6 +7,7 @@
  
-+#include <deque>
- #include <memory>
- #include <stdio.h>
- #include <stdlib.h>
+ #include <tinyformat.h>
++#include <functional>
+ #include <utility>
+ /**
diff --git a/feathercoin-univalue.patch b/feathercoin-univalue.patch
new file mode 100644 (file)
index 0000000..ec6e45b
--- /dev/null
@@ -0,0 +1,11 @@
+--- Feathercoin-0.19.1/src/rpc/blockchain.cpp.orig     2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/src/rpc/blockchain.cpp  2020-09-22 19:32:56.101427468 +0200
+@@ -2094,7 +2094,7 @@
+             // no scan in progress
+             return NullUniValue;
+         }
+-        result.pushKV("progress", g_scan_progress);
++        result.pushKV("progress", g_scan_progress.load());
+         return result;
+     } else if (request.params[0].get_str() == "abort") {
+         CoinsViewScanReserver reserver;
index e75b9e3b3939e07a18a5c531046d1631e63092e2..69afa6df32963390abe4ca0a5a39cc6efbf6b82d 100644 (file)
@@ -7,16 +7,17 @@
 Summary:       Feathercoin - a peer-to-peer currency
 Summary(pl.UTF-8):     Feathercoin - waluta peer-to-peer
 Name:          feathercoin
-Version:       0.18.3
-Release:       3
+Version:       0.19.1
+Release:       1
 License:       MIT
 Group:         Applications/Networking
 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
 Source0:       https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: e5e3fc683a09ec7c2efc21dda691c402
+# Source0-md5: 5af573e26b1fc7cb57ef5efc5dd88801
 Patch0:                lib.patch
 Patch1:                qt-5.15.patch
 Patch2:                %{name}-includes.patch
+Patch3:                %{name}-univalue.patch
 URL:           https://www.feathercoin.com/
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5
@@ -33,20 +34,23 @@ BuildRequires:      boost-devel >= 1.47.0
 %{?with_ccache:BuildRequires:  ccache}
 BuildRequires: db-cxx-devel >= 4.8
 BuildRequires: gettext-tools
+BuildRequires: libevent-devel
 %{?with_gui:BuildRequires:     libpng-devel}
-BuildRequires: libsecp256k1-devel
-BuildRequires: libstdc++-devel
+BuildRequires: libsecp256k1-devel >= 0.1.0.15
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: libtool >= 2:2
 BuildRequires: libunivalue-devel >= 1.0.4
 BuildRequires: miniupnpc-devel >= 1.5
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: protobuf-devel
+BuildRequires: python3 >= 1:3.5
 BuildRequires: qrencode-devel
 %{?with_gui:BuildRequires:     qt5-build >= 5}
 BuildRequires: zeromq-devel >= 4
 %{?with_gui:BuildRequires:     zlib-devel}
 BuildRequires: zxing-cpp-devel
+Requires:      libsecp256k1 >= 0.1.0.15
 Requires:      libunivalue >= 1.0.4
 Requires:      perl-base
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -107,6 +111,7 @@ Oparty na Qt portfel Feathercoin.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -116,8 +121,12 @@ Oparty na Qt portfel Feathercoin.
 %{__automake}
 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
 %configure \
+       --disable-bench \
+       --enable-bip70 \
        --enable-ccache%{!?with_ccache:=no} \
+       --disable-gui-tests \
        --disable-silent-rules \
+       --disable-tests \
        --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
        --with-incompatible-bdb \
        --with-system-univalue
index a693e010f3db51bfb039e012e9835ccd16f254a9..40836d339a22a5048022238f942675ceab084e66 100644 (file)
--- a/lib.patch
+++ b/lib.patch
@@ -1,25 +1,23 @@
---- Feathercoin-0.16.3/configure.ac~   2018-09-22 09:16:24.000000000 +0200
-+++ Feathercoin-0.16.3/configure.ac    2018-09-25 20:30:45.640038984 +0200
-@@ -1310,9 +1310,6 @@ if test x$need_bundled_univalue = xyes;
+--- Feathercoin-0.19.1/configure.ac.orig       2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/configure.ac    2020-09-21 22:22:56.190904468 +0200
+@@ -1252,6 +1252,7 @@
+       else
+           AC_DEFINE_UNQUOTED([ENABLE_ZMQ],[0],[Define to 1 to enable ZMQ functions])
+       fi
++      PKG_CHECK_MODULES([SECP256K1], [libsecp256k1],, [AC_MSG_ERROR(libsecp256k1 not found.)])
+     ]
+   )
+ else
+@@ -1655,9 +1656,6 @@
    AC_CONFIG_SUBDIRS([src/univalue])
  fi
  
--ac_configure_args="${ac_configure_args} --disable-shared --with-pic --with-bignum=no --enable-module-recovery --disable-jni"
+-ac_configure_args="${ac_configure_args} --disable-shared --with-pic --enable-benchmark=no --with-bignum=no --enable-module-recovery --disable-jni"
 -AC_CONFIG_SUBDIRS([src/secp256k1])
 -
  AC_OUTPUT
  
  dnl Taken from https://wiki.debian.org/RpathIssue
---- Feathercoin-0.16.3/configure.ac~   2018-09-25 20:31:22.000000000 +0200
-+++ Feathercoin-0.16.3/configure.ac    2018-09-25 20:34:53.278016850 +0200
-@@ -972,6 +972,7 @@ if test x$use_pkgconfig = xyes; then
-       else
-           AC_DEFINE_UNQUOTED([ENABLE_ZMQ],[0],[Define to 1 to enable ZMQ functions])
-       fi
-+      PKG_CHECK_MODULES([SECP256K1], [libsecp256k1],, [AC_MSG_ERROR(libsecp256k1 not found.)])
-     ]
-   )
- else
 --- Feathercoin-0.16.3/src/Makefile.am~        2018-09-22 09:16:24.000000000 +0200
 +++ Feathercoin-0.16.3/src/Makefile.am 2018-09-25 20:40:02.844966767 +0200
 @@ -2,7 +2,7 @@
This page took 0.23195 seconds and 4 git commands to generate.