]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
eeccde52d7771b5aea9ff6de44a1f6f10b3e8d3d
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.17.0.2
11 Release:        1
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  b5d463886272c5d5eef0abc71faed87d
17 Patch0:         lib.patch
18 URL:            https://www.feathercoin.com/
19 %if %{with gui}
20 BuildRequires:  Qt5Core-devel >= 5
21 BuildRequires:  Qt5DBus-devel >= 5
22 BuildRequires:  Qt5Gui-devel >= 5
23 BuildRequires:  Qt5Network-devel >= 5
24 BuildRequires:  Qt5PrintSupport-devel >= 5
25 BuildRequires:  Qt5Test-devel >= 5
26 BuildRequires:  Qt5Widgets-devel >= 5
27 %endif
28 BuildRequires:  autoconf >= 2.69
29 BuildRequires:  automake
30 BuildRequires:  boost-devel >= 1.47.0
31 %{?with_ccache:BuildRequires:   ccache}
32 BuildRequires:  db-cxx-devel >= 4.8
33 BuildRequires:  gettext-tools
34 %{?with_gui:BuildRequires:      libpng-devel}
35 BuildRequires:  libsecp256k1-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool >= 2:2
38 BuildRequires:  libunivalue-devel >= 1.0.4
39 BuildRequires:  miniupnpc-devel >= 1.5
40 BuildRequires:  openssl-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  protobuf-devel
43 BuildRequires:  qrencode-devel
44 %{?with_gui:BuildRequires:      qt5-build >= 5}
45 BuildRequires:  zeromq-devel >= 4
46 %{?with_gui:BuildRequires:      zlib-devel}
47 BuildRequires:  zxing-cpp-devel
48 Requires:       libunivalue >= 1.0.4
49 Requires:       perl-base
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 # uses nNeoScryptOptions symbol from binaries
53 %define         skip_post_check_so      libbitcoinconsensus.so.*
54
55 %description
56 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
57 central authority issues new money or tracks transactions. These tasks
58 are managed collectively by the network.
59
60 %description -l pl.UTF-8
61 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
62 centralnego urzędu, który emituje nowe pieniądze czy śledzi
63 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
64
65 %package devel
66 Summary:        Header file for bitcoinconsensus library
67 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bitcoinconsensus
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       openssl-devel
71 Conflicts:      bitcoin-devel
72
73 %description devel
74 Header file for bitcoinconsensus library.
75
76 %description devel -l pl.UTF-8
77 Plik nagłówkowy biblioteki bitcoinconsensus.
78
79 %package static
80 Summary:        Static bitcoinconsensus library
81 Summary(pl.UTF-8):      Statyczna biblioteka bitcoinconsensus
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84 Conflicts:      bitcoin-static
85
86 %description static
87 Static bitcoinconsensus library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka bitcoinconsensus.
91
92 %package qt
93 Summary:        Qt-based Feathercoin Wallet
94 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
95 Group:          X11/Applications
96
97 %description qt
98 Qt-based Feathercoin Wallet.
99
100 %description qt -l pl.UTF-8
101 Oparty na Qt portfel Feathercoin.
102
103 %prep
104 %setup -q -n Feathercoin-%{version}
105 %patch0 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
114 %configure \
115         --enable-ccache%{!?with_ccache:=no} \
116         --disable-silent-rules \
117         --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
118         --with-incompatible-bdb \
119         --with-system-univalue
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 # obsoleted by pkg-config
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
131
132 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
133 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
134 [Desktop Entry]
135 Encoding=UTF-8
136 Name=Feathercoin
137 Comment=Feathercoin P2P Cryptocurrency
138 Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
139 Comment[pl]=Feathercoin - kryptowaluta P2P
140 Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
141 Exec=feathercoin-qt %u
142 Terminal=false
143 Type=Application
144 Icon=bitcoin128
145 MimeType=x-scheme-handler/feathercoin;
146 Categories=Office;Finance;
147 EOF
148
149 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
150 [Protocol]
151 exec=feathercoin-qt '%u'
152 protocol=feathercoin
153 input=none
154 output=none
155 helper=true
156 listing=
157 reading=false
158 writing=false
159 makedir=false
160 deleting=false
161 EOF
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc COPYING README.md doc/*.txt
172 %attr(755,root,root) %{_bindir}/feathercoin-cli
173 %attr(755,root,root) %{_bindir}/feathercoin-tx
174 %attr(755,root,root) %{_bindir}/feathercoind
175 %{_mandir}/man1/feathercoin-cli.1*
176 %{_mandir}/man1/feathercoin-tx.1*
177 %{_mandir}/man1/feathercoind.1*
178 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
184 %{_includedir}/bitcoinconsensus.h
185 %{_pkgconfigdir}/libbitcoinconsensus.pc
186
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libbitcoinconsensus.a
190
191 %files qt
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_bindir}/feathercoin-qt
194 %{_datadir}/kde4/services/feathercoin-qt.protocol
195 %{_desktopdir}/feathercoin-qt.desktop
196 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.049236 seconds and 2 git commands to generate.