]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
a2780e8f710d6eefec189f1e89256a2195a3373b
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.19.1
11 Release:        2
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  5af573e26b1fc7cb57ef5efc5dd88801
17 Patch0:         lib.patch
18 Patch1:         qt-5.15.patch
19 Patch2:         %{name}-includes.patch
20 Patch3:         %{name}-univalue.patch
21 URL:            https://www.feathercoin.com/
22 %if %{with gui}
23 BuildRequires:  Qt5Core-devel >= 5
24 BuildRequires:  Qt5DBus-devel >= 5
25 BuildRequires:  Qt5Gui-devel >= 5
26 BuildRequires:  Qt5Network-devel >= 5
27 BuildRequires:  Qt5PrintSupport-devel >= 5
28 BuildRequires:  Qt5Test-devel >= 5
29 BuildRequires:  Qt5Widgets-devel >= 5
30 %endif
31 BuildRequires:  autoconf >= 2.69
32 BuildRequires:  automake
33 BuildRequires:  boost-devel >= 1.47.0
34 %{?with_ccache:BuildRequires:   ccache}
35 BuildRequires:  db-cxx-devel >= 4.8
36 BuildRequires:  gettext-tools
37 BuildRequires:  libevent-devel
38 %{?with_gui:BuildRequires:      libpng-devel}
39 BuildRequires:  libsecp256k1-devel >= 0.1.0.15
40 BuildRequires:  libstdc++-devel >= 6:4.7
41 BuildRequires:  libtool >= 2:2
42 BuildRequires:  libunivalue-devel >= 1.0.4
43 BuildRequires:  miniupnpc-devel >= 1.5
44 BuildRequires:  openssl-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  protobuf-devel
47 BuildRequires:  python3 >= 1:3.5
48 BuildRequires:  qrencode-devel
49 %{?with_gui:BuildRequires:      qt5-build >= 5}
50 BuildRequires:  zeromq-devel >= 4
51 %{?with_gui:BuildRequires:      zlib-devel}
52 BuildRequires:  zxing-cpp-devel
53 Requires:       libsecp256k1 >= 0.1.0.15
54 Requires:       libunivalue >= 1.0.4
55 Requires:       perl-base
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 # uses nNeoScryptOptions symbol from binaries
59 %define         skip_post_check_so      libbitcoinconsensus.so.*
60
61 %description
62 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
63 central authority issues new money or tracks transactions. These tasks
64 are managed collectively by the network.
65
66 %description -l pl.UTF-8
67 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
68 centralnego urzędu, który emituje nowe pieniądze czy śledzi
69 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
70
71 %package devel
72 Summary:        Header file for bitcoinconsensus library
73 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bitcoinconsensus
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       openssl-devel
77 Conflicts:      bitcoin-devel
78
79 %description devel
80 Header file for bitcoinconsensus library.
81
82 %description devel -l pl.UTF-8
83 Plik nagłówkowy biblioteki bitcoinconsensus.
84
85 %package static
86 Summary:        Static bitcoinconsensus library
87 Summary(pl.UTF-8):      Statyczna biblioteka bitcoinconsensus
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Conflicts:      bitcoin-static
91
92 %description static
93 Static bitcoinconsensus library.
94
95 %description static -l pl.UTF-8
96 Statyczna biblioteka bitcoinconsensus.
97
98 %package qt
99 Summary:        Qt-based Feathercoin Wallet
100 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
101 Group:          X11/Applications
102
103 %description qt
104 Qt-based Feathercoin Wallet.
105
106 %description qt -l pl.UTF-8
107 Oparty na Qt portfel Feathercoin.
108
109 %prep
110 %setup -q -n Feathercoin-%{version}
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114 %patch3 -p1
115
116 %build
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
123 %configure \
124         --disable-bench \
125         --enable-bip70 \
126         --enable-ccache%{!?with_ccache:=no} \
127         --disable-gui-tests \
128         --disable-silent-rules \
129         --disable-tests \
130         --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
131         --with-incompatible-bdb \
132         --with-system-univalue
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 # obsoleted by pkg-config
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
144
145 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
146 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
147 [Desktop Entry]
148 Encoding=UTF-8
149 Name=Feathercoin
150 Comment=Feathercoin P2P Cryptocurrency
151 Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
152 Comment[pl]=Feathercoin - kryptowaluta P2P
153 Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
154 Exec=feathercoin-qt %u
155 Terminal=false
156 Type=Application
157 Icon=bitcoin128
158 MimeType=x-scheme-handler/feathercoin;
159 Categories=Office;Finance;
160 EOF
161
162 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
163 [Protocol]
164 exec=feathercoin-qt '%u'
165 protocol=feathercoin
166 input=none
167 output=none
168 helper=true
169 listing=
170 reading=false
171 writing=false
172 makedir=false
173 deleting=false
174 EOF
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc COPYING README.md doc/*.txt
185 %attr(755,root,root) %{_bindir}/feathercoin-cli
186 %attr(755,root,root) %{_bindir}/feathercoin-tx
187 %attr(755,root,root) %{_bindir}/feathercoin-wallet
188 %attr(755,root,root) %{_bindir}/feathercoind
189 %{_mandir}/man1/feathercoin-cli.1*
190 %{_mandir}/man1/feathercoin-tx.1*
191 %{_mandir}/man1/feathercoin-wallet.1*
192 %{_mandir}/man1/feathercoind.1*
193 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
199 %{_includedir}/bitcoinconsensus.h
200 %{_pkgconfigdir}/libbitcoinconsensus.pc
201
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/libbitcoinconsensus.a
205
206 %files qt
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/feathercoin-qt
209 %{_datadir}/kde4/services/feathercoin-qt.protocol
210 %{_desktopdir}/feathercoin-qt.desktop
211 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.079545 seconds and 2 git commands to generate.