]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
2033b18a04c838d13fd4442d994b598d1ca4c677
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.18.3
11 Release:        2
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  e5e3fc683a09ec7c2efc21dda691c402
17 Patch0:         lib.patch
18 Patch1:         qt-5.15.patch
19 Patch2:         %{name}-includes.patch
20 URL:            https://www.feathercoin.com/
21 %if %{with gui}
22 BuildRequires:  Qt5Core-devel >= 5
23 BuildRequires:  Qt5DBus-devel >= 5
24 BuildRequires:  Qt5Gui-devel >= 5
25 BuildRequires:  Qt5Network-devel >= 5
26 BuildRequires:  Qt5PrintSupport-devel >= 5
27 BuildRequires:  Qt5Test-devel >= 5
28 BuildRequires:  Qt5Widgets-devel >= 5
29 %endif
30 BuildRequires:  autoconf >= 2.69
31 BuildRequires:  automake
32 BuildRequires:  boost-devel >= 1.47.0
33 %{?with_ccache:BuildRequires:   ccache}
34 BuildRequires:  db-cxx-devel >= 4.8
35 BuildRequires:  gettext-tools
36 %{?with_gui:BuildRequires:      libpng-devel}
37 BuildRequires:  libsecp256k1-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:2
40 BuildRequires:  libunivalue-devel >= 1.0.4
41 BuildRequires:  miniupnpc-devel >= 1.5
42 BuildRequires:  openssl-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  protobuf-devel
45 BuildRequires:  qrencode-devel
46 %{?with_gui:BuildRequires:      qt5-build >= 5}
47 BuildRequires:  zeromq-devel >= 4
48 %{?with_gui:BuildRequires:      zlib-devel}
49 BuildRequires:  zxing-cpp-devel
50 Requires:       libunivalue >= 1.0.4
51 Requires:       perl-base
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 # uses nNeoScryptOptions symbol from binaries
55 %define         skip_post_check_so      libbitcoinconsensus.so.*
56
57 %description
58 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
59 central authority issues new money or tracks transactions. These tasks
60 are managed collectively by the network.
61
62 %description -l pl.UTF-8
63 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
64 centralnego urzędu, który emituje nowe pieniądze czy śledzi
65 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
66
67 %package devel
68 Summary:        Header file for bitcoinconsensus library
69 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bitcoinconsensus
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       openssl-devel
73 Conflicts:      bitcoin-devel
74
75 %description devel
76 Header file for bitcoinconsensus library.
77
78 %description devel -l pl.UTF-8
79 Plik nagłówkowy biblioteki bitcoinconsensus.
80
81 %package static
82 Summary:        Static bitcoinconsensus library
83 Summary(pl.UTF-8):      Statyczna biblioteka bitcoinconsensus
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Conflicts:      bitcoin-static
87
88 %description static
89 Static bitcoinconsensus library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka bitcoinconsensus.
93
94 %package qt
95 Summary:        Qt-based Feathercoin Wallet
96 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
97 Group:          X11/Applications
98
99 %description qt
100 Qt-based Feathercoin Wallet.
101
102 %description qt -l pl.UTF-8
103 Oparty na Qt portfel Feathercoin.
104
105 %prep
106 %setup -q -n Feathercoin-%{version}
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
118 %configure \
119         --enable-ccache%{!?with_ccache:=no} \
120         --disable-silent-rules \
121         --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
122         --with-incompatible-bdb \
123         --with-system-univalue
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 # obsoleted by pkg-config
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
135
136 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
137 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
138 [Desktop Entry]
139 Encoding=UTF-8
140 Name=Feathercoin
141 Comment=Feathercoin P2P Cryptocurrency
142 Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
143 Comment[pl]=Feathercoin - kryptowaluta P2P
144 Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
145 Exec=feathercoin-qt %u
146 Terminal=false
147 Type=Application
148 Icon=bitcoin128
149 MimeType=x-scheme-handler/feathercoin;
150 Categories=Office;Finance;
151 EOF
152
153 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
154 [Protocol]
155 exec=feathercoin-qt '%u'
156 protocol=feathercoin
157 input=none
158 output=none
159 helper=true
160 listing=
161 reading=false
162 writing=false
163 makedir=false
164 deleting=false
165 EOF
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc COPYING README.md doc/*.txt
176 %attr(755,root,root) %{_bindir}/feathercoin-cli
177 %attr(755,root,root) %{_bindir}/feathercoin-tx
178 %attr(755,root,root) %{_bindir}/feathercoin-wallet
179 %attr(755,root,root) %{_bindir}/feathercoind
180 %{_mandir}/man1/feathercoin-cli.1*
181 %{_mandir}/man1/feathercoin-tx.1*
182 %{_mandir}/man1/feathercoin-wallet.1*
183 %{_mandir}/man1/feathercoind.1*
184 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
190 %{_includedir}/bitcoinconsensus.h
191 %{_pkgconfigdir}/libbitcoinconsensus.pc
192
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/libbitcoinconsensus.a
196
197 %files qt
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/feathercoin-qt
200 %{_datadir}/kde4/services/feathercoin-qt.protocol
201 %{_desktopdir}/feathercoin-qt.desktop
202 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.07281 seconds and 2 git commands to generate.