]> git.pld-linux.org Git - packages/feathercoin.git/blame - feathercoin.spec
- release 4 (by relup.sh)
[packages/feathercoin.git] / feathercoin.spec
CommitLineData
d71863a9
JB
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
24d61d02
JB
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
0f77417f 9Name: feathercoin
d71863a9 10Version: 0.9.6
d0405d69 11Release: 4
d71863a9
JB
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16# Source0-md5: 9ac8509ab7bc7fb39b8e9d474a1079e3
17Patch0: %{name}-c++.patch
18Patch1: %{name}-zxing.patch
688b842e 19Patch2: x32.patch
24d61d02 20URL: https://www.feathercoin.com/
d71863a9
JB
21%if %{with gui}
22BuildRequires: Qt5Core-devel >= 5
23BuildRequires: Qt5DBus-devel >= 5
24BuildRequires: Qt5Gui-devel >= 5
25BuildRequires: Qt5Network-devel >= 5
26BuildRequires: Qt5PrintSupport-devel >= 5
27BuildRequires: Qt5Test-devel >= 5
28BuildRequires: Qt5Widgets-devel >= 5
29%endif
30BuildRequires: autoconf >= 2.69
31BuildRequires: automake
0f77417f 32BuildRequires: boost-devel
d71863a9
JB
33%{?with_ccache:BuildRequires: ccache}
34BuildRequires: db-cxx-devel >= 4.8
35BuildRequires: gettext-tools
36%{?with_gui:BuildRequires: libpng-devel}
37BuildRequires: libstdc++-devel
0f77417f
AM
38BuildRequires: miniupnpc-devel >= 1.5
39BuildRequires: openssl-devel
d71863a9
JB
40BuildRequires: pkgconfig
41BuildRequires: protobuf-devel
0f77417f 42BuildRequires: qrencode-devel
d71863a9
JB
43%{?with_gui:BuildRequires: qt5-build >= 5}
44BuildRequires: zxing-cpp-devel
45%{?with_gui:BuildRequires: zlib-devel}
0f77417f
AM
46Requires: perl-base
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
24d61d02
JB
50Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
51central authority issues new money or tracks transactions. These tasks
52are managed collectively by the network.
53
54%description -l pl.UTF-8
55Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
56centralnego urzędu, który emituje nowe pieniądze czy śledzi
57transakcje. Zadania te są obsługiwane zespołowo przez sieć.
0f77417f
AM
58
59%package qt
60Summary: Qt-based Feathercoin Wallet
24d61d02 61Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
0f77417f
AM
62Group: X11/Applications
63
64%description qt
65Qt-based Feathercoin Wallet.
66
24d61d02
JB
67%description qt -l pl.UTF-8
68Oparty na Qt portfel Feathercoin.
69
0f77417f 70%prep
d71863a9
JB
71%setup -q -n Feathercoin-%{version}
72%patch0 -p1
73%patch1 -p1
688b842e
JR
74%ifarch x32
75%patch2 -p1
76%endif
0f77417f
AM
77
78%build
d71863a9
JB
79install -d src/build-aux
80%{__aclocal} -I m4
81%{__autoconf}
82%{__autoheader}
83%{__automake}
84# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
85%configure \
86 --enable-ccache%{!?with_ccache:=no} \
87 --disable-silent-rules \
88 --with-incompatible-bdb \
89 --with-gui=%{?with_gui:qt5}%{!?with_gui:no}
0f77417f
AM
90
91%{__make}
92
0f77417f
AM
93%install
94rm -rf $RPM_BUILD_ROOT
0f77417f 95
d71863a9
JB
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
0f77417f 98
d71863a9
JB
99install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,5},%{_desktopdir},%{_datadir}/kde4/services}
100sed -e 's#bitcoin#feathercoin#g;s#Bitcoin#Feathercoin#g' contrib/debian/bitcoin-qt.desktop > $RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
0f77417f 101sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.protocol > $RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
d71863a9
JB
102cp -p contrib/debian/manpages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
103cp -p contrib/debian/manpages/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
0f77417f
AM
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(644,root,root,755)
d71863a9
JB
110%doc COPYING README.md doc/*.txt contrib/debian/examples/bitcoin.conf
111%attr(755,root,root) %{_bindir}/feathercoin-cli
0f77417f 112%attr(755,root,root) %{_bindir}/feathercoind
d71863a9
JB
113%attr(755,root,root) %{_bindir}/test_bitcoin
114%{_mandir}/man1/feathercoin-cli.1*
115%{_mandir}/man1/feathercoind.1*
116%{_mandir}/man5/feathercoin.conf.5*
0f77417f
AM
117
118%files qt
119%defattr(644,root,root,755)
120%attr(755,root,root) %{_bindir}/feathercoin-qt
d71863a9 121%attr(755,root,root) %{_bindir}/test_bitcoin-qt
0f77417f
AM
122%{_datadir}/kde4/services/feathercoin-qt.protocol
123%{_desktopdir}/feathercoin-qt.desktop
d71863a9 124%{_mandir}/man1/feathercoin-qt.1*
This page took 0.117918 seconds and 4 git commands to generate.