]> git.pld-linux.org Git - packages/feathercoin.git/blame - feathercoin.spec
- patch fix, release 3
[packages/feathercoin.git] / feathercoin.spec
CommitLineData
d71863a9
JB
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
24d61d02
JB
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
0f77417f 9Name: feathercoin
4e6b795e 10Version: 0.18.3
c4807f26 11Release: 3
d71863a9
JB
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
4e6b795e 16# Source0-md5: e5e3fc683a09ec7c2efc21dda691c402
d27150c9 17Patch0: lib.patch
4e6b795e 18Patch1: qt-5.15.patch
36f7f9aa 19Patch2: %{name}-includes.patch
24d61d02 20URL: https://www.feathercoin.com/
d71863a9
JB
21%if %{with gui}
22BuildRequires: Qt5Core-devel >= 5
23BuildRequires: Qt5DBus-devel >= 5
24BuildRequires: Qt5Gui-devel >= 5
25BuildRequires: Qt5Network-devel >= 5
26BuildRequires: Qt5PrintSupport-devel >= 5
27BuildRequires: Qt5Test-devel >= 5
28BuildRequires: Qt5Widgets-devel >= 5
29%endif
30BuildRequires: autoconf >= 2.69
31BuildRequires: automake
d5d03ba6 32BuildRequires: boost-devel >= 1.47.0
d71863a9
JB
33%{?with_ccache:BuildRequires: ccache}
34BuildRequires: db-cxx-devel >= 4.8
35BuildRequires: gettext-tools
36%{?with_gui:BuildRequires: libpng-devel}
d27150c9 37BuildRequires: libsecp256k1-devel
d71863a9 38BuildRequires: libstdc++-devel
d5d03ba6
JB
39BuildRequires: libtool >= 2:2
40BuildRequires: libunivalue-devel >= 1.0.4
0f77417f
AM
41BuildRequires: miniupnpc-devel >= 1.5
42BuildRequires: openssl-devel
d71863a9
JB
43BuildRequires: pkgconfig
44BuildRequires: protobuf-devel
0f77417f 45BuildRequires: qrencode-devel
d71863a9 46%{?with_gui:BuildRequires: qt5-build >= 5}
d5d03ba6 47BuildRequires: zeromq-devel >= 4
d71863a9 48%{?with_gui:BuildRequires: zlib-devel}
d27150c9 49BuildRequires: zxing-cpp-devel
d5d03ba6 50Requires: libunivalue >= 1.0.4
0f77417f
AM
51Requires: perl-base
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
d5d03ba6
JB
54# uses nNeoScryptOptions symbol from binaries
55%define skip_post_check_so libbitcoinconsensus.so.*
56
0f77417f 57%description
24d61d02
JB
58Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
59central authority issues new money or tracks transactions. These tasks
60are managed collectively by the network.
61
62%description -l pl.UTF-8
63Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
64centralnego urzędu, który emituje nowe pieniądze czy śledzi
65transakcje. Zadania te są obsługiwane zespołowo przez sieć.
0f77417f 66
f6a6bc9a
JB
67%package devel
68Summary: Header file for bitcoinconsensus library
69Summary(pl.UTF-8): Plik nagłówkowy biblioteki bitcoinconsensus
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: openssl-devel
73Conflicts: bitcoin-devel
74
75%description devel
76Header file for bitcoinconsensus library.
77
78%description devel -l pl.UTF-8
79Plik nagłówkowy biblioteki bitcoinconsensus.
80
81%package static
82Summary: Static bitcoinconsensus library
83Summary(pl.UTF-8): Statyczna biblioteka bitcoinconsensus
84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
86Conflicts: bitcoin-static
87
88%description static
89Static bitcoinconsensus library.
90
91%description static -l pl.UTF-8
92Statyczna biblioteka bitcoinconsensus.
93
0f77417f
AM
94%package qt
95Summary: Qt-based Feathercoin Wallet
24d61d02 96Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
0f77417f
AM
97Group: X11/Applications
98
99%description qt
100Qt-based Feathercoin Wallet.
101
24d61d02
JB
102%description qt -l pl.UTF-8
103Oparty na Qt portfel Feathercoin.
104
0f77417f 105%prep
d71863a9
JB
106%setup -q -n Feathercoin-%{version}
107%patch0 -p1
4e6b795e 108%patch1 -p1
36f7f9aa 109%patch2 -p1
0f77417f
AM
110
111%build
d27150c9
AM
112%{__libtoolize}
113%{__aclocal}
d71863a9
JB
114%{__autoconf}
115%{__autoheader}
116%{__automake}
117# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
118%configure \
119 --enable-ccache%{!?with_ccache:=no} \
120 --disable-silent-rules \
d27150c9 121 --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
f6a6bc9a 122 --with-incompatible-bdb \
d27150c9 123 --with-system-univalue
0f77417f
AM
124
125%{__make}
126
0f77417f
AM
127%install
128rm -rf $RPM_BUILD_ROOT
0f77417f 129
d71863a9
JB
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
0f77417f 132
f6a6bc9a
JB
133# obsoleted by pkg-config
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
135
136install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
d5d03ba6
JB
137cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
138[Desktop Entry]
139Encoding=UTF-8
140Name=Feathercoin
141Comment=Feathercoin P2P Cryptocurrency
142Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
143Comment[pl]=Feathercoin - kryptowaluta P2P
144Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
145Exec=feathercoin-qt %u
146Terminal=false
147Type=Application
148Icon=bitcoin128
149MimeType=x-scheme-handler/feathercoin;
150Categories=Office;Finance;
151EOF
152
153cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
154[Protocol]
155exec=feathercoin-qt '%u'
156protocol=feathercoin
157input=none
158output=none
159helper=true
160listing=
161reading=false
162writing=false
163makedir=false
164deleting=false
165EOF
0f77417f
AM
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
f6a6bc9a
JB
170%post -p /sbin/ldconfig
171%postun -p /sbin/ldconfig
d27150c9 172
0f77417f
AM
173%files
174%defattr(644,root,root,755)
d5d03ba6 175%doc COPYING README.md doc/*.txt
d71863a9 176%attr(755,root,root) %{_bindir}/feathercoin-cli
d27150c9 177%attr(755,root,root) %{_bindir}/feathercoin-tx
4e6b795e 178%attr(755,root,root) %{_bindir}/feathercoin-wallet
0f77417f 179%attr(755,root,root) %{_bindir}/feathercoind
d71863a9 180%{_mandir}/man1/feathercoin-cli.1*
d27150c9 181%{_mandir}/man1/feathercoin-tx.1*
4e6b795e 182%{_mandir}/man1/feathercoin-wallet.1*
d71863a9 183%{_mandir}/man1/feathercoind.1*
f6a6bc9a 184%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
d27150c9 185%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
f6a6bc9a
JB
186
187%files devel
188%defattr(644,root,root,755)
189%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
190%{_includedir}/bitcoinconsensus.h
191%{_pkgconfigdir}/libbitcoinconsensus.pc
192
193%files static
194%defattr(644,root,root,755)
195%{_libdir}/libbitcoinconsensus.a
0f77417f
AM
196
197%files qt
198%defattr(644,root,root,755)
199%attr(755,root,root) %{_bindir}/feathercoin-qt
200%{_datadir}/kde4/services/feathercoin-qt.protocol
201%{_desktopdir}/feathercoin-qt.desktop
d71863a9 202%{_mandir}/man1/feathercoin-qt.1*
This page took 0.14521 seconds and 4 git commands to generate.