]> git.pld-linux.org Git - packages/feathercoin.git/blame - feathercoin.spec
boost rebuild
[packages/feathercoin.git] / feathercoin.spec
CommitLineData
d71863a9
JB
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
24d61d02
JB
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
0f77417f 9Name: feathercoin
27aee4eb 10Version: 0.19.1
3de361ac 11Release: 3
d71863a9
JB
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
27aee4eb 16# Source0-md5: 5af573e26b1fc7cb57ef5efc5dd88801
d27150c9 17Patch0: lib.patch
4e6b795e 18Patch1: qt-5.15.patch
36f7f9aa 19Patch2: %{name}-includes.patch
27aee4eb 20Patch3: %{name}-univalue.patch
24d61d02 21URL: https://www.feathercoin.com/
d71863a9
JB
22%if %{with gui}
23BuildRequires: Qt5Core-devel >= 5
24BuildRequires: Qt5DBus-devel >= 5
25BuildRequires: Qt5Gui-devel >= 5
26BuildRequires: Qt5Network-devel >= 5
27BuildRequires: Qt5PrintSupport-devel >= 5
28BuildRequires: Qt5Test-devel >= 5
29BuildRequires: Qt5Widgets-devel >= 5
30%endif
31BuildRequires: autoconf >= 2.69
32BuildRequires: automake
d5d03ba6 33BuildRequires: boost-devel >= 1.47.0
d71863a9
JB
34%{?with_ccache:BuildRequires: ccache}
35BuildRequires: db-cxx-devel >= 4.8
36BuildRequires: gettext-tools
27aee4eb 37BuildRequires: libevent-devel
d71863a9 38%{?with_gui:BuildRequires: libpng-devel}
27aee4eb
JB
39BuildRequires: libsecp256k1-devel >= 0.1.0.15
40BuildRequires: libstdc++-devel >= 6:4.7
d5d03ba6
JB
41BuildRequires: libtool >= 2:2
42BuildRequires: libunivalue-devel >= 1.0.4
0f77417f
AM
43BuildRequires: miniupnpc-devel >= 1.5
44BuildRequires: openssl-devel
d71863a9
JB
45BuildRequires: pkgconfig
46BuildRequires: protobuf-devel
27aee4eb 47BuildRequires: python3 >= 1:3.5
0f77417f 48BuildRequires: qrencode-devel
d71863a9 49%{?with_gui:BuildRequires: qt5-build >= 5}
d5d03ba6 50BuildRequires: zeromq-devel >= 4
d71863a9 51%{?with_gui:BuildRequires: zlib-devel}
d27150c9 52BuildRequires: zxing-cpp-devel
27aee4eb 53Requires: libsecp256k1 >= 0.1.0.15
d5d03ba6 54Requires: libunivalue >= 1.0.4
0f77417f
AM
55Requires: perl-base
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
d5d03ba6
JB
58# uses nNeoScryptOptions symbol from binaries
59%define skip_post_check_so libbitcoinconsensus.so.*
60
0f77417f 61%description
24d61d02
JB
62Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
63central authority issues new money or tracks transactions. These tasks
64are managed collectively by the network.
65
66%description -l pl.UTF-8
67Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
68centralnego urzędu, który emituje nowe pieniądze czy śledzi
69transakcje. Zadania te są obsługiwane zespołowo przez sieć.
0f77417f 70
f6a6bc9a
JB
71%package devel
72Summary: Header file for bitcoinconsensus library
73Summary(pl.UTF-8): Plik nagłówkowy biblioteki bitcoinconsensus
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: openssl-devel
77Conflicts: bitcoin-devel
78
79%description devel
80Header file for bitcoinconsensus library.
81
82%description devel -l pl.UTF-8
83Plik nagłówkowy biblioteki bitcoinconsensus.
84
85%package static
86Summary: Static bitcoinconsensus library
87Summary(pl.UTF-8): Statyczna biblioteka bitcoinconsensus
88Group: Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90Conflicts: bitcoin-static
91
92%description static
93Static bitcoinconsensus library.
94
95%description static -l pl.UTF-8
96Statyczna biblioteka bitcoinconsensus.
97
0f77417f
AM
98%package qt
99Summary: Qt-based Feathercoin Wallet
24d61d02 100Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
0f77417f
AM
101Group: X11/Applications
102
103%description qt
104Qt-based Feathercoin Wallet.
105
24d61d02
JB
106%description qt -l pl.UTF-8
107Oparty na Qt portfel Feathercoin.
108
0f77417f 109%prep
d71863a9
JB
110%setup -q -n Feathercoin-%{version}
111%patch0 -p1
4e6b795e 112%patch1 -p1
36f7f9aa 113%patch2 -p1
27aee4eb 114%patch3 -p1
0f77417f
AM
115
116%build
d27150c9
AM
117%{__libtoolize}
118%{__aclocal}
d71863a9
JB
119%{__autoconf}
120%{__autoheader}
121%{__automake}
122# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
123%configure \
27aee4eb
JB
124 --disable-bench \
125 --enable-bip70 \
d71863a9 126 --enable-ccache%{!?with_ccache:=no} \
27aee4eb 127 --disable-gui-tests \
d71863a9 128 --disable-silent-rules \
27aee4eb 129 --disable-tests \
d27150c9 130 --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
f6a6bc9a 131 --with-incompatible-bdb \
d27150c9 132 --with-system-univalue
0f77417f
AM
133
134%{__make}
135
0f77417f
AM
136%install
137rm -rf $RPM_BUILD_ROOT
0f77417f 138
d71863a9
JB
139%{__make} install \
140 DESTDIR=$RPM_BUILD_ROOT
0f77417f 141
f6a6bc9a
JB
142# obsoleted by pkg-config
143%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
144
145install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
d5d03ba6
JB
146cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
147[Desktop Entry]
148Encoding=UTF-8
149Name=Feathercoin
150Comment=Feathercoin P2P Cryptocurrency
151Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
152Comment[pl]=Feathercoin - kryptowaluta P2P
153Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
154Exec=feathercoin-qt %u
155Terminal=false
156Type=Application
157Icon=bitcoin128
158MimeType=x-scheme-handler/feathercoin;
159Categories=Office;Finance;
160EOF
161
162cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
163[Protocol]
164exec=feathercoin-qt '%u'
165protocol=feathercoin
166input=none
167output=none
168helper=true
169listing=
170reading=false
171writing=false
172makedir=false
173deleting=false
174EOF
0f77417f
AM
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
f6a6bc9a
JB
179%post -p /sbin/ldconfig
180%postun -p /sbin/ldconfig
d27150c9 181
0f77417f
AM
182%files
183%defattr(644,root,root,755)
d5d03ba6 184%doc COPYING README.md doc/*.txt
d71863a9 185%attr(755,root,root) %{_bindir}/feathercoin-cli
d27150c9 186%attr(755,root,root) %{_bindir}/feathercoin-tx
4e6b795e 187%attr(755,root,root) %{_bindir}/feathercoin-wallet
0f77417f 188%attr(755,root,root) %{_bindir}/feathercoind
d71863a9 189%{_mandir}/man1/feathercoin-cli.1*
d27150c9 190%{_mandir}/man1/feathercoin-tx.1*
4e6b795e 191%{_mandir}/man1/feathercoin-wallet.1*
d71863a9 192%{_mandir}/man1/feathercoind.1*
f6a6bc9a 193%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
d27150c9 194%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
f6a6bc9a
JB
195
196%files devel
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
199%{_includedir}/bitcoinconsensus.h
200%{_pkgconfigdir}/libbitcoinconsensus.pc
201
202%files static
203%defattr(644,root,root,755)
204%{_libdir}/libbitcoinconsensus.a
0f77417f
AM
205
206%files qt
207%defattr(644,root,root,755)
208%attr(755,root,root) %{_bindir}/feathercoin-qt
209%{_datadir}/kde4/services/feathercoin-qt.protocol
210%{_desktopdir}/feathercoin-qt.desktop
d71863a9 211%{_mandir}/man1/feathercoin-qt.1*
This page took 0.062919 seconds and 4 git commands to generate.