]> git.pld-linux.org Git - packages/fdutils.git/commitdiff
- DESTDIR support
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 9 Feb 2008 16:41:54 +0000 (16:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fdutils-DESTDIR.patch -> 1.1

fdutils-DESTDIR.patch [new file with mode: 0644]

diff --git a/fdutils-DESTDIR.patch b/fdutils-DESTDIR.patch
new file mode 100644 (file)
index 0000000..7118488
--- /dev/null
@@ -0,0 +1,129 @@
+--- fdutils-5.5/doc/Makefile.in.orig   2008-02-09 15:25:18.520448000 +0100
++++ fdutils-5.5/doc/Makefile.in        2008-02-09 15:42:44.432051695 +0100
+@@ -79,51 +79,51 @@ Fdutils.texi: $(TEXISRC) texi-linearize
+ # Don't cd, to avoid breaking install-sh references.
+ install-info: info
+-      $(top_srcdir)/mkinstalldirs $(infodir)
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(infodir)
+       if test -f fdutils.info; then \
+         for i in fdutils.info*; do \
+-          $(INSTALL_DATA) $$i $(infodir)/$$i; \
++          $(INSTALL_DATA) $$i $(DESTDIR)$(infodir)/$$i; \
+         done; \
+       else \
+         for i in $(srcdir)/fdutils.info*; do \
+-          $(INSTALL_DATA) $$i $(infodir)/`echo $$i | sed 's|^$(srcdir)/||'`; \
++          $(INSTALL_DATA) $$i $(DESTDIR)$(infodir)/`echo $$i | sed 's|^$(srcdir)/||'`; \
+         done; \
+       fi; \
+       if [ -n "$(INSTALL_INFO)" ] ; then \
+-              if [ -f $(infodir)/dir.info ] ; then \
+-                      $(INSTALL_INFO) $(infodir)/fdutils.info $(infodir)/dir.info; \
++              if [ -f $(DESTDIR)$(infodir)/dir.info ] ; then \
++                      $(INSTALL_INFO) $(DESTDIR)$(infodir)/fdutils.info $(DESTDIR)$(infodir)/dir.info; \
+               fi; \
+               if [ -f $(infodir)/dir ] ; then \
+-                      $(INSTALL_INFO) $(infodir)/fdutils.info $(infodir)/dir; \
++                      $(INSTALL_INFO) $(DESTDIR)$(infodir)/fdutils.info $(DESTDIR)$(infodir)/dir; \
+               fi; \
+       fi
+ install-man:
+-      $(top_srcdir)/mkinstalldirs $(mandir1)
+-      $(top_srcdir)/mkinstalldirs $(mandir4)
+-      $(top_srcdir)/mkinstalldirs $(mandir8)
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir1)
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir4)
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir8)
+       for i in $(MANPAGES1); do \
+-              install -c -m $(MANPERM) -o $(UID) -g $(GID) \
+-                      $(srcdir)/$$i $(mandir1)/$$i; \
++              install -c -m $(MANPERM) \
++                      $(srcdir)/$$i $(DESTDIR)$(mandir1)/$$i; \
+       done
+       for i in $(MANPAGES4); do \
+-              install -c -m $(MANPERM) -o $(UID) -g $(GID) \
+-                      $(srcdir)/$$i $(mandir4)/$$i; \
++              install -c -m $(MANPERM) \
++                      $(srcdir)/$$i $(DESTDIR)$(mandir4)/$$i; \
+       done
+ #     for i in $(MANPAGES8); do \
+-#             install -c -m $(MANPERM) -o $(UID) -g $(GID) \
+-#                     $(srcdir)/$$i $(mandir8)/$$i; \
++#             install -c -m $(MANPERM) \
++#                     $(srcdir)/$$i $(DESTDIR)$(mandir8)/$$i; \
+ #     done
+-      ( cd $(mandir1); \
+-              ln -sf fdmount.1 $(mandir1)/fdumount.1; \
+-              ln -sf fdmount.1 $(mandir1)/fdlist.1; \
+-              ln -sf fdmount.1 $(mandir1)/fdmountd.1; \
+-              ln -sf xdfcopy.1 $(mandir1)/xdfformat.1 \
++      ( cd $(DESTDIR)$(mandir1); \
++              echo '.so fdmount.1' > fdumount.1; \
++              echo '.so fdmount.1' > fdlist.1; \
++              echo '.so fdmount.1' > fdmountd.1; \
++              echo '.so xdfcopy.1' > xdfformat.1 \
+       )
+ install-zman:
+--- fdutils-5.5/src/Makefile.in.orig   2002-11-21 08:23:06.000000000 +0100
++++ fdutils-5.5/src/Makefile.in        2008-02-09 15:43:41.115281887 +0100
+@@ -111,32 +111,29 @@ spotless:        clean
+       diskseek diskd_old setfdprm xdfcopy fdmount 2>/dev/null
+ install: install-bin install-conf
+-      @grep -q '^floppy:' /etc/group \
+-          || echo 'Add a group "floppy" to /etc/group.'
+ install-conf:
+-      $(top_srcdir)/mkinstalldirs $(syconfdir)
+-      if [ ! -f $(sysconfdir)/mediaprm ] ; then \
+-              cp $(srcdir)/mediaprm  $(sysconfdir) ; \
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(syconfdir)
++      if [ ! -f $(DESTDIR)$(sysconfdir)/mediaprm ] ; then \
++              cp $(srcdir)/mediaprm  $(DESTDIR)$(sysconfdir) ; \
+       fi
+ install-bin: all
+-      $(top_srcdir)/mkinstalldirs $(bindir)
+-      $(INSTALL) -c -m $(PERM) -o $(UID) -g $(GID) $(srcdir)/MAKEFLOPPIES $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) diskd $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) diskseekd $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) floppycontrol $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) floppymeter $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) getfdprm $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) setfdprm $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) fdrawcmd $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) superformat $(bindir)
+-      $(INSTALL) -c -s -m $(PERM) -o $(UID) -g $(GID) xdfcopy $(bindir)
+-      $(INSTALL) -c -s -m $(SPERM) -o $(UID) -g $(GID) fdmount $(bindir)
+-      $(INSTALL) -c -s -m $(SPERM) -o $(UID) -g $(GID) fdmount $(bindir)/fdumount
+-      ( cd $(bindir); \
+-      ln -sf xdfcopy $(bindir)/xdfformat; \
+-      ln -sf fdmount $(bindir)/fdumount; \
+-      ln -sf fdmount $(bindir)/fdlist; \
+-      ln -sf fdmount $(bindir)/fdmountd )
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) $(srcdir)/MAKEFLOPPIES $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) diskd $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) diskseekd $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) floppycontrol $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) floppymeter $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) getfdprm $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) setfdprm $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) fdrawcmd $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) superformat $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) xdfcopy $(DESTDIR)$(bindir)
++      $(INSTALL) -c -m $(PERM) fdmount $(DESTDIR)$(bindir)
++      ( cd $(DESTDIR)$(bindir); \
++      ln -sf xdfcopy xdfformat; \
++      ln -sf fdmount fdumount; \
++      ln -sf fdmount fdlist; \
++      ln -sf fdmount fdmountd )
This page took 0.083552 seconds and 4 git commands to generate.