]> git.pld-linux.org Git - packages/fcpci.git/blob - fcpci.spec
- spec renamed to fcpci.spec
[packages/fcpci.git] / fcpci.spec
1 #
2 # SMP will proably *never* work.
3 #
4 # Conditional build:
5 %bcond_without  dist_kernel     # allow non-distribution kernel
6 %bcond_without  kernel          # don't build kernel modules
7 %bcond_without  userspace       # don't build userspace programs
8 %bcond_with     verbose         # verbose build (V=1)
9 #
10 %if !%{with kernel}
11 %undefine       with_dist_kernel
12 %endif
13 %define         sub_ver 07
14 %define         _rel    0.2
15 Summary:        CAPI 2.0 driver of the AVM FRITZ! controller (ISDN TA)
16 Summary(pl.UTF-8):      Sterownik CAPI 2.0 do kontrolera AVM FRITZ! (ISDN TA)
17 Name:           fcpci
18 Version:        3.11
19 Release:        %{_rel}
20 Epoch:          0
21 License:        Proprietary (non-distributable) with LGPL v2.1+ part
22 Group:          Base/Kernel
23 Source0:        ftp://ftp.avm.de/cardware/fritzcrd.pci/linux/suse.93/%{name}-suse93-%{version}-%{sub_ver}.tar.gz
24 # NoSource0-md5:        3ee301b5d0e8df9e4b915af58b725556
25 # to be done:
26 #Source1:       http://www.quiss.org/caiviar/Two-Fritzcards-HOWTO
27 # Source1-md5:  -
28 NoSource:       0
29 Patch0:         %{name}-Makefile.patch
30 URL:            http://www.avm.de/de/Produkte/FRITZCard/
31 %if %{with kernel}
32 %{?with_dist_kernel:BuildRequires:      kernel-module-build >= 3:2.6.7}
33 BuildRequires:  rpmbuild(macros) >= 1.217
34 %endif
35 ExclusiveArch:  %{ix86}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This is the package "CAPI4Linux" for AVM FRITZ! controlers. In package
40 you will find following components:
41 - CAPI 2.0 driver of the controller
42 - CAPI 2.0 plug-in for the Generic PPP-Stack "pppd" (missing)
43
44 This package could attend two controlers simultaneously.
45
46 %description -l pl.UTF-8
47 Ten pakiet zawiera CAPI4Linux dla kontrolerów AVM FRITRZ!. W pakiecie
48 znajdują się:
49 - Sterownik CAPI 2.0
50 - Wtyczka CAPI 2.0 dla pppd (brakująca)
51
52 Ten pakiet może obsługiwać dwa kontrolery jednocześnie.
53
54 %package -n kernel%{_alt_kernel}-isdn-fcpci
55 Summary:        Linux driver for fcpci
56 Summary(pl.UTF-8):      Sterownik dla Linuksa do fcpci
57 Release:        %{_rel}@%{_kernel_ver_str}
58 Group:          Base/Kernel
59 Requires(post,postun):  /sbin/depmod
60 %if %{with dist_kernel}
61 %requires_releq_kernel
62 Requires(postun):       %releq_kernel
63 %endif
64
65 %description -n kernel%{_alt_kernel}-isdn-fcpci
66 This is driver for fcpci for Linux.
67
68 This package contains Linux kernel module.
69
70 %description -n kernel%{_alt_kernel}-isdn-fcpci -l pl.UTF-8
71 Sterownik dla Linuksa do fcpci.
72
73 Ten pakiet zawiera moduł jądra Linuksa.
74
75 %prep
76 %setup -q -n fritz
77 %patch0 -p1
78
79 %build
80 %if %{with kernel}
81 %build_kernel_modules -m fcpci{1,2}
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with kernel}
88 %install_kernel_modules -m fcpci{1,2} -d isdn/hardware
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -n kernel%{_alt_kernel}-isdn-fcpci
95 %depmod %{_kernel_ver}
96
97 %postun -n kernel%{_alt_kernel}-isdn-fcpci
98 %depmod %{_kernel_ver}
99
100 %if %{with kernel}
101 %files -n kernel%{_alt_kernel}-isdn-fcpci
102 %defattr(644,root,root,755)
103 %doc CAPI20_Errormessages.txt license.txt *.html
104 /lib/modules/%{_kernel_ver}/isdn/hardware/*.ko*
105 %endif
This page took 0.104366 seconds and 4 git commands to generate.