]> git.pld-linux.org Git - packages/fcgi.git/blob - fcgi.spec
- allow larger listen() backlog
[packages/fcgi.git] / fcgi.spec
1 Summary:        FastCGI development kit - shared libraries
2 Summary(pl):    Zestaw dla programistów FastCGI - biblioteki wspó³dzielone
3 Name:           fcgi
4 Version:        2.4.0
5 Release:        1
6 License:        distributable
7 Group:          Libraries
8 Source0:        http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  d15060a813b91383a9f3c66faf84867e
10 Patch0:         %{name}-no-libs.patch
11 URL:            http://www.fastcgi.com/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool >= 2:1.4d-3
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _includedir     %{_prefix}/include/fastcgi
18
19 %description
20 FastCGI is an open extension to CGI that provides high performance for
21 all Internet applications without the penalties of Web server APIs.
22
23 FastCGI is designed to be layered on top of existing Web server APIs.
24 For instance, the mod_fastcgi Apache module adds FastCGI support to
25 the Apache server. FastCGI can also be used, with reduced
26 functionality and reduced performance, on any Web server that supports
27 CGI.
28
29 This FastCGI Developer's Kit is designed to make developing FastCGI
30 applications easy. The kit currently supports FastCGI applications
31 written in C/C++, Perl, Tcl, and Java.
32
33 This package contains only shared libraries used by programs developed
34 using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
35 FastCGI).
36
37 %description -l pl
38 FastCGI to otwarte rozszerzenie CGI daj±ce wysok± wydajno¶æ dla
39 wszystkich aplikacjach internetowych bez obci±¿ania API serwera WWW.
40
41 FastCGI zosta³ zaprojektowany "na wierzchu" istniej±cych API serwerów.
42 Na przyk³ad, modu³ Apache mod_fastcgi dodaje obs³ugê FastCGI do serwera
43 Apache. FastCGI mo¿e byæ u¿ywany, ze zmniejszon± funkcjonalno¶ci±
44 i wydajno¶ci±, z dowolnym serwerem obs³uguj±cym CGI.
45
46 Zestaw Programisty FastCGI jest tak zaprojektowany, by uczyniæ ³atwym
47 tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
48 FastCGI w C/C++, Perlu, Tcl i Javie.
49
50 Ten pakiet zawiera tylko biblioteki wspó³dzielone u¿ywane przez programy
51 stworzone przy u¿yciu FastCGI developer's Kit oraz program cgi-fcgi
52 (bramkê pomiêdzy CGI a FastCGI).
53
54 %package devel
55 Summary:        FastCGI development kit
56 Summary(pl):    Zestaw dla programistów FastCGI
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Obsoletes:      fastcgi-devkit
60
61 %description devel
62 This package contains FastCGI Developer's Kit, which is designed to
63 make developing FastCGI applications easy. The kit currently supports
64 FastCGI applications written in C/C++, Perl, Tcl, and Java.
65
66 %description devel -l pl
67 Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
68 zaprojektowany, by uczyniæ ³atwym tworzenie aplikacji FastCGI.
69 Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
70 Javie.
71
72 %package static
73 Summary:        FastCGI static library
74 Summary(pl):    Statyczna biblioteka FastCGI
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 FastCGI static library.
80
81 %description static -l pl
82 Statyczna biblioteka FastCGI.
83
84 %prep
85 %setup -q
86 %patch -p1
87
88 %build
89 # supplied libtool is broken (relink, C++)
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --with-global \
96         --with-nodebug \
97         --with-noassert \
98         --with-notest
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc README LICENSE.TERMS doc/*.1
120 %attr(755,root,root) %{_bindir}/*
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3
126 %attr(755,root,root) %{_libdir}/lib*.so
127 %{_libdir}/lib*.la
128 %{_includedir}
129 %{_examplesdir}/fastcgi
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/lib*.a
This page took 0.063785 seconds and 3 git commands to generate.