]> git.pld-linux.org Git - packages/fcgi.git/blob - fcgi.spec
cf7cff8d1ded2de63214cf722eb3f8d616c87261
[packages/fcgi.git] / fcgi.spec
1 Summary:        FastCGI development kit - shared libraries
2 Summary(pl):    Zestaw dla programistów FastCGI - biblioteki wspó³dzielone
3 Name:           fcgi
4 Version:        2.4.0
5 Release:        1
6 License:        distributable
7 Group:          Libraries
8 Source0:        http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-no-libs.patch
10 URL:            http://www.fastcgi.com/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool >= 2:1.4d-3
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _includedir     %{_prefix}/include/fastcgi
17
18 %description
19 FastCGI is an open extension to CGI that provides high performance for
20 all Internet applications without the penalties of Web server APIs.
21
22 FastCGI is designed to be layered on top of existing Web server APIs.
23 For instance, the mod_fastcgi Apache module adds FastCGI support to
24 the Apache server. FastCGI can also be used, with reduced
25 functionality and reduced performance, on any Web server that supports
26 CGI.
27
28 This FastCGI Developer's Kit is designed to make developing FastCGI
29 applications easy. The kit currently supports FastCGI applications
30 written in C/C++, Perl, Tcl, and Java.
31
32 This package contains only shared libraries used by programs developed
33 using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
34 FastCGI).
35
36 %description -l pl
37 FastCGI to otwarte rozszerzenie CGI daj±ce wysok± wydajno¶æ dla
38 wszystkich aplikacjach internetowych bez obci±¿ania API serwera WWW.
39
40 FastCGI zosta³ zaprojektowany "na wierzchu" instniej±cych API
41 serwerów. Na przyk³ad, modu³ Apache mod_fastcgi dodaje obs³ugê FastCGI
42 do serwera Apache. FastCGI mo¿e byæ u¿ywany, ze zmniejszon±
43 funkcjonalno¶ci± i wydajno¶ci±, z dowolnym serwerem obs³uguj±cym CGI.
44
45 Zestaw Programisty FastCGI jest tak zaprojektowany, by uczyniæ ³atwym
46 tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
47 FastCGI w C/C++, Perlu, Tcl i Javie.
48
49 Ten pakiet zawiera tylko biblioteki wspó³dzielone u¿ywane przez
50 programy stworzone przy u¿yciu FastCGI developer's Kit oraz program
51 cgi-fcgi (bramkê pomiêdzy CGI a FastCGI).
52
53 %package devel
54 Summary:        FastCGI development kit
55 Summary(pl):    Zestaw dla programistów FastCGI
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}
58 Obsoletes:      fastcgi-devkit
59 Provides:       fastcgi-devkit = %{version}
60
61 %description devel
62 This package contains FastCGI Developer's Kit, which is designed to
63 make developing FastCGI applications easy. The kit currently supports
64 FastCGI applications written in C/C++, Perl, Tcl, and Java.
65
66 %description devel -l pl
67 Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
68 zaprojektowany, by uczyniæ ³atwym tworzenie aplikacji FastCGI.
69 Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
70 Javie.
71
72 %package static
73 Summary:        FastCGI static library
74 Summary(pl):    Statyczna biblioteka FastCGI
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}
77
78 %description static
79 FastCGI static library.
80
81 %description static -l pl
82 Statyczna biblioteka FastCGI.
83
84 %prep
85 %setup -q
86 %patch -p1
87
88 %build
89 # supplied libtool is broken (relink, C++)
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --with-global \
96         --with-nodebug \
97         --with-noassert \
98         --with-notest
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc README LICENSE.TERMS doc/*.1
120 %attr(755,root,root) %{_bindir}/*
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3
126 %attr(755,root,root) %{_libdir}/lib*.so
127 %{_libdir}/lib*.la
128 %{_includedir}
129 %{_examplesdir}/fastcgi
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/lib*.a
This page took 0.175626 seconds and 2 git commands to generate.