]> git.pld-linux.org Git - packages/fcgi.git/blob - fcgi.spec
72163aca4f2f4a41023985ae7129d8f867ccaa4c
[packages/fcgi.git] / fcgi.spec
1 Summary:        FastCGI development kit - shared libraries
2 Summary(pl.UTF-8):      Zestaw dla programistów FastCGI - biblioteki współdzielone
3 Name:           fcgi
4 Version:        2.4.0
5 Release:        3
6 License:        distributable
7 Group:          Libraries
8 Source0:        http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  d15060a813b91383a9f3c66faf84867e
10 Patch0:         %{name}-no-libs.patch
11 Patch1:         %{name}-listen-backlog.patch
12 Patch2:         %{name}-includes.patch
13 URL:            http://www.fastcgi.com/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool >= 2:1.4d-3
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _includedir     %{_prefix}/include/fastcgi
20
21 %description
22 FastCGI is an open extension to CGI that provides high performance for
23 all Internet applications without the penalties of Web server APIs.
24
25 FastCGI is designed to be layered on top of existing Web server APIs.
26 For instance, the mod_fastcgi Apache module adds FastCGI support to
27 the Apache server. FastCGI can also be used, with reduced
28 functionality and reduced performance, on any Web server that supports
29 CGI.
30
31 This FastCGI Developer's Kit is designed to make developing FastCGI
32 applications easy. The kit currently supports FastCGI applications
33 written in C/C++, Perl, Tcl, and Java.
34
35 This package contains only shared libraries used by programs developed
36 using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
37 FastCGI).
38
39 %description -l pl.UTF-8
40 FastCGI to otwarte rozszerzenie CGI dające wysoką wydajność dla
41 wszystkich aplikacjach internetowych bez obciążania API serwera WWW.
42
43 FastCGI został zaprojektowany "na wierzchu" istniejących API serwerów.
44 Na przykład, moduł Apache mod_fastcgi dodaje obsługę FastCGI do serwera
45 Apache. FastCGI może być używany, ze zmniejszoną funkcjonalnością
46 i wydajnością, z dowolnym serwerem obsługującym CGI.
47
48 Zestaw Programisty FastCGI jest tak zaprojektowany, by uczynić łatwym
49 tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
50 FastCGI w C/C++, Perlu, Tcl i Javie.
51
52 Ten pakiet zawiera tylko biblioteki współdzielone używane przez programy
53 stworzone przy użyciu FastCGI developer's Kit oraz program cgi-fcgi
54 (bramkę pomiędzy CGI a FastCGI).
55
56 %package devel
57 Summary:        FastCGI development kit
58 Summary(pl.UTF-8):      Zestaw dla programistów FastCGI
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Obsoletes:      fastcgi-devkit
62
63 %description devel
64 This package contains FastCGI Developer's Kit, which is designed to
65 make developing FastCGI applications easy. The kit currently supports
66 FastCGI applications written in C/C++, Perl, Tcl, and Java.
67
68 %description devel -l pl.UTF-8
69 Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
70 zaprojektowany, by uczynić łatwym tworzenie aplikacji FastCGI.
71 Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
72 Javie.
73
74 %package static
75 Summary:        FastCGI static library
76 Summary(pl.UTF-8):      Statyczna biblioteka FastCGI
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 FastCGI static library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka FastCGI.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 %build
93 # supplied libtool is broken (relink, C++)
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__automake}
98
99 CPPFLAGS="-DLISTEN_BACKLOG=1024"
100 %configure \
101         --with-global \
102         --with-noassert \
103         --with-nodebug \
104         --with-notest
105
106 # parallel build broken: library is searched before it's built
107 %{__make} -j1
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc README LICENSE.TERMS doc/*.1
127 %attr(755,root,root) %{_bindir}/cgi-fcgi
128 %attr(755,root,root) %{_libdir}/libfcgi.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libfcgi.so.0
130 %attr(755,root,root) %{_libdir}/libfcgi++.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libfcgi++.so.0
132
133 %files devel
134 %defattr(644,root,root,755)
135 %doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3
136 %attr(755,root,root) %{_libdir}/libfcgi.so
137 %attr(755,root,root) %{_libdir}/libfcgi++.so
138 %{_libdir}/libfcgi.la
139 %{_libdir}/libfcgi++.la
140 %{_includedir}
141 %{_examplesdir}/%{name}-%{version}
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libfcgi.a
146 %{_libdir}/libfcgi++.a
This page took 0.049798 seconds and 2 git commands to generate.