]> git.pld-linux.org Git - packages/fcgi.git/blob - fcgi.spec
- new %%doc
[packages/fcgi.git] / fcgi.spec
1 Summary:        FastCGI development kit - shared libraries
2 Summary(pl):    Zestaw dla programistów FastCGI - biblioteki wspó³dzielone
3 Name:           fcgi
4 Version:        2.2.2
5 Release:        1
6 License:        distributable
7 Group:          Libraries
8 Source0:        http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-no-libs.patch
10 URL:            http://www.fastcgi.com/
11 BuildRequires:  autoconf
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         _includedir     %{_prefix}/include/fastcgi
15
16 %description
17 FastCGI is an open extension to CGI that provides high performance for
18 all Internet applications without the penalties of Web server APIs.
19
20 FastCGI is designed to be layered on top of existing Web server APIs.
21 For instance, the mod_fastcgi Apache module adds FastCGI support to
22 the Apache server. FastCGI can also be used, with reduced
23 functionality and reduced performance, on any Web server that supports
24 CGI.
25
26 This FastCGI Developer's Kit is designed to make developing FastCGI
27 applications easy. The kit currently supports FastCGI applications
28 written in C/C++, Perl, Tcl, and Java.
29
30 This package contains only shared libraries used by programs developed
31 using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
32 FastCGI).
33
34 %description -l pl
35 FastCGI to otwarte rozszerzenie CGI daj±ce wysok± wydajno¶æ dla
36 wszystkich aplikacjach internetowych bez obci±¿ania API serwera WWW.
37
38 FastCGI zosta³ zaprojektowany "na wierzchu" instniej±cych API
39 serwerów. Na przyk³ad, modu³ Apache mod_fastcgi dodaje obs³ugê FastCGI
40 do serwera Apache. FastCGI mo¿e byæ u¿ywany, ze zmniejszon±
41 funkcjonalno¶ci± i wydajno¶ci±, z dowolnym serwerem obs³uguj±cym CGI.
42
43 Zestaw Programisty FastCGI jest tak zaprojektowany, by uczyniæ ³atwym
44 tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
45 FastCGI w C/C++, Perlu, Tcl i Javie.
46
47 Ten pakiet zawiera tylko biblioteki wspó³dzielone u¿ywane przez
48 programy stworzone przy u¿yciu FastCGI developer's Kit oraz program
49 cgi-fcgi (bramkê pomiêdzy CGI a FastCGI).
50
51 %package devel
52 Summary:        FastCGI development kit
53 Summary(pl):    Zestaw dla programistów FastCGI
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}
56 Obsoletes:      fastcgi-devkit
57 Provides:       fastcgi-devkit = %{version}
58
59 %description devel
60 This package contains FastCGI Developer's Kit, which is designed to
61 make developing FastCGI applications easy. The kit currently supports
62 FastCGI applications written in C/C++, Perl, Tcl, and Java.
63
64 %description devel -l pl
65 Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
66 zaprojektowany, by uczyniæ ³atwym tworzenie aplikacji FastCGI.
67 Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
68 Javie.
69
70 %package static
71 Summary:        FastCGI static library
72 Summary(pl):    Statyczna biblioteka FastCGI
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}
75
76 %description static
77 FastCGI static library.
78
79 %description static -l pl
80 Statyczna biblioteka FastCGI.
81
82 %prep
83 %setup -q
84 %patch -p1
85
86 %build
87 %{__autoconf}
88 %configure \
89         --with-global \
90         --with-nodebug \
91         --with-noassert \
92         --with-notest
93
94 %{__make}
95
96 # avoid relinking
97 cd libfcgi
98 sed -e '/^relink_command.*/d' libfcgi++.la > libfcgi++.la.tmp
99 mv -f libfcgi++.la.tmp libfcgi++.la
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/fastcgi
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README LICENSE.TERMS doc/*.1
119 %attr(755,root,root) %{_bindir}/*
120 %attr(755,root,root) %{_libdir}/lib*.so.*.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3
125 %attr(755,root,root) %{_libdir}/lib*.so
126 %{_libdir}/lib*.la
127 %{_includedir}
128 %{_examplesdir}/fastcgi
129
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/lib*.a
This page took 0.082245 seconds and 3 git commands to generate.